Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
darksied
Hangin' Around


Joined: Jan 27, 2004
Posts: 25
Location: New Jersey

PostPosted: Wed Aug 04, 2004 3:31 pm Reply with quote

i have installed sentinel final on a PHPNuke 6.9 system but when i disabled the site all i have is a blank page when i do the same install on a PHPnuke 7.4 Patched sysem i actually see the site disabled sentinel logo. below is the header.php from my 6.9 Nuke when i do a compare in bbedit 7.1.4 i only see one difference. which is below can some one help me on this issue everthing else works.

This is my header.php file
Code:
<?php


/************************************************************************/
/* PHP-NUKE: Advanced Content Management System                         */
/* ============================================                         */
/*                                                                      */
/* Copyright (c) 2002 by Francisco Burzi                                */
/* http://phpnuke.org                                                   */
/*                                                                      */
/* This program is free software. You can redistribute it and/or modify */
/* it under the terms of the GNU General Public License as published by */
/* the Free Software Foundation; either version 2 of the License.       */
/************************************************************************/

if (eregi("header.php",$_SERVER['PHP_SELF'])) {
    Header("Location: index.php");
    die();
}

require_once("mainfile.php");

##################################################
# Include some common header for HTML generation #
##################################################

$header = 1;

function head() {
    global $ab_config, $slogan, $sitename, $banners, $nukeurl, $Version_Num, $artpage, $topic, $hlpfile, $user, $hr, $theme, $cookie, $bgcolor1, $bgcolor2, $bgcolor3, $bgcolor4, $textcolor1, $textcolor2, $forumpage, $adminpage, $userpage, $pagetitle;
    $ThemeSel = get_theme();
    include("themes/$ThemeSel/theme.php");
    echo "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">\n";
    echo "<html>\n";
    echo "<head>\n";
    echo "<title>$sitename $pagetitle</title>\n";
   /*START BAN SYSTEM*/
   include("includes/blocker.php");
   /*STOP BAN SYSTEM*/
    include("includes/meta.php");
    include("includes/javascript.php");
   
    if (file_exists("themes/$ThemeSel/images/favicon.ico")) {
   echo "<link REL=\"shortcut icon\" HREF=\"themes/$ThemeSel/images/favicon.ico\" TYPE=\"image/x-icon\">\n";
    }
       
    echo "<LINK REL=\"StyleSheet\" HREF=\"themes/$ThemeSel/style/style.css\" TYPE=\"text/css\">\n\n\n";
    include("includes/my_header.php");
    echo "\n\n\n</head>\n\n";
    if($ab_config['site_switch'] == 1) {
      echo "<center><img src='images/sentinel/disabled.png' border='0' width='200' height='20'></center><br />\n";
    }
    themeheader();
}

online();
head();
include("includes/counter.php");
global $home;
if ($home == 1) {
    message_box();
    blocks(Center);
}

?>


This is what is different in the header.php on my PHPNuke 7.4 patched ver.

if (eregi("header.php", $_SERVER['SCRIPT_NAME'])) {
Code:


and if so would changing it help or not thanks in advanced for any and all help.

Image
 
View user's profile Send private message Visit poster's website AIM Address
chatserv
Member Emeritus


Joined: May 02, 2003
Posts: 1389
Location: Puerto Rico

PostPosted: Wed Aug 04, 2004 4:03 pm Reply with quote

It shouldn't make a difference but i can tell your 6.9 site is not patched as its patch also uses script_name.
 
View user's profile Send private message Visit poster's website
darksied
PostPosted: Wed Aug 04, 2004 4:29 pm Reply with quote

should have mentioned that the blank screen only shows up when tring to view closed down site from another matchine not the one i am currently logged in on.

sorry chatserv but you lost me could you elaborate a little more thanks.
 
darksied
PostPosted: Wed Aug 04, 2004 5:35 pm Reply with quote

I found the problem i updated my 6.9 site to chatserv patched 2.5 files and now the closed site function works properly.
 
chatserv
PostPosted: Wed Aug 04, 2004 5:38 pm Reply with quote

Wink
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©