Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
kenspa
Hangin' Around



Joined: Sep 24, 2005
Posts: 48
Location: Spain

PostPosted: Sat Feb 01, 2014 4:00 pm Reply with quote

Hi all,
I'm getting the following error after a fresh install v 2.5.1

Fatal error: Call to undefined function: date_default_timezone_set() in mainfile.php on line 124

any help will be much appreciated.
Thanks Rolling Eyes
 
View user's profile Send private message
nuken
RavenNuke(tm) Development Team



Joined: Mar 11, 2007
Posts: 2024
Location: North Carolina

PostPosted: Sat Feb 01, 2014 4:36 pm Reply with quote

What version of PHP are you running on your server?

_________________
Tricked Out News 
View user's profile Send private message Send e-mail Visit poster's website
nuken







PostPosted: Sat Feb 01, 2014 4:54 pm Reply with quote

That is a php function introduced in php 5.1.2. The minimum version of php for Ravennuke is 5.2+. If you are running a correct version, your host has it disabled in the php.ini file.
 
kenspa







PostPosted: Sat Feb 01, 2014 9:07 pm Reply with quote

Thank you nuken. I didn't know the versión running on the server, but just found it. I'm using 4.4.9!! I can move up to 5.3 but not sure since I have a prodution site with older versión of raven nuke and the change could clash with that old versión??!! I've got to choose I think!! Many thanks
 
montego
Site Admin



Joined: Aug 29, 2004
Posts: 9457
Location: Arizona

PostPosted: Sun Feb 02, 2014 9:12 am Reply with quote

kenspa, Raven was able to host both PHP4 and PHP5 for a measure of time awhile back. Might be worth asking your host if that is possible with them for a bit. Although, I would highly recommend upgrading your older RN versions as each version came with security fixes. Wink

_________________
Where Do YOU Stand?
HTML Newsletter::ShortLinks::Mailer::Downloads and more... 
View user's profile Send private message Visit poster's website
kenspa







PostPosted: Sun Feb 02, 2014 5:35 pm Reply with quote

Hey Montego!! it's been a while, nice to talk to you again Smile !!!
Well, I found a way to this, simply installed this versión a couple of hours ago on a different server which, as nuken pointed, is php5+ and it worked like a charm!!
I should say THIS IS AN AWESOME SOFTWARE version, I'd love to be able to get my old modules work with this!!
I will give all possible time to hack those necessary mods for me and bring them to this new version. BTW, does the approve member lite work with this?
Thanks a lot for all your support. Smile
 
nuken







PostPosted: Mon Feb 03, 2014 8:54 am Reply with quote

What features of Approved Membership do you need? The reason I ask is that there are many of those features already added into Your Account under the Edit Users admin link.
 
kenspa







PostPosted: Tue Feb 04, 2014 3:13 am Reply with quote

Thank you so much nuken for your reply. What I wanted from the Approve members was adding one or two customized fields and the approve part, and I found this versión doing all of it and more.. Embarassed
The only thing at the moment is the nukeWYSIWYG_3_6_3_1! I downloaded it and it displays perfect but when clicking on the "see server" button to upload an image file, the whole screen freezes at that point. I will double check the instructions and see if I missed anything.
I will dedicate much more time to see all the other functions if any would report an error. This software has unexpectedly improved a lot!!

Thanks again for your help Wink
 
Raven
Site Admin/Owner



Joined: Aug 27, 2002
Posts: 17087

PostPosted: Thu Feb 06, 2014 6:40 pm Reply with quote

Kenspa,

montego wrote:
kenspa, Raven was able to host both PHP4 and PHP5 for a measure of time awhile back. Might be worth asking your host if that is possible with them for a bit. Although, I would highly recommend upgrading your older RN versions as each version came with security fixes. Wink


They can easily co-exist Smile . Just have your HOST install the versions according to installation instructions easily Google'd Wink . Basically, your virtual-hosts setup in Apache can be unique for each client if you want.
 
View user's profile Send private message
kenspa







PostPosted: Sat Feb 08, 2014 7:52 am Reply with quote

Thank you so much raven!
I found a quick way to handle this, at the moment, on a different server and different domain which has php 5+ installed. I will take your advice to ask my host so.

I admit I should update and upgrade to the current versions in all the sites, and this will take some pretty time to clean up my ideas coming from the start of NUKE..

RavensScripts

BTW, search thread in your forum is giving me this error:

Quote:
Could not delete old search id sessions

DEBUG MODE

SQL Error : 145 Table './ravenmar_rps/nuke_bbsearch_results' is marked as crashed and should be repaired

DELETE FROM nuke_bbsearch_results WHERE search_time < 1391863245

Line : 669
File : search.php
 
Raven







PostPosted: Sat Feb 08, 2014 3:47 pm Reply with quote

That error should be fixed Wink , Thanks!
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©