Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
gator81
Worker
Worker



Joined: Jun 09, 2007
Posts: 172

PostPosted: Thu Aug 23, 2012 1:06 am Reply with quote

I have tried to research this alot, and I went into my account and set it for gmt -5 for est for me. after the change the default siteinfo block is showing me this 09:03 am CEST and it should be showing 03:03

I have read up on this but is seem to be more for 2.4...I am running 2.5 with php 5.3

any suggestions to point me in the right direction and I would be greatful.
 
View user's profile Send private message
hicuxunicorniobestbuildpc
The Mouse Is Extension Of Arm



Joined: Aug 13, 2009
Posts: 1008
Location: Netherland

PostPosted: Thu Aug 23, 2012 8:03 am Reply with quote

[ Only registered users can see links on this board! Get registered or login! ] [ Only registered users can see links on this board! Get registered or login! ]

I hope this help. Take a look on the section of RavenNuke 2.5 and u will find more answers.
 
View user's profile Send private message Visit poster's website
spasticdonkey
RavenNuke(tm) Development Team



Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Thu Aug 23, 2012 9:39 am Reply with quote

if memory serves me correctly, the site info block shows server time which will not be relative to any user timezone settings
 
View user's profile Send private message Visit poster's website
gator81







PostPosted: Thu Aug 23, 2012 11:53 am Reply with quote

I would not of even paid any attention but when I went to do some more with the gcalendar it was showing the wrong date for me, so when it was the evening (est -5) of the 22 gcalendar was showing me that it was the 23rd. It was as the time was saying it was the next day and it wasn't yet for me. This is where I seen what the siteinfo block was showing under server info a time and UTC.

This is all from test servers that I run on my local machine. My machine's time and date are set correctly. I have tested this with 2 versions of xampp and a version of wamppserver and the one for wampp in the php.ini was set for UTC. php.ini with the xampp had Europe/Berlin, and for an older backup of xampp i had from awhile back has America/New_York. The first two was php 5.3.3 and the old one was php 5.2.0 Just in cased asked, I made sure to only test one running at a time, after i would make a change i would logout and turn off the service and then restart it so it would reload with the changed info and I still had the same time errors. I could also verify this by going to the user data and looking at the date and time it would show for the last login.

unicornio: I did read those and if you notice that they did the same suggested changes and had no results either.
 
neralex
Site Admin



Joined: Aug 22, 2007
Posts: 1512

PostPosted: Thu Aug 23, 2012 3:48 pm Reply with quote

spasticdonkey wrote:
if memory serves me correctly, the site info block shows server time which will not be relative to any user timezone settings


This is correct!

I have no problems on my wamp based local installation in gcalendar. I think you have a wrong timezone setting in the php.ini. I have set my timezone in wamp on:

date.timezone = Europe/Berlin

Make sure you have changed the timezone of the php.ini inside the apache bin folder (\wamp\bin\apache\--yourapacheversion--\bin\). In wamp you have two php.ini files. The other one is in (\wamp\bin\php\--yourphpversion--\). Restart the apache and it must work.
 
View user's profile Send private message
gator81







PostPosted: Thu Aug 23, 2012 4:50 pm Reply with quote

ok, i went into both php.ini files and changed them to "America/New_York" and reloaded and now the server info shows the correct time but still an incorrect zone. It now shows the right time but EDT and I need it to show EST. Because I live in southern Indiana i made the change to "America/Indiana" in both the php.ini files and there was no change. I even went in and changed it to just America and it was still showing the correct time but it was EDT. When I go and look at my computer time zone there are 2 that would work. One is (UTC-05:00) Eastern Time (US & Canada) and the other is (UTC-05:00) Indiana (East).
For the good part at least the date and time are correct. This only worked with wamp after doing the edits to both php.ini files.
I also went and checked the xampp server and there was no php.ini file in the apache folder, but after making the change in the php folder then the time was also correct except that it also had EDT instead of EST.

Neralex: ty for the detailed info, it helped alot. If you ever have the idea of why it wouldnt be est or the changes so it would be then please let me know Smile
 
neralex







PostPosted: Thu Aug 23, 2012 5:21 pm Reply with quote

np Smile

Try a look at this one: [ Only registered users can see links on this board! Get registered or login! ]
Maybe you will found your correct timezone.
 
gator81







PostPosted: Thu Aug 23, 2012 6:43 pm Reply with quote

Neralex: I have some more stuff that confuses me and you may have an answer for. I changed this to America/Louisville as that is the closest zone for me, I made the change on both php.ini files and there was no change. I made sure all my cache was flushed and even loaded it with a different web browser and it still was showing the same. For fun I wanted to see what would happen if i commented the whole line by just putting the ; in front like is used in alot of the ini file for info, and after unloading and re loading again, it still showed the correct time but EDT instead of EST. I would figure i would of had some type of error if it was commented out? when i changed it from europe to america the change was right there, but now nothing changes and It seems to be confusing.
 
neralex







PostPosted: Fri Aug 24, 2012 6:25 am Reply with quote

I don't know. It seems that is an local issue on your mashine.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©