Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Server Help
Author Message
toolim
New Member
New Member


Joined: Jan 30, 2010
Posts: 5

PostPosted: Sun Mar 18, 2012 10:04 am Reply with quote

I have a problem with fonts in the captcha system.

[Sun Mar 18 15:22:20 2012] [notice] caught SIGTERM, shutting down
[Sun Mar 18 15:22:21 2012] [error] python_init: Python version mismatch, expected '2.6.5+', found '2.6.6'.
[Sun Mar 18 15:22:21 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Sun Mar 18 15:22:21 2012] [error] python_init: Python path being used '/usr/lib/python2.6/:/usr/lib/python2.6/plat-linux2:/usr/lib/python2.6/lib-tk:/usr/lib/python2.6/lib$
[Sun Mar 18 15:22:21 2012] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Sun Mar 18 15:22:21 2012] [notice] mod_python: using mutex_directory /tmp
[Sun Mar 18 15:22:21 2012] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze8 with Suhosin-Patch mod_python/3.3.1 Python/2.6.6 mod_perl/2.0.4 Perl/v5.10.1 configured -- $
[Sun Mar 18 15:22:31 2012] [error] [client 81.133.30.67] PHP Warning: ./cache/ba2ae2867aa1bde403e45894b2e34d8f.spc is not writeable in /mnt/live/sites/jackaman.net/docs/h$
[Sun Mar 18 15:22:31 2012] [error] [client 81.133.30.67] PHP Warning: ./cache/0ca10a72be5b8f826458a9953c6b6453.spc is not writeable in /mnt/live/sites/jackaman.net/docs/h$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imageftbbox(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imagefttext(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imageftbbox(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imagefttext(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imageftbbox(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imagefttext(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imageftbbox(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imagefttext(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imageftbbox(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$
[Sun Mar 18 15:22:32 2012] [error] [client 81.133.30.67] PHP Warning: imagefttext(): Could not read font in /mnt/live/sites/jackaman.net/docs/html/includes/class.php-capt$


The error file was truncated, I then restarted the webserver and viewed the web page - the above is the content of the error log.

This stops any of the captcha letters being displayed in the captcha box.

My system had been working well for years until I had to rebuild my system and was forced to upgrade to Debain squeeze.

My documents root is on a windows share and so all the files remained unaffected by my server being rebuilt which is why I think the problem is server based.

There appears to be a write error in the cache. My settings show;
drwxr-xr-x 1 root root 0 Mar 9 23:00 cache

and in the cache directory
-rwxr-xr-x 1 root root 95256 Mar 9 23:00 7bc68b22222ff7db3e797a1f36e936c1.spc
-rwxr-xr-x 1 root root 31460 Mar 9 23:00 ade5a2fad097794b8ca0084228c2cfcd.spc
-rwxr-xr-x 1 root root 60296 Mar 9 23:00 ba2ae2867aa1bde403e45894b2e34d8f.spc
-rwxr-xr-x 1 root root 0 Mar 9 23:00 index.html

The 9th March was before I rebuild the server





Here are the things that I have tried so far.

changed the mount command to
mount -t cifs -o username=XXXXX,password=XXXXXXX //192.168.254.99/DebianServerFiles /mnt/ -noserverino
(I had to change to cifs because of the upgrade. The -noserverino was added after trying to troubleshoot this error)

Checked that the font files are not 0 bytes (this fault is across multiple websites so I assume it is server side)

I have swapped font files and removed them as advised in another thread.

Cheeked that GD is installed and working correctly. You can see the config at Only registered users can see links on this board! Get registered or login!

Checked permissions are correct

Other forum posts seem to indicate that this error was mainly confined to XP machines and I was wondering if the mount command was wrong - but all other files can be found and the web sites appear to be working normally apart from this error.

Any advice would be appreciated.
 
View user's profile Send private message
toolim
PostPosted: Sun Mar 18, 2012 11:50 am Reply with quote

I feel such a fool. Two days I have been trying to sort this out. After posting this I noticed that if I tried to chown the cache directory to www-data it remained as root. I rebooted the windows server that maintains the share and it started working! The first rule - turn it off and turn it back on again! I still don't understand how this error was caused.

Sorry if I have wasted anyone's time.


Ian
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Sun Mar 18, 2012 12:45 pm Reply with quote

No worries. Glad you got it sorted out (and let us know). Smile

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
toolim
PostPosted: Mon Mar 19, 2012 9:25 am Reply with quote

Just in case anyone has the same problem the error was cased by the mount cifs command. The letters will only show up in the captcha if you use the -noserverino switch. Also when using cifs you must specify the user and group or the web server can't write files. Thus the final command that appears to be working for now is;

mount -t cifs //192.168.254.99/DebianServerFiles /mnt/ -o,noserverino,username=WindowsUserName,password=WindowsPassword,uid=www-data,gid=www-data
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Server Help

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©