Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules
Author Message
Deep-Blue
New Member
New Member


Joined: Mar 01, 2006
Posts: 5

PostPosted: Fri Mar 26, 2010 9:25 am Reply with quote

Hello,

After searching everywhere (even here) for an answer to my problem, I decided to finally make a small post.

Fresh install of RavenNuke 2.40, I made a survey, everything is ok, the block is ok, but when I click on 'results' in the block, I get a 500 server error. I tried plenty of 'solutions' found on forums, I tried with other versions, nothing to do.
After analysing the problem more in depth, I found out that if I comment one line (the include_once('header.php'); in the first elseif statement) then the error page disapear, I can see the results of the poll but on a simple white page and the footer. I use Fisubice theme, I tried with the standard DeepBlue and Traditional themes without success.

Here is the code of the first lines of the index.php file in Surveys module :
Code:
if (!defined('MODULE_FILE')) {

   die('You can\'t access this file directly...');
}
require_once('mainfile.php');
$module_name = basename(dirname(__FILE__));
get_lang($module_name);
$pagetitle = '- ' . _SURVEYS;
if (isset($pollID)) {
   $pollID = intval($pollID);
}
if (!isset($op)) {
   $op = '';
}
if (!isset($pollID)) {
   include_once 'header.php';
   pollList();
   include_once 'footer.php';
} elseif ($op == 'results' && $pollID > 0) {
   if (isset($tid)) {
      Header('Location: modules.php?name=' . $module_name);
   }
   include_once 'header.php';
   title(_CURRENTPOLLRESULTS);

The line I remove to make it 'work' is the last include just before 'title(...)'

I am now desperated because I've no more ideas on how to make it work.
Any help would be greatly appreciated, thanks in advance.
 
View user's profile Send private message
spasticdonkey
RavenNuke(tm) Development Team


Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Fri Mar 26, 2010 9:45 am Reply with quote

I'm going to guess that your host has mb_internal_encoding disabled. Try enabling $display_errors in config.php and you will likely see an error like this:

Fatal error: Call to undefined function: mb_internal_encoding()

If that's the case, you will need to get it enabled, which may (or may not) require contacting your host.

I know on godaddy you just have to make sure to run in php5, by adding this to the top of your .htaccess file

Code:
AddHandler x-httpd-php5 .php

AddHandler x-httpd-php .php4
 
View user's profile Send private message Visit poster's website
Deep-Blue
PostPosted: Fri Mar 26, 2010 10:22 am Reply with quote

Wow, thank you for your fast answer Smile

First, I'm running the website on my own server so I can change anything (If only I know what to change Embarassed )

Second problem is that I have $display_errors set to True in config.php AND also 'display_errors' set to ON in php.ini (I'm not in production yet)
but I can't see any error when one occurs, just '500 - Internal Error on server'

I'm using php version 5.2.8

You're saying that I must enable 'mb_internal_encoding()'
but where ? not in php.ini where I can find such a string. (I've found a 'mbstring.internal_encoding' but enabling it doesn't change the problem.

Thank you for your post and help,
 
spasticdonkey
PostPosted: Fri Mar 26, 2010 11:01 am Reply with quote

hmmm, I was just taking a stab in the dark about mb_internal_encoding Smile
It may not be related to your issue.. 500 errors are due to some type of fatal server error, do you have an error log you can look at?
 
Deep-Blue
PostPosted: Mon Mar 29, 2010 1:54 am Reply with quote

I just found the inetpub logs where I see the line about my access to the survey module, that line ends with 500 0 0 265 (500 for the error page I suppose but I don't know what represent the 265).
 
spasticdonkey
PostPosted: Mon Mar 29, 2010 8:00 am Reply with quote

I'm not sure, but you may be looking at the access logs and not the error logs..

If you want to post some more info about your test environment, someone may be able to help Smile
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©