Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.6.x
Author Message
Djinn
New Member
New Member


Joined: Dec 20, 2002
Posts: 22
Location: USA/Boston/MA

PostPosted: Sun Aug 23, 2009 7:39 pm Reply with quote

Ok, I did everything to get this puppy to run correct.
my problem is the Database Maintenance and HTTPAuth Menu links are dead.
The CGIAuth Setup link is active.
When I set the Admin Auth: Admin CGIAuth it runs the .htaccess and I get the http restricted user login in screen.
Thing is, I cant get back in the NS admin screen to run HTTPAuth.
The htaccess Path, staccess, Path, and ftaccess Path are correct.
I don't get the File does not exist or is not correctly CHMODed message.
I tried diffrent ones then get that message.
I manually added an IP address to the "Add Blocked IP" tool and it is showing up as blocked from the data base but not from the .htaccess.
Any kind of what direction I need to go would be great. I have the Admin folder restricted by renaming it to help not get hacked again. Thank you all in advanced. Djinn
 
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Mon Aug 24, 2009 1:58 am Reply with quote

If everything is correct, and your password is in .staccess its possible you cant log in because of this problem:
Only registered users can see links on this board! Get registered or login!


To log in again change http_auth from 2 to 0 in your table nuke_nsnst_config

In my opinion its not needed to rename the admin folder rename it back, check your blocker settings for NukeSentinel and see if this solve this problem.
CGI Auth works well.
 
View user's profile Send private message
Djinn
PostPosted: Tue Aug 25, 2009 8:11 am Reply with quote

The captcha works fine.
I tried restting the http_auth before and still get the http log in screen. Even when I turn OFF Admin Auth I still get blocked. I have no clu to what is going on here. BTW my .staccess is empty.
 
Susann
PostPosted: Wed Aug 26, 2009 12:49 pm Reply with quote

Is the HTTPAuth Menu link and the other link still dead ? So you re not able as god admin to scan for new admins or resend the password. I think you will need to fix this first. Also its good to to clear cookies and cache to check if something has changed.
 
Djinn
PostPosted: Wed Aug 26, 2009 5:34 pm Reply with quote

Susann wrote:
Is the HTTPAuth Menu link and the other link still dead ? So you re not able as god admin to scan for new admins or resend the password. I think you will need to fix this first. Also its good to to clear cookies and cache to check if something has changed.

Exactly. I clear the cookies all the time. No scan because of no active HTTPAuth and Database Maintenance links. Thanks!
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9455
Location: Arizona

PostPosted: Thu Aug 27, 2009 6:20 am Reply with quote

Rename your .htaccess file to something else temporarily so that you can get into NukeSentinel and do the scan for new admins and then generate the needed password hash in .staccess.

The reason you keep getting the pop-up is because your .htaccess is telling Apache to do that... Wink

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Djinn
PostPosted: Thu Aug 27, 2009 9:35 am Reply with quote

montego wrote:
Rename your .htaccess file to something else temporarily so that you can get into NukeSentinel and do the scan for new admins and then generate the needed password hash in .staccess.

The reason you keep getting the pop-up is because your .htaccess is telling Apache to do that... Wink

That's what I been doing. Problem is, the link's are always inactive to do a scan. I can't do a scan period. Thanks!
 
Djinn
PostPosted: Fri Aug 28, 2009 9:28 am Reply with quote

This is what I have set

Image
As you can see, no links


Image
Path is correct


Image
I change the httaccess file name


Image
ftp picture


Confused Confused Confused Confused

Any more help would be so much appreciated. Thank you!
 
Susann
PostPosted: Sat Aug 29, 2009 12:37 pm Reply with quote

I can try to log in. If you PM your admin password, ftp password and database password.
 
Susann
PostPosted: Sun Aug 30, 2009 8:52 am Reply with quote

Maybe ask Raven how to activate the death links.Everything is setup correctly. the password I added to .staccess and the .htaccess contains the path to .staccess to use CGI AUTH.
 
Djinn
PostPosted: Sun Aug 30, 2009 10:44 am Reply with quote

Yes. I tried everything like I said before. The links should be active no matter what the data base is set up or not. That is the funny thing. Since all else is correct, that being you and I tried with same with exact results, I will have to check every Sentinel folder and file and compare to the installation ones. I all ready compared a working Sentinel data base to it and all is correct. This has to be a Folder, File, Permission, Server issue. I will ask Raven after I have exhausted all my efforts. Thanks for your help, Susann. Djinn
 
Djinn
PostPosted: Sun Aug 30, 2009 12:20 pm Reply with quote

OK, I got the html .htaccess log-in to work...but still the death links.
The problem there was the nuke_nsnst_admins password was incripted wrong. This proves the death links are what I said before..


Djinn wrote:
I will have to check every Sentinel folder and file and compare to the installation ones. I all ready compared a working Sentinel data base to it and all is correct. This has to be a Folder, File, Permission, Server issue. I will ask Raven after I have exhausted all my efforts. Thanks for your help, Susann. Djinn


Basically, the Scan for New Admins was manually built to the CGIAuth file then added to the .htaccess file.
This doesn't fix the main problem. We have a few superadmins on are site that don't have a nuke_nsnst_admins. I build it if worse comes to worse though Idea
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sun Aug 30, 2009 12:50 pm Reply with quote

I have sent you the probable solution. You must be logged in as a user that is a God admin and they need to have the same name. You are missing that piece.
 
View user's profile Send private message
Raven
PostPosted: Sun Aug 30, 2009 4:05 pm Reply with quote

But, the bottom line cause was your MySQL server was running out of memory and crashing. I have sent to you a PM describing the problem and what to tell your host.
 
Djinn
PostPosted: Mon Aug 31, 2009 10:06 am Reply with quote

Raven wrote:
But, the bottom line cause was your MySQL server was running out of memory and crashing. I have sent to you a PM describing the problem and what to tell your host.


yes, correct. I have 100 MB of total storage space and 16 MB of memory allocation for memory tables. This is what they have set up...

Code:
mysql> show variables like '%heap%';

+---------------------+----------+
| Variable_name       | Value    |
+---------------------+----------+
| max_heap_table_size | 16777216 |
+---------------------+----------+
1 row in set (0.01 sec)


that comes out to around 16 MB, which is the default value. they said it would be increased to 64 MB Smile All is running well now. Thanks for your time, Raven and Susann!
 
Raven
PostPosted: Mon Aug 31, 2009 2:18 pm Reply with quote

You won't know for sure until you repopulate your IP2Country table. Have you done that?
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.6.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©