Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.6.x
Author Message
rogue3
Regular
Regular


Joined: Jul 02, 2009
Posts: 63

PostPosted: Thu Jul 02, 2009 6:41 am Reply with quote

I just instaled Nuke Sentinel and made all the necessary edits. After I activated the module and the icon appears in the admin screen I click on the icon and it loads a blank page.
 
View user's profile Send private message
Palbin
Site Admin


Joined: Mar 30, 2006
Posts: 2583
Location: Pittsburgh, Pennsylvania

PostPosted: Thu Jul 02, 2009 7:53 am Reply with quote

Only registered users can see links on this board! Get registered or login!

_________________
"Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." — Brian W. Kernighan. 
View user's profile Send private message
rogue3
PostPosted: Thu Jul 02, 2009 7:55 am Reply with quote

Thanks for that. I am using GoDaddy. But, it doesn't say what you can do about it. Is there no fix?
 
rogue3
PostPosted: Thu Jul 02, 2009 10:28 am Reply with quote

I checked GoDaddy's help page and found this:

Do you support fsockopen?

Yes, we do. You can use fsockopen on all of our PHP-enabled hosting plans for TCP ports 80 and 443.

Yet it still fails. Any ideas?
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9453
Location: Arizona

PostPosted: Tue Jul 07, 2009 5:31 pm Reply with quote

Do any of the other admin tools cause the same behavior or only NukeSentinel? If so, then it could be one of your edits. If not, then one of your NukeSentinel files could be corrupted. Try re-uploading the NS files using a good FTP tool, such as FileZilla, and use binary for the uploads.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
rogue3
PostPosted: Tue Jul 07, 2009 6:15 pm Reply with quote

No, sentinel is the only one.
 
Palbin
PostPosted: Tue Jul 07, 2009 6:37 pm Reply with quote

As montego suggested try reuploading.
 
rogue3
PostPosted: Tue Jul 07, 2009 7:17 pm Reply with quote

I reuploaded all the files and now it works. Thanks for the tip. Like you said, it must have had a corrupted file, or maybe a few files got skipped. But, I'm now able to get into the admin screen and take it out of test mode.
 
montego
PostPosted: Sat Jul 11, 2009 3:27 pm Reply with quote

Excellent. Thanks for letting us know.
 
rogue3
PostPosted: Sun Jul 12, 2009 6:05 am Reply with quote

No problem.

Since I've gotten it up and running, I frequently get abuse emails such as this one:

Created By: NukeSentinel(tm) 2.6.01
Date & Time: 2009-07-11 03:27:08 MST GMT -0700
Blocked IP: 91.142.xxx.xxx
User ID: JTA Viewer (1)
Reason: Abuse-Filter
--------------------
Referer: none
User Agent: libwww-perl/5.805
HTTP Host: Only registered users can see links on this board! Get registered or login!
Script Name: /content/modules.php
Query String:
***query string here***

Post String: Not Available
Forwarded For: none
Client IP: none
Remote Address: 91.142.xxx.xxx
Remote Port: 38448
Request Method: GET


There's a little more to it such as the query string but the code won't post in the forums.

Are these anything to worry about? Are my viewers getting blocked?

Here is the link in the query string: Only registered users can see links on this board! Get registered or login!
 
montego
PostPosted: Sun Jul 12, 2009 8:19 am Reply with quote

Let us not start a lengthy off-topic (off original topic) thread within this thread, but the quick answer is that you will be amazed at how much NukeSentinel(tm) will catch... its doing its job.
 
rogue3
PostPosted: Sun Jul 12, 2009 8:23 am Reply with quote

I understand. I was just making sure it was working OK.
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sun Jul 12, 2009 4:43 pm Reply with quote

It is working fine. Those messages are showing attempted hacks by automated bots - all of us get those.

To avoid 99% of those Abuse-Filter messages, look to blocking through .htaccess - there are posts on this forum how to do so.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.6.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©