Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes
Author Message
kadabram
Hangin' Around


Joined: Oct 29, 2007
Posts: 30

PostPosted: Thu Jun 04, 2009 2:22 pm Reply with quote

Hello,

I use the Search module that is distributed with RavenNuke.

When I do a search with a word containing accented characters (for example " référencement "), the search result is displayed correctly.

But if I decide to make a new search, the accented word I was previously searching for goes as a parameter into the url ( /modules.php?name=Web_Links&l_op=search&query=référencement ) and I get a " HTTP Error 406 - Not acceptable error message ".

I think it is a bug. Does anyboby else have the same problem?

What can we do to correct this?

If it is a bug, is it possible to correct this in the next RavenNuke version?

Thanks!

Have a nice day!


Last edited by kadabram on Mon Jun 08, 2009 8:02 am; edited 1 time in total 
View user's profile Send private message
Palbin
Site Admin


Joined: Mar 30, 2006
Posts: 2583
Location: Pittsburgh, Pennsylvania

PostPosted: Thu Jun 04, 2009 3:32 pm Reply with quote

Everything seems fine to me.

_________________
"Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." — Brian W. Kernighan. 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Fri Jun 05, 2009 4:06 pm Reply with quote

kadabram wrote:
Hello,

I use the Search module that is distributed with RavenNuke.

When I do a search with a word containing accented characters (for example " référencement "), the search result is displayed correctly.

But if I decide to make a new search, the accented word I was previously searching for goes as a parameter into the url ( /modules.php?name=Web_Links&l_op=search&query=référencement ) and I get a " HTTP Error 406 - Not acceptable error message ".

I think it is a bug. Does anyboby else have the same problem?

What can we do to correct this?

If it is a bug, is it possible to correct this in the next RavenNuke version?

Thanks!

Have a nice day!


There is no bug. A 406 error is an Apache mod_security module error message. The mod_security modules rules are controlled by your host.
 
View user's profile Send private message
ToolBox
Regular
Regular


Joined: Mar 16, 2005
Posts: 74

PostPosted: Fri Jun 05, 2009 5:11 pm Reply with quote

That is not an error but an ignored part, which never ends.
The primary solution is to use "UTF-8."
As long as ascii-based encoding in in use, such extended character set and search issues will never be settled down.
That's why phpnuke and other nukes do not cope with right multi-lingual functions. If the multi-lingual systems in any types of nuke becomes true with no flaws, character encoding should be utf-8 or some types of encodings that do not employ ascii-based encoding.

In this context, security patch has also a serious problem. When you type in more than 2 bytes language coding such as chinese, the security patch codes change them to simple codes.

These should be improved in nuke community. Otherwise, this issue will never end.

You may test this in multi-lingual mode and with non-alphabetical language codes. the same thing happens agian.
 
View user's profile Send private message
kadabram
PostPosted: Mon Jun 08, 2009 8:02 am Reply with quote

Thank you for all your kind replies.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©