Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> BB2Nuke
Author Message
mikemc
New Member
New Member


Joined: Dec 14, 2007
Posts: 12

PostPosted: Thu May 07, 2009 3:58 pm Reply with quote

Every time I post a file via the attachment mod the file uploads fine (to "modules/forums/file" folder) and appears in the post OK, the in-line link is fin (i.e. [domain name]/modules.php?name=Forums&file=download&id=##) but the resulting link goes to a path "[domain name]/modules/Forums/modules/Forums/files/[file.ext]"

I've looked for the issue in these forums, all over the net and through all my files but cannot seem to find where I've gone wrong. Anyone else seen this issue?
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Thu May 07, 2009 11:37 pm Reply with quote

Try setting the path to just /files

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
mikemc
PostPosted: Fri May 08, 2009 6:28 am Reply with quote

I tried that, and the links already in posts will then work, but the upload for new posts fail because the destination [domain name]/files/ does not exist...... It has to be somewhere in the uploads or forum display file, but I cannot seem to find it.
 
mikemc
PostPosted: Mon May 25, 2009 6:19 am Reply with quote

I believe I know where the issue is being generate, but cannot find in the code where the action is performed.

I think the displayed link translation is adding a second "modules/forums/" to the translated link path. Uploading files works correctly, and the files are stored in the correct folder on the server. But the link in a post is picking up an extra PHPbb_Root_Path somewhere.

When you attempt to download the file from a post, the link is directing towards Only registered users can see links on this board! Get registered or login! (notice the duplication of folder paths "modules/forums/").

Anyone have an idea which file performs the filename determination and storage to the database?

Or put another way;
When I click an attachment link in a post, what file translates "http://www.YourDomain.com/modules.php?name=Forums&file=download&id=23" into this; "http://www.YourDomain.com/modules/Forums/file/filename.txt"?
 
mikemc
PostPosted: Mon May 25, 2009 8:29 am Reply with quote

OK, I got this "fixed" for the moment, but located the avenue for initial issue investigation. In the forum control panel under EXTENSIONS > EXTENSION GROUP CONTROLS, I changed the download mode to "INLINE" and all works fine now. Therefore I assume the issue resides in the "Physical" mode.
 
evaders99
PostPosted: Mon May 25, 2009 1:40 pm Reply with quote

Yes, not sure what physical mode is doing. For now, use inline
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> BB2Nuke

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©