Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Captcha Security
Author Message
dssripper
Regular
Regular


Joined: Feb 16, 2004
Posts: 69

PostPosted: Mon Sep 29, 2008 8:41 am Reply with quote

I am having a problem with new users not being able to see
the captcha image. It displays fine on the admin log in.
It doesn't show a broken image, it just simply does not
display. The site is Only registered users can see links on this board! Get registered or login!
I am using version rn2.10.00.

Thanks in advance for any input!

Larry
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Tue Sep 30, 2008 6:03 am Reply with quote

What is your setting for $gfx_chk in config.php? And, look at the comments above the variables for an explanation of each of the valid values.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
dssripper
PostPosted: Thu Oct 02, 2008 8:30 am Reply with quote

montego,

Thanks for your reply.

I have changed the settings in the config.php to
0 and to 7 and to any other setting. It isn't taking
effect.
Whats strange is, that you can see that there is
a label for the security code beside where the image
should be...but no actual image.

Thanks again for your time!


Larry
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Thu Oct 02, 2008 1:27 pm Reply with quote

I am just wondering. I was having similar problems with the latest release of RN and not seeing the captcha image on one of several sites I was running. I gave up and had set the config file setting to 0 (no captcha). I just tried it again and it works. What's changed? Well for one thing I went from PHP 4.x to 5.x on the site. I wasn't even aware I was running 4 until I was trying to track down some Gallery problems. See what version of PHP you are running. If you can switch to 5 (in Cpanel there is a setting you can use) and see if that helps.

The other thing I did was clear cache. In Firefox at least there a a couple places, one clear private data in tools but also clear network cache in tools options advanced.

I'm not sure what fixed it but it's fixed for me.
 
View user's profile Send private message Visit poster's website
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Thu Oct 02, 2008 5:18 pm Reply with quote

You didn´say that you use a hack it´ s CNB YA 4.4.0 b2

The captcha included in RavenNuke works fine for all my multilingual sites.
 
View user's profile Send private message
wiz
Involved
Involved


Joined: Oct 09, 2006
Posts: 413
Location: UK

PostPosted: Mon Mar 23, 2009 11:56 am Reply with quote

I too am getting this error, it only started when i upgraded to 2.3.00, ive just updated to 2.3.01 with no luck.

$gfx_check = 0
Php version = 5.2.9
GD = Enabled

On login it says 'security code' where the captcha image should be.

Cheers
WIZ
 
View user's profile Send private message Visit poster's website AIM Address
montego
PostPosted: Wed Mar 25, 2009 8:55 am Reply with quote

GD has to be compiled with FreeType support, so you may need to ask your host about that. Wiz, what version of RN did you come from when you upgraded?
 
wiz
PostPosted: Wed Mar 25, 2009 9:10 am Reply with quote

umm...the previous version. I dont remember the number Embarassed, but it was upto date.
The weird thing is, the form box is displayed, but if you ignore it; you can login just fine.
 
montego
PostPosted: Wed Mar 25, 2009 9:37 am Reply with quote

Ok, so its not server-side then as you've had the captcha working previously. Weird. Has anything changed on your browser end? You may also try re-uploading the following (use binary if the target server is *nix):

images/captcha.php
 
wiz
PostPosted: Wed Mar 25, 2009 9:58 am Reply with quote

ok, ive found something quite humerous out. The issue is with the captcha being of black text. My theme is based upon Fisubice, but is of a black background. The problem is resolved when i switch themes to Fisubice.
Can i change the colour of the Captcha display?
 
montego
PostPosted: Sat Mar 28, 2009 7:21 am Reply with quote

You may be able to tweak the code in either images/captcha.php or includes/class.php-captcha.php. But, within images/captcha.php, I find this code intriguing:

//If there is a filename to use as a background
$file = (isset($_GET['file'])) ? $_GET['file'] : '';

looks like you may be able to pass in on the image link whatever background you wish to use (you could also hard-code $file to it if you wanted. Might be worth trying. There may be a better way, but this was just something quick that I saw as a possibility.
 
wiz
PostPosted: Sat Mar 28, 2009 9:06 am Reply with quote

Thanks for your help guys.
I found the problem was in the php configuration, and have managed to fix it. However...this is weird, with graphics check to zero...it still displays on the user login page boxingself
 
montego
PostPosted: Sun Mar 29, 2009 8:28 am Reply with quote

I am unable to replicate that with any of my RN 2.3.x sites.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Captcha Security

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©