Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> RN NSN Groups Issues
Author Message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Tue Dec 09, 2008 2:54 am Reply with quote

You have it the wrong way around. It is not RavenNukes (tm) job to be compatible with bad or inefficient code but the job of third party developers to keep up with the current standards instead of perpetuating the cycle of re-using someone elses very old code.

Although RavenNuke should work with most older modules, there are a few things that might prevent them from working.
If you can be specific about any issue you have with a specific module then I'm sure someone can advise you what the problem might be.
So far, I have only found one module that would not work with RN2.3 and that was because it was a very old module that used the $dbi database abstraction layer. A warning that $dbi was deprecated and was not to be used was contained in every nuke version for at least the last 4 years.
 
View user's profile Send private message Send e-mail
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Tue Dec 09, 2008 6:16 am Reply with quote

One thing to also keep in mind about using older scripts (besides security issues) is that PHP-Nuke itself modified the way certain things worked, in the admin area for example, which essentially "breaks" many of these older modules. Since RavenNuke(tm) was built upon PHP-Nuke 7.6, to be fair and true to your comments, pureliving, about "modules i had on my previous php nuke website, i can no longer get to work with raven nuke. Why is this?", one would have to try and run the module on 7.6 as well as on RN to judge. I have numerous non-core RavenNuke modules and can tell you that not one of them could not run on both.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> RN NSN Groups Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©