Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
blith
Client


Joined: Jul 18, 2003
Posts: 977

PostPosted: Tue Jul 22, 2008 9:43 am Reply with quote

I have 4 forum categories, and subforums under those. Up until today I had no problems assigning moderating permissions to the group "Moderators" When I went to change permissions on the forums today I was met with the following. Please help, thank you.

Code:
SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_' at line 3


SELECT ug.user_id, COUNT(auth_mod) AS is_auth_mod FROM nuke_bbauth_access aa, nuke_bbuser_group ug WHERE ug.user_id IN () AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_id

Line : 559
File : admin_ug_auth.php
 
View user's profile Send private message Visit poster's website
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Tue Jul 22, 2008 12:24 pm Reply with quote

Get and run the fixgroup script

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
blith
PostPosted: Tue Jul 22, 2008 1:58 pm Reply with quote

So this was not fixed in the RN 2.20.00? or why did it happen? It seems like a pretty big bug for RavenNuke? (meaning I am surprised it is there. I am not trying to be facetious, I am serious. Is it something I messed up or is it in phpbb2?
 
blith
PostPosted: Tue Jul 22, 2008 2:07 pm Reply with quote

Additionally in my bbusers_groups I have like 22 groupids now. Is that normal? Thank you.

I also cannot change my user level from User to Administrator. It does not stick after saving.
 
blith
PostPosted: Wed Jul 23, 2008 8:53 am Reply with quote

Can someone please explain how this problem would pop up so suddenly after assigning moderator status prior to yesterday? I made no modifications to the Forums module.
 
evaders99
PostPosted: Wed Jul 23, 2008 11:51 am Reply with quote

This is an error with your database, esp if you've been using existing phpNuke data. Fixgroup will fix this issue for your users
 
blith
PostPosted: Wed Jul 23, 2008 3:35 pm Reply with quote

I did not use existing phpnuke data, this was on a totally fresh install of RN 2.20.01. No user data existed, except mine. I even posted I did a complete install with no issues. The forums have been working marvelously up until this point... I still have the issue where the user Permission will not stick. i am trying to make myself an administrator and it won't work. The only changes I ran on the db was nsngd install. Would that change anything with group permissions within the Forums?
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Wed Jul 23, 2008 6:58 pm Reply with quote

What is nsngd? What does the install do? If you don't know perhaps you could put the script inside code tags here if it is not too long. Or post a link to it.
 
View user's profile Send private message Visit poster's website
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Thu Jul 24, 2008 6:22 am Reply with quote

That is shorthand for "NSN GR Downloads". I now know where all these extra groups are showing up as we have switched from the core YA module to a highly modified by us version of CNBYA in our development environment and I noticed the differences in the area of the phpBB tables.

Unfortunately I have no idea why you would be getting this issue on a fresh install. It typically only happens as Evaders stated with the carry-over of old PHP-Nuke data. There is nothing in the NSNGD install that should have affected this IMO.

Please find and use the noted script from Evader's post and see if that clears it up. We'll have to put this on the "list"... <sigh>

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
blith
PostPosted: Thu Jul 24, 2008 8:22 am Reply with quote

I did run the script for fixgroup. It listed all my users and then assigned a differnet group number to all of them. Is this the way it should work? I am still having the problem in the forum administration page where I select my username to give permissions, I choose administrator and it does not stick. Thanks!
 
evaders99
PostPosted: Thu Jul 24, 2008 10:10 pm Reply with quote

Yes, the script worked correctly. It should allow you to assign moderators.

For administrators, that may be a separate issue. You may need to go to the users table directly and set your user_level = 2
 
blith
PostPosted: Fri Jul 25, 2008 8:08 am Reply with quote

Thanks all for the help!
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©