Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
teamjoc
New Member
New Member


Joined: Jun 11, 2008
Posts: 16

PostPosted: Fri Jul 04, 2008 2:57 am Reply with quote

Hi there,

I don't know what I did to my website but if you visit Only registered users can see links on this board! Get registered or login! you will see (if you use IE as browser) that it says there is a script error on line 2, sign 1. It is a syntaxerror. Also Code 0.
Please help me out on fixing this.
Also is there a quick reply function in the RavenNuke? And if so, how to activate it for all users automatically? (So they don't have to activate it themselves...)

Thanks in advance.
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Fri Jul 04, 2008 4:54 am Reply with quote

LOTS of problems, but I think this is the major one:
Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>


That code is AFTER the </head> and before the <body> (i.e. there are 2 doctype, 2 html, 2 head, 2 title, 2 meta content type tags. There is a closing object tag right after the opening body tag.

My guess is that this is a theme or addon issue. If you change to one of the default RN themes, you should be able to see if there are any issues with your content or addon scripts.

We've discussed quick reply, but it isn't there yet. If so, it would automatically be available. There are several quick reply mods - some require a click to open, others do not or can be changed to do so. Is that what you mean?

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Fri Jul 04, 2008 4:56 am Reply with quote

Try switching to one of the default themes as you have a number of CSS on that page.
The quick reply mod is part of the forum template so if your theme doesn't have that, you will need to compare your theme/AOG_Army/forum/ with fisubice to see what is required.
 
View user's profile Send private message Send e-mail
kguske
PostPosted: Fri Jul 04, 2008 4:58 am Reply with quote

Thanks, G. I didn't realize the quick reply was there. Sorry for the confusion.
 
Guardian2003
PostPosted: Fri Jul 04, 2008 5:01 am Reply with quote

Yeah sorry, I was slow in typing Smile
 
teamjoc
PostPosted: Fri Jul 04, 2008 12:57 pm Reply with quote

Uhm yea I know what you mean with a LOT of peoblems on the site, cuz I checked it with W3C validator and OMG what came out there! Very Happy
Anyway I don't feel like fixing it as I am kinda too lazy for doing that... Razz
Anyhow, I saw what you ment and I checked all my new installed modules but I can't find the mistake in either one of them...
If I click "View Source Code" on my website I see what you mean, 2 DOCS TYPE am I right? Very Happy
Can you please tell me how to fix it otherwise? Cuz' I really like the AOG_Army theme and I don't want to use a standard one...
(It's a gming clan so it has to look green and armystyle Razz)
 
kguske
PostPosted: Fri Jul 04, 2008 1:25 pm Reply with quote

First, I would test another them, just to make sure the theme is the issue. If it is, you may only need to change the theme.php file. But if you change the theme to one of the default RN themes and still have the issue, the problem is in your content (this isn't likely). Either way, it shouldn't be hard to fix.
 
teamjoc
PostPosted: Fri Jul 04, 2008 1:30 pm Reply with quote

Ill check if the theme is a problem, but Ill need to re-download RavenNuke again because I removed the themes from the webserver Very Happy
What wonders me is the
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

on top of the page, a little bit under that text there is the second DOCTYPE but with another version than then the 1.0 Transitional like this:
Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

As you can see that is a 4.01 instead of a 1.0 Transitional, I don't know if it is normal that there are more Transitionals in a website... But if so what is Ravens Transitional?
 
Guardian2003
PostPosted: Fri Jul 04, 2008 2:09 pm Reply with quote

RavenNuke is XHTML 1.0 Transitional compliant and that is correct.
You should never have or need more than one DOCTYPE on a page.
 
teamjoc
PostPosted: Fri Jul 04, 2008 2:34 pm Reply with quote

KK I have changed the theme for a while with an official RN theme but the error still shows up.
I tried finding the file who is making the error but I can't find it...
I DID upgrade the NukeSentinel to the latest verison 2.6.00 maybe its that?
(I don't know what Ive done though, just installed it Razz)
Guardian or another site admin I can grant u FTP if you want..? Just ask...
 
kguske
PostPosted: Fri Jul 04, 2008 3:37 pm Reply with quote

I would check any files modified for NukeSEntinel - I doubt NS itself is causing that.
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Fri Jul 04, 2008 8:18 pm Reply with quote

Just a little nit to add in terms of looking at the W3C validator. You can have one relatively simply error, like say leaving out a closing table tag and the validator will go all wacko and find 50 errors ... because they compound themselves. In some cases where it shows A LOT of errors there really are a lot, but in other cases you can fix one or a couple of things and have 50 errors disappear.
 
View user's profile Send private message Visit poster's website
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Sun Jul 06, 2008 7:24 am Reply with quote

Try disabling the banner that you have at the top. Some code has definitely injected these double-headers, but I am thinking it is either a HTML block (not likely due to the placement of the issue), or a banner, or you have modified header.php.

No, the NukeSentinel edits have not done this.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
teamjoc
PostPosted: Mon Jul 07, 2008 7:28 am Reply with quote

montego u were right about the header thing, I managed to get away those double DOCTYPE's, but I still have an error on it, same line, same sign, but realy now I am stuck...
EDIT: I spotted another friggin DOCTYPE on it...
To the makers of RavenNuke: Can u post in here please what files in the Nuke have a DOCTYPE on it?
 
montego
PostPosted: Tue Jul 08, 2008 5:09 am Reply with quote

teamjoc, RavenNuke only produces ONE DOCTYPE. I still believe it has something to do with your theme or what I posted directly above.
 
montego
PostPosted: Tue Jul 08, 2008 5:11 am Reply with quote

BTW, please change your theme to "fisubice" and then determine if you still have the double DOCTYPE. That is the ONLY theme that was modified to be 100% XHTML compliant throughout. If you still have the error, then my previous post stands. Wink
 
teamjoc
PostPosted: Thu Jul 17, 2008 8:19 am Reply with quote

Put this on solved please, my mate solved it, it was the scrolling NukeSentinel and the NukeSentinel center banner block (both latest version) which was causing the error.
Thank you for your help anyway.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©