Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
sutterboy78
New Member
New Member


Joined: Jul 04, 2008
Posts: 9

PostPosted: Mon Jul 07, 2008 5:02 am Reply with quote

Hello, I am sorry if this have been already discussed here, but I tried to search this problem on the whole forum and I simply cant find anything about it. Therefore I am posting it.

I am using PHP-NUKE 8 based site for some time and I decided to migrate it to Raven. I have successfully managed to migrate my current site with all its content to Raven 2.20.01 (also thanks to many topics related to this problem on this forum). Everything seems to work ok, but I have one issue for which I can't find a solution.

May be its about me being noob as I don't have much experience with php and stuff, but to the problem ...

The NEWS content is visible when you are not logged in. So for Anonymous users, lets say all visitors its visible. So its according to settings of this module, which is fine. But when you log in the NEWS are gone. Also when you log as an administrator the NEWS just disapear. There is no group assigned to NEWS module. I did not make any changes in the code. All the main core file edits I have done accordingly. And still this strange behavior is there.

I hope I have described the problem successfully and please accept my apology if this problem have been solved here already. If yes I would really appreciate if someone would post me a link to forum where can I find an answer, or any other help would be really welcomed as I am lost to be honest.

Thank you very much.


Last edited by sutterboy78 on Tue Jul 08, 2008 5:57 pm; edited 1 time in total 
View user's profile Send private message
sutterboy78
PostPosted: Mon Jul 07, 2008 9:54 am Reply with quote

ok so a little update, dont know why i didnt notice it before. When I am logged in with my god admin user but not logged as regular user the news are still visible.
So it only disapearing for regular members. The NEWS modul is set to All Visitors as it is placed as Home page.
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Tue Jul 08, 2008 5:16 am Reply with quote

sutterboy78, what do you mean in your original post by this statement:

Quote:

All the main core file edits I have done accordingly.


Are you using the provided news module that came with RavenNuke or some other one?

I would also try turning on the db logging to setting '1' within rnconfig.php and then check your rnlogs/dblog file to see if there are any errors after trying this scenario again.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
sutterboy78
PostPosted: Tue Jul 08, 2008 7:18 am Reply with quote

montego wrote:
sutterboy78, what do you mean in your original post by this statement:

Quote:

All the main core file edits I have done accordingly.


Are you using the provided news module that came with RavenNuke or some other one?

I would also try turning on the db logging to setting '1' within rnconfig.php and then check your rnlogs/dblog file to see if there are any errors after trying this scenario again.


I mean the necessary edits in config.php for example to connect the db, or allowable html to be able to use images in news module ... just these basic things. May be I should have posted this in the thread related to problems after migrating from standard php-nuke to raven nuke. Anyway ... I am using the standard raven news module, I didnt make any changes to included modules or blocks or anything else. Im using custom theme and some additional modules and blocks.

I have tried to use different theme of course, and the problem is not theme related. Now I will try to follow your advices and will let you know the results.

Thank you for reply !
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Tue Jul 08, 2008 8:07 am Reply with quote

I know you said you used a different theme, but did you try fisubice? The themes definitely do different things with articles depending on whether you are logged in and whether you are an admin so that COULD be a source of the problem.

The other thing that could help us would be if you went into your modules table with PHPmyadmin and just copied and pasted the field names and values from the News record there. Post them here and we can compare with a working version.
 
View user's profile Send private message Visit poster's website
sutterboy78
PostPosted: Tue Jul 08, 2008 8:45 am Reply with quote

fkelly wrote:
I know you said you used a different theme, but did you try fisubice? The themes definitely do different things with articles depending on whether you are logged in and whether you are an admin so that COULD be a source of the problem.

The other thing that could help us would be if you went into your modules table with PHPmyadmin and just copied and pasted the field names and values from the News record there. Post them here and we can compare with a working version.


Yes I tried fisubice. Somewhere on the forum I found that fisubice is theme designed for Raven and that it is necessary to always try fisubice before posting a problem.

Here is the content of my NEWS row in MODULE table
mid - 10
title - News
custom_title - News
active - 1
view - 0
groups - (blank)
inmenu - 1
mod_group - 0
admins - .... (name of admins comma separated)

Also I have tried to log the DB errors in mlogs/dblog and the only thing I recieved there is something about duplicate key '0' (key number 1) with this message:
Code:
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)

SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('2674', 'Kym', '1215524015', '80.78.145.29', '1347326237', '/modules.php?name=Your_Account', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/index.php', 'none', 'none', '80.78.145.29', '50198', 'GET', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('2674', 'Kym', '1215524016', '80.78.145.29', '1347326237', '/modules.php?name=Your_Account&op=logout', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/modules.php?name=Your_Account', 'none', 'none', '80.78.145.29', '50210', 'GET', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('1', '', '1215524018', '80.78.145.29', '1347326237', '/index.php', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/modules.php?name=Your_Account&op=logout', 'none', 'none', '80.78.145.29', '50224', 'GET', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('1', '', '1215524022', '80.78.145.29', '1347326237', '/modules.php?name=Your_Account&username=Kym&op=login', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/index.php', 'none', 'none', '80.78.145.29', '50254', 'POST', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('2674', 'Kym', '1215524022', '80.78.145.29', '1347326237', '/modules.php?name=Your_Account&op=userinfo&bypass=1&username=Kym', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/index.php', 'none', 'none', '80.78.145.29', '50260', 'GET', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('2674', 'Kym', '1215524024', '80.78.145.29', '1347326237', '/index.php', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/modules.php?name=Your_Account&op=userinfo&bypass=1&username=Kym', 'none', 'none', '80.78.145.29', '50278', 'GET', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('2674', 'Kym', '1215524029', '80.78.145.29', '1347326237', '/modules.php?name=Forums', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/index.php', 'none', 'none', '80.78.145.29', '50322', 'GET', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 3:33 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('2674', 'Kym', '1215524033', '80.78.145.29', '1347326237', '/index.php', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'http://impact-guild.eu/modules.php?name=Forums', 'none', 'none', '80.78.145.29', '50378', 'GET', 'cz')
 remote addr: 80.78.145.29
July 8, 2008, 4:08 pm 1062 : Zdvojen-Bý klíč '0' (číslo klíče 1)
SQL was: INSERT INTO `nuke_nsnst_tracked_ips` (`user_id`, `username`, `date`, `ip_addr`, `ip_long`, `page`, `user_agent`, `refered_from`, `x_forward_for`, `client_ip`, `remote_addr`, `remote_port`, `request_method`, `c2c`) VALUES ('2674', 'Kym', '1215526135', '80.78.145.29', '1347326237', '/index.php', 'Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15', 'none', 'none', 'none', '80.78.145.29', '49245', 'GET', 'cz')
 remote addr: 80.78.145.29


Dont know if it can influence the NEWS module as it is sentinel related.
 
fkelly
PostPosted: Tue Jul 08, 2008 9:03 am Reply with quote

The news record in the modules table appears similar to mine so I don't see that as a source of the error. The dblog entries do not look related either. If you are trying fisubice and that doesn't work then it rules out a theme related problem. I guess that gets to a custom edit you did. Could you substitute in the mainfile that comes with the 2.20.01 distribution? Is your news/index.php the same as what's in the distribution? I think we need to look at any differences between your programs and what's in the distribution because that would seem to be the source of the problem.
 
sutterboy78
PostPosted: Tue Jul 08, 2008 10:58 am Reply with quote

I tried to replace the mainfile.php with the one from the original Raven Nuke distribution and still the same problem. News are visible only till you are not logged in. So for All Visitors its runing perfect. But when you log in the News disepear.

I think this is not related to any edit I have done, because Im always double, triple checking what Im doing and besides that all the modifications I did are only in those additional blocks and modules Im using on the site.

I think it has something to do with the DB. But the strange thing is that when I create new story in news it still does not apear when Im logged. When I create new user still the same. I dont know what else to try. I really didnt make any modifications to the Raven Nuke files except few very small changes and Im pretty sure these changes cant affect the site itself. This is really strange.
 
Gremmie
Former Moderator in Good Standing


Joined: Apr 06, 2006
Posts: 2415
Location: Iowa, USA

PostPosted: Tue Jul 08, 2008 12:32 pm Reply with quote

Do you have blocks that are visible to members only? If so, try turning those off one by one.

_________________
Only registered users can see links on this board! Get registered or login! - An Event Calendar for PHP-Nuke
Only registered users can see links on this board! Get registered or login! - A Google Maps Nuke Module 
View user's profile Send private message
sutterboy78
PostPosted: Tue Jul 08, 2008 1:30 pm Reply with quote

Nope ... that didnt help ... I tried to deactivate all not necessary blocks, then I tried also modules ... neither of those ways didnt work ...

I wish I would understand php more ... I tried also to put Forums on home page, then I changed News to Registered Users Only and nothing ... again no success ... then I tried set it for Registered and also Group I have on site (only one group tho, but still I tried that) ... and again no success ...

If anybody here have some other suggestions I will be happy for it.

By the way thank you all for your replies to my problem. Really thanks for your interest!
 
sutterboy78
PostPosted: Tue Jul 08, 2008 6:05 pm Reply with quote

OK ... I have find the source of the problem.

I tried to substitute '/modules/News/index.php' with the one from my original PHP-NUKE based site and bingo the News are back also when I'm logged in as member. Then I put the original index.php file which is part of the Raven Nuke 2.20.01 distribution and the problem was back.

So now I'm going to try go through the code and find the differences. May be some of you here would like to help me with it. I think that the problem could point to something what is not correct in the Raven's '/module/News/index.php' file ... may be its an issue only for my site I dont know, but I think its worth of checking it ... at least ...

What you think ?
 
montego
PostPosted: Tue Jul 08, 2008 6:19 pm Reply with quote

Well, to be quite honest, none of us have seen this issue before. So, now I suspect that you really have yet another file that might not have uploaded completely or is corrupted? Or, there is still a table/data discrepancy somewhere due to your conversion from 8 to RN.

I would try using FileZilla from SourceForge.net and if the target server is Linux, upload in binary mode.

I am pretty sure this is not a core RavenNuke issue as almost all of us use News as our home module and we do not experience this behavior.
 
sutterboy78
PostPosted: Tue Jul 08, 2008 6:46 pm Reply with quote

I would say so, but I'm using FileZilla for ages, actually dont even remember if I ever used something different. For working with the site files I'm using Dreamweaver, for small code updates and file edits I'm using Textpad. About the ftp uploading method, yes its Linux server and I'm using binary mode for uploading. There should not be any problem. And even if I'm really beginner, I'm using logic mind while editting files and the scripting methods are not totally unknown to me. Anyway I still call myself noob in this area.

But at the end I totally agree with you that the problem is most likely not RN related. But thats not the point, I just would like to isolate it and find a solution for it as substitution of the file from the original PHP-NUKE site is not a solution. I believe there is problem in DB, I have used MySQLDiff for "downgrading" the DB of my PHP-NUKE 8 site to RN DB and there I think is the problem.

I will try to go line by line through the code of those files and will try to find the linkage with the DB and the differences which could cause this. May be I will find something.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©