Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
Paul_K
Hangin' Around


Joined: Feb 22, 2004
Posts: 40
Location: Dorset, England

PostPosted: Mon Apr 21, 2008 11:11 am Reply with quote

Hi Guys,

Ok, So here goes... I logged out as admin today as I wanted to see how the frontpage was looking without the additional clutter, once satisfied I went to log back in as admin and started having captcha issues Sad

The captcha image was being displayed properly but no matter how many times I typed the codes I saw in it would just cycle straight onto the next one as if I had entered it wrong. As the image was being displayed I assumed I must have forgotten my password or something so remade it in phpmyadmin. Still no joy!

It was about this time I realised I hadn't logged in since having a bit of an issue with Gallery. You see I recently moved host and was unable to access ImageMagik properly once the site had transferred, something about account security rights or similar. The host resolved it by placing a php.ini file in the root of RavenNuke with one line in "disable_functions =" This sorted out my ImageMagik problems BUT if I delete this file captcha starts working properly again i.e. My typed code is accepted as correct!

So what can I do guys? Can I amend this php.ini file with something to make captcha and ImageMagik work or do I just have to lose that part of Gallerys functionality? I'd rather not live without captcha Sad

Cheers, Paul K

Edit. Just checked and this is what my host said originally. Not sure if it will shed any light at all?

Paul_K's Host wrote:
Hello,

There was exec functions was causing problem to ImageMagic. We have disabled this function on the server due to security. I have enabled it for just your account so now ImageMagick Test Settings works. Please check and verify the same at your end.

Regards,
 
View user's profile Send private message Yahoo Messenger MSN Messenger ICQ Number
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Mon Apr 21, 2008 11:43 am Reply with quote

Without seeing more information I can't tell exactly. Here is what I would do.

- With the php.ini file in place, run a phpinfo() script.
- Then, rename php.ini so it won't work. Run another phpinfo() script.
- Compare the 2 outputs and see what changes between the two.

Hopefully that will point you to the issue/resolution.
 
View user's profile Send private message
Paul_K
PostPosted: Mon Apr 21, 2008 12:07 pm Reply with quote

Hi Raven,

Thanks for the advice, there are quite a few differences and I don't really know what I'm looking for so I saved the outputs as two different pages...


and


Anything that catches your eye with a quick glance?

Cheers, Paul K
 
Raven
PostPosted: Mon Apr 21, 2008 12:13 pm Reply with quote

YIKES! You published your httpauth id/password. I deleted them, hopefully before anyone else saw them. You shouldn't have many differences at all unless you have a number of changes in your php.ini file. You will have to do a line by line comparison and note the differences. Then as long as the differences don't involve security, just post the differences.
 
Paul_K
PostPosted: Mon Apr 21, 2008 12:41 pm Reply with quote

Whoops Embarassed Will have a look through and post back...
 
Paul_K
PostPosted: Mon Apr 21, 2008 1:20 pm Reply with quote

Okay, here are the differences that I can see. I've left out the error logging ones.

With php.ini.

disable_functions no value
max_execution_time 30
max_input_nesting_level 64
max_input_time -1
memory_limit 128M
output_buffering 0
safe_mode_exec_dir /usr/local/php/bin
upload_max_filesize 2M
url_rewriter.tags a=href,area=href,frame=src,form=,fieldset=

No php.ini

disable_functions shell_exec,system,passthru,exec,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,highlight_file,escapeshellcmd,
define_syslog_variables,posix_uname,posix_getpwuid,apache_child_terminate,posix_kill,posix_mkfifo,posix_setpgid,posix_setsid,posix_setuid,
escapeshellarg,posix_uname,ftp_exec,ftp_connect,ftp_login,ftp_get,ftp_put,ftp_nb_fput,ftp_raw,ftp_rawlist,ini_alter,inject_code,syslog,openlog,define_syslog_variables,apache_setenv
max_execution_time 900
max_input_nesting_level 64
max_input_time 60
memory_limit 32M
output_buffering no value
safe_mode_exec_dir no value
upload_max_filesize 10m
url_rewriter.tags a=href,area=href,frame=src,input=src,form=,fieldset=

The info for the non-php.ini setup has additional sections that the php.ini one doesn't! Namely...

SQLite
PDO
pdo_mysql
pdo_sqlite
suhosin
Zend Optimiser

The url_rewriter.tags one looks like it might be something?
 
Raven
PostPosted: Mon Apr 21, 2008 3:00 pm Reply with quote

Paul, no offense, but I don't think your host, or at least the person "helping" you, knows what they are doing. I won't say anything more but I would strongly suggest that you either get another host or get someone else to help you.

Try changing your php.ini to this.
memory_limit=128M
output_buffering=4096

Then let me know what the results are. I'm going to start with the most restrictive and tweak from there.
 
Paul_K
PostPosted: Mon Apr 21, 2008 3:17 pm Reply with quote

Hi Raven,

I was more than happy with my last host but he was a one man band outfit and decided he needed to spend more time with his family. A decision I can't really hold against him. The latest hosts would appear to have some knowledgeable guys in the UK but I only ever seem to get dealt with by a help center in China. I got the impression last time that the guy was struggling to sort my issue out as the same problem on the last host was resolved in about a minute with no php.ini files being added to the folder!

I tried your suggestions but alas, the problem remains. I appreciate that your time is valuable to you and that this could take a large amount of it so I'll understand if you just want to walk away! lol
 
Raven
PostPosted: Mon Apr 21, 2008 3:51 pm Reply with quote

And I would tend to agree that it's probably not a php.ini issue but the 2 overrides mentioned above are better than what the hosts' default values are so that's the reason you should probably keep them Smile

Please email, to me, the following info and I will try to sort it all out tonight.
raven @AT@ ravenphpscripts .DOT. com

Site url, admin id/pass
NukeSentinel(tm) id/pass (if using)
FTP url, id/pass

Just to make sure that it's not a caching issue, have you cleared your cache, closed down all browser instances, and deleted any/all cookies that reference your site url?
 
Paul_K
PostPosted: Sun Jun 29, 2008 4:27 am Reply with quote

Hi,

I never did e-mail you my details, work got hectic and tbh the whole thing had slipped my mind. At the time I just left it so that the captcha system worked so users would be able to log in.

However, a new member wants to upload some pictures and can't Sad Raven, is there any chance you would be willing to take a quick look?

Oh, and while installing a gallery update today I got this message...

Warning: The exec() function is disabled in your PHP by the disabled_functions parameter in php.ini. You won't be able to use modules that require external binaries (e.g. ImageMagick, NetPBM or Ffmpeg). This can only be set server-wide, so you will need to change it in the global php.ini.

Shed any light at all?

Cheers, Paul K
 
Raven
PostPosted: Sun Jun 29, 2008 11:59 am Reply with quote

Your host is the only one who can enable the "exec" function.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©