Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
bugsy
Worker
Worker


Joined: May 08, 2007
Posts: 130

PostPosted: Mon Jun 16, 2008 4:38 am Reply with quote

Hi All,

I have recently installed RN2.2 in one of my sites and all is running fine other than few lil hitches - and one major problem is in the phpbb forum when in config setting "Use SMTP Server for email" is set to "No" - all mails are shooting fine including - new account registration - private messages - email member through board's form.

Only in the few cases the mails are not shooting..

a) When an user tries to apply for access to a particular open group in the forum - after applying it gets an error


Code:
"General Error" Failed sending email :: PHP :: DEBUG MODE Line : 238 File : emailer.php 


What effectively happens is the mail doesn't get delivered to the Boards Moderator that new group application has been submited - but when Moderator goes to forums-groupcp.html he can see the pending application.

Now the funny part is when the member is approved for the group membership - he does get a congrats mail!

I have tried using the smtp option but the problem is I use google aps for email and gmail requires a TLS. When using smtp the error while applying for group is .. "Start TTLS Command First" - so I guess right now the smtp option is not a viable one as phpbb or tego mailer does not support ssl.

Any ideas?

Well....there is another problem... to protect the Forums Admin Module i have activated the .htaccess in the Admin folder with the required information. But when I am logged in to my RN2.2 admin interface and try to access the forum admin it shows "Internal Server Error" - but when as a normal visitor i try to access the admin module directly from the browser the http authentication does come up...So basically I can not access forum admin unless i deactivate the .htaccess....which is a security issue...few suggestions will be appreciated in this context too...

Thanks in advance...
 
View user's profile Send private message Visit poster's website
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Mon Jun 16, 2008 6:12 am Reply with quote

bugsy, not sure on the email as I have never used public groups. Regarding the .htaccess file, although its an added security, the original reason for that was due to an exploit within the BBtoNuke/phpBB code. That has long since been patched, so I wouldn't even worry about using that .htaccess. I honestly do not understand why it works directly and not through admin. This is how I've used this now for a couple of years... odd.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
bugsy
PostPosted: Mon Jun 16, 2008 7:07 am Reply with quote

...regarding the .htaccess what happens is when logging in to admin.php i have to authenticate once anyway - so after i have authenticated myself and logged in as superadmin when i try to go to forum admin then the server error happens. May be it has got to do with dual authentification conflict or something?

I guess as per your suggestion i can do away with the .htaccess in the admin folder of the forum altogether..

as for the email i guess smtp is presently out of question as i am using google mail which requires tls. Problem is if I do not get membership applications by mail i need to check it everyday. Else i need to open up the boards so that any registered member can post there. Actually I wanted to have a semi private group kinda where interested parties can show interest to join but can join only after approval. Private groups Admins need to add i do understand - so that email is required to inform me of new public applications!
 
montego
PostPosted: Tue Jun 17, 2008 5:17 am Reply with quote

bugsy, that server error sounds like your path to the .staccess file isn't correct. However, what is bugging me is that you also said further up above that when you go directly to the link, you do not get the server error. It just does not make any sense to me given that the forum admin links pretty much look the same I thought.

As far as the email, I am making NO promises, but I was considering changing the mailer functions in phpBB to use the TegoNuke(tm) Mailer. However, since SMTP worked just fine in phpBB, I decided not to take the effort. I know that others are using Gmail and TLS now as well and since Swift (which is what is underneath the Mailer) has TLS support, I will try at some point in a future release to add this support.
 
bugsy
PostPosted: Wed Jun 18, 2008 3:35 am Reply with quote

The path that I have given in the .staccess is exactly the path that is there protecting the normal admin.php. Both paths are supposed to be same i guess.

Now what is happening is if I am trying to access the forums admin folder directly the authentication is coming up and after I have inputted the details and hit go I am getting same error as I was getting while trying to access forum admin from nuke admin. "The server encountered an internal error or misconfiguration and was unable to complete your request."

I have a hunch that it can be a httpd.conf related problem in the apache - I am not sure - I am saying this cause I had to modify the httpd.conf file so that all my domains can operate separate .htacess. Although I do not think i need to modify it for each folder that has a .htaccess!

Regarding the email - I guess I have to develop a work around and wait for your tls integration - the amount of stuff google mail is giving free for using with your domain i guess you will find lots of users shifting to gmail as a mailing platform in near future..
 
montego
PostPosted: Wed Jun 18, 2008 6:47 am Reply with quote

Ok, that explains it then. I was puzzled by the seeming working in one case and not the other. But, the bottom line is that any .htaccess that is not within your nuke root directory probably isn't allowed to have a .htaccess file. Unfortunately, I cannot recall what is required to allow them. Not sure if its following symbolic links or something else.

You might want to post under the Apache forum this specific question.
 
bugsy
PostPosted: Fri Jun 20, 2008 5:47 am Reply with quote

K thanks...I guess as you mentioned before.. removing it in RN2.2 will not be a security issue so will do that I guess for the time being and try to research in the Apache forums...
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©