Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
Malke
Hangin' Around


Joined: May 14, 2006
Posts: 25

PostPosted: Mon Jun 09, 2008 4:18 am Reply with quote

I have a problem that I seem unable to fix. I contacted my provider and they asked me what permissions my script (ravennuke) needs from the sql server.

Here is the error:

June 9, 2008, 11:59 am 1054 : Unknown column 'groups' in 'field list'
SQL was: update nuke_blocks set bkey='', title='TITLE', content='CONTENT', url='', bposition='l', weight='8', active='1', refresh='0', blanguage='', blockfile='', view='0', groups='', expire='0', action='d', subscription='0' where bid='42'

I am unable to edit old news items. However, I'm able to add new and edit the new ones (might be enough).

But the problem is that I'm unable to edit or add blocks.

I imported everything from phpnuke 7.8 and ran the downgrader. I did it once and everything seemed to work. The second time this happens. I used bigdump to get the sql files into the new database.

Help would be very appreciated!
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Mon Jun 09, 2008 5:47 am Reply with quote

Malke, take a look at the HowToInstall manual the page on "Upgrading". Looks like you missed a couple of SQL file updates. In this specific case, nsngroups.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Mon Jun 09, 2008 5:47 am Reply with quote

It sounds like something has gone a bit pearshaped during your transition.

When you say you imported you database then ran the downgrade, do you mean imported to the RN database you created then ran the downgrade?

You would need to run the downgrade on your 7.8 database and drop it to 7.6 and then upgrade to RN from there. This has been discussed extensively in the forums and their are guidelines in the HowToInstall files.

It would be worth installing it on a test site first using XAMP and even comparing the downgraded 7.8 to RN using something like MySQlDiff.
 
View user's profile Send private message
Malke
PostPosted: Thu Jun 12, 2008 6:58 pm Reply with quote

What I did was that I installed RN on the new server, then moved over the database tables that I think I needed. Blocks, links, content and news basically.

After that, I ran the downgrader on the entire database.

I think the problem is the downgrader. I tried the whole operation over and:

Operation Status!
- ALTER TABLE nuke_banner_clients failed
- ALTER TABLE nuke_banner failed
- ALTER TABLE nuke_banner failed
- ALTER TABLE nuke_banner failed
- ALTER TABLE nuke_banner failed
- ALTER TABLE nuke_banner failed
- ALTER TABLE nuke_banner failed
- DROP TABLE nuke_banner_positions failed
- DROP TABLE nuke_banner_terms failed
- DROP TABLE nuke_banner_plans failed
- ALTER TABLE nuke_users failed
- ALTER TABLE nuke_users failed
- DROP TABLE nuke_comments_moderated failed
- DROP TABLE nuke_pollcomments_moderated failed
- DROP TABLE nuke_reviews_comments_moderated failed
- ALTER TABLE nuke_comments failed
- ALTER TABLE nuke_pollcomments failed
- ALTER TABLE nuke_stories failed
- ALTER TABLE nuke_modules failed
Operation Complete!

Last time I assumed it had fixed the tables that I needed it to fix since it didn't list them as failed.

I guess they failed too. Any way I could do it manually?

I tried the downgrader on the old sever (on nuke 7.8 with no RN tables) and it failed there too.

According to my provider, my sql account has maximum rights.
 
montego
PostPosted: Fri Jun 13, 2008 5:43 am Reply with quote

I would suspect that the list of errors would have been different though. I would start with your 7.8 database, run the downgrader on that, and post the same list as you did above. (Personally, I'd do all of this "testing" using XAMPP on your local PC that way you can hork it up as many times as you wish and not impact anything plus its just a little bit easier to work with locally.)

After you have done this, you should be at the 7.6 version level. At this point, to bring it to RN 2.20.01 level, you would execute the SQL that is in the provided html\INSTALLATION\sql\includedInCore directory once-by-one. Then change the nuke_config version field to "rn2.02.00" and then execute the html\INSTALLATION\rndb_upgrade.php script.

Now, I can honestly say that I have never had to downgrade (because I refused years back to ever go above 7.6 due to the security issues introduced above that version), so this is why it would be good to work through this process locally using XAMPP.
 
Malke
PostPosted: Fri Jun 13, 2008 11:01 am Reply with quote

Wouldn't that overwrite the old tables? Not sure if I understand what you mean by includedInCore.
 
Malke
PostPosted: Sat Jun 14, 2008 5:16 am Reply with quote

I did it manually. The content module was the same. The posts (news) table was different but I only had to delete one variable for it to work fine.

The blocks table had one more variable in RN so I just made new blocks from scratch. The big tables was the content and the posts tables. Thanks for the input. I'm very happy with how it turned out.
 
jakec
PostPosted: Sat Jun 14, 2008 6:53 am Reply with quote

Excellent, I am glad you got it working.

Welcome to the RavenNuke world. Wink
 
montego
PostPosted: Sat Jun 14, 2008 1:09 pm Reply with quote

Wave

That is awesome news! Way to go!
 
montego
PostPosted: Sat Jun 14, 2008 1:12 pm Reply with quote

Oh sorry about the double-post, but do please make sure you change your nuke_config version value to "rn2.20.01" otherwise, our provided upgrade scripts from release to release will not work properly... Wink
 
Malke
PostPosted: Sun Jun 15, 2008 12:24 am Reply with quote

Thanks!

And yeah, the right version number was already in the config Smile. Since I did a new install and just replaced two (other) tables, it was there.

And for the record (and for people that may encounter the same thing) the variable that had to be removed from the nuke_stories table of the 7.8 version was rating_ip.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©