Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
spiritwulf
New Member
New Member


Joined: Feb 10, 2006
Posts: 18

PostPosted: Fri Apr 04, 2008 11:31 pm Reply with quote

Just setup a new site using the fresh shiny new RN v2.20.01

All seems well at first and then i run into a few hiccups in the forums. Testing with all default settings and themes with no addons atm btw.

1. unable to get the orig registered user (the one you put in during setup after God) listed as anything but a user. Trying to set them as admin in forum admin they just stick as a user and will not become an admin.
Not a major issue, just setup another user and made it admin instead.

The rest i have been able to correct myself or found workarounds for.

Anyone else run into this issue?
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Tue Apr 08, 2008 1:59 am Reply with quote

I thought I ha replied to this once, is this a duplicate post?
 
View user's profile Send private message Send e-mail
spiritwulf
PostPosted: Tue Apr 08, 2008 11:43 am Reply with quote

Not a duplicate as far as I know.

Did an extensive search before i put this post up but didnt find anything relating to this specific issue
 
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Tue Apr 08, 2008 12:16 pm Reply with quote

I have had a look at this and I am able to set the user to Admin, this is the user I created during the setup. .....but I've just found out when I try to change it back to user instead of Administrator I am receiving the following message:

Quote:
Could not obtain moderator status

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_' at line 3

SELECT ug.user_id, COUNT(auth_mod) AS is_auth_mod FROM nuke_bbauth_access aa, nuke_bbuser_group ug WHERE ug.user_id IN () AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_id

Line : 559
File : admin_ug_auth.php
 
View user's profile Send private message
jakec
PostPosted: Tue Apr 08, 2008 1:10 pm Reply with quote

Upon further investigation this error only seems to appear for the user created during the initial setup.

I'm not sure if this is related to the original post, but if someone can verify they are having the same problem I'll make a note in bug tracker.
 
Guardian2003
PostPosted: Tue Apr 08, 2008 2:08 pm Reply with quote

I think we also need to clarify whether you are trying to make a normal nuke user a nuke admin or a normal nuke user a forum admin.
 
spiritwulf
PostPosted: Tue Apr 08, 2008 7:24 pm Reply with quote

Trying to make a normal user a forum admin - specificly the normal user created during the setup process
 
bprsk8r4272
Regular
Regular


Joined: Jan 23, 2007
Posts: 96
Location: Rochester, Ny

PostPosted: Tue Apr 08, 2008 7:56 pm Reply with quote

isn't the normal user already suppose to have forum admin when you make your first account?

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
spiritwulf
PostPosted: Wed Apr 09, 2008 2:14 am Reply with quote

bprsk8r4272 wrote:
isn't the normal user already suppose to have forum admin when you make your first account?


If the orig normal user created at setup is supposed to automaticly get forum admin (and i dont believe that is how it is setup) then that operation failed in my instal. Its an interesting situation and ill prob just say hell with it and cheat pretty soon by going into the database and changing it manualy but it is still enjoyable to try and isolate what is causing it.
 
spiritwulf
PostPosted: Mon Apr 14, 2008 2:25 am Reply with quote

Well, i finaly gave in and changed it in the database. Do not know what was preventing the change through normal forum admin process.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©