Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help
Author Message
danny234
Worker
Worker


Joined: Feb 14, 2008
Posts: 123

PostPosted: Wed Mar 05, 2008 7:14 am Reply with quote

Ok so I took many people advice on these boards and did away with my old website I'm trying to install the latest that is out 20.01 or somthing like that, well i've cleard my database out and everything on my website and then uploaded all the html content files to my website then I edited the config file to access the database then run the install.SQL file in my browser. It said it connected to the database but when I click on step 1 it's giving me this error message

The exact error message that your MySQL server reported is:
MySQL Error # 4 = Specified key was too long; max key length is 1000 bytes


why would it be giving me this? I always get errors, not my luck lol


Last edited by danny234 on Wed Mar 05, 2008 9:23 am; edited 1 time in total 
View user's profile Send private message Visit poster's website MSN Messenger
danny234
PostPosted: Wed Mar 05, 2008 8:06 am Reply with quote

Anyone on here today?
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Wed Mar 05, 2008 9:23 am Reply with quote

You probably created the database with the utf8 character set. Create it with one of the latin character sets and you should be good to go. Probably we are going to need a sticky post on this once we have a chance to research the causes further. But if you google "specified key was too long" you should get an indication of what the underlying problem is.
 
View user's profile Send private message Visit poster's website
danny234
PostPosted: Wed Mar 05, 2008 9:40 am Reply with quote

I did read a post on mysql and it says use latin1_general_ci, I used this as the MySQL connection collation then tried the fresh install again nothing happend just the same thing as before. The MySQL charset: is set to UTF-8 Unicode (utf8) but I don't know how to change that it doesn't give you s drop down box to change anything in this bit
 
fkelly
PostPosted: Wed Mar 05, 2008 9:47 am Reply with quote

I don't have a quick answer to that. My phpmyadmin gave me a way when I was creating the database. Someone is going to need to research this entire issue and post something more definitive. I can't right now; headed to airport. The collation sequence does appear to be separate from but related to the character set. But as I say, in my case I was able to set the character set as part of creating the database.
 
danny234
PostPosted: Wed Mar 05, 2008 9:50 am Reply with quote

Thanks for your help fkelly, can somone help me set it up please, i've deleted my whole website to have a fresh install and now it won't install the new version of raven. I can't change anything in the charset field.
 
fkelly
PostPosted: Wed Mar 05, 2008 10:03 am Reply with quote

do you have phpmyadmin? Or tell us how you are creating your database
 
danny234
PostPosted: Wed Mar 05, 2008 10:05 am Reply with quote

yeah it's phpmyadmin and it connects to it because it says connected but give me the error message when loading step 1 core files.
 
fkelly
PostPosted: Wed Mar 05, 2008 10:17 am Reply with quote

okay. I just dropped my local database and created a new one with the same name. Under collation which is right next to create new database on my phpmyadmin screen I chose latin1_swedish_ci. Then I was able to run installSQL.php successfully. Try that.
 
danny234
PostPosted: Wed Mar 05, 2008 10:43 am Reply with quote

Nope I just tried this and it's giving me

The exact error message that your MySQL server reported is:
MySQL Error # 4 = Specified key was too long; max key length is 1000 bytes

I don't know why because I changed it to latin1_swedish_ci
 
danny234
PostPosted: Wed Mar 05, 2008 10:47 am Reply with quote

when it makes the database tables it shows utf8_general_ci in the collation field table at the top but I changed it to latin1_swedish_ci in the advanced configeration.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©