Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
Dawg
RavenNuke(tm) Development Team


Joined: Nov 07, 2003
Posts: 910

PostPosted: Tue Feb 12, 2008 8:25 am Reply with quote

Are there Databases changes with this new version?

I am pulling down a backup pf my main site now. I am going to try the new version locally and just wanted a heads up on any databse changes....

Dawg
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Tue Feb 12, 2008 9:25 am Reply with quote

Thats a very good question.
Having stared at various bits of this for 9 months (I wonder if there is some cosmic significance to '9 months') I honestly don't remember.
If no one beats me to it, I'll have to do a compare.
 
View user's profile Send private message Send e-mail
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Tue Feb 12, 2008 10:37 am Reply with quote

If you look at the upgrade scripts from 2.00, 2.02 and 2.10.xx you can see implicitly what database changes were made from those versions. We wrote the necessary add and alter statements to bring tables from those versions up to 2.20.
 
View user's profile Send private message Visit poster's website
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Tue Feb 12, 2008 7:08 pm Reply with quote

Guardian2003 wrote:
... I wonder if there is some cosmic significance to '9 months' ...

Yes. Congratulations! Look at what you helped father!
 
View user's profile Send private message
Gremmie
Former Moderator in Good Standing


Joined: Apr 06, 2006
Posts: 2415
Location: Iowa, USA

PostPosted: Tue Feb 12, 2008 7:40 pm Reply with quote

fkelly wrote:
If you look at the upgrade scripts from 2.00, 2.02 and 2.10.xx you can see implicitly what database changes were made from those versions. We wrote the necessary add and alter statements to bring tables from those versions up to 2.20.


I'm kind of curious about this too and was poking around, trying to find the upgrade script. The install script mentions a file called rn_core_pl32.sql in the INSTALLATION/sql directory, but I could not find this file. I found the rn_core.sql file. I'm just curious what gets changed from 2.10.1 to 2.20.0.

_________________
Only registered users can see links on this board! Get registered or login! - An Event Calendar for PHP-Nuke
Only registered users can see links on this board! Get registered or login! - A Google Maps Nuke Module 
View user's profile Send private message
fkelly
PostPosted: Tue Feb 12, 2008 8:36 pm Reply with quote

In the INSTALLATION directory you should find the file:

rndb_upgrade.php

That has the changes for each version in it. Just to answer your question directly, from 2.10 to 2.20 we add the field requestor to the users_temp table if it's not already there. We also save off the old headlines table to a renamed table and then load up the table that Kguske improved for 2.20 (a lot of the RSS urls in the old table were bad). Then we add the gcalendar and html newsletter tables if they aren't already present.

There is also a file called rndb_upgrade_nukesentinel.php

That upgrades Sentinel to 2.5.16. All I really did there was copy Bob's database updates from his installation scripts and change the way the messages work a little bit. All credit is his, all blame mine.
 
Gremmie
PostPosted: Tue Feb 12, 2008 9:22 pm Reply with quote

Thanks. Looks like we want to fix the text generated from rndb_upgrade.php. It says this:

Quote:

The "core" tables are those found in the file "rn_core_pl32.sql" in the INSTALLATION/sql directory.
 
fkelly
PostPosted: Tue Feb 12, 2008 9:32 pm Reply with quote

I must be having a blonde moment but what's wrong with that?
 
Gremmie
PostPosted: Tue Feb 12, 2008 9:40 pm Reply with quote

The file rn_core_pl32.sql doesn't exist. At least not in my just updated SVN working copy. I do have a rn_core.sql file though.
 
fkelly
PostPosted: Tue Feb 12, 2008 10:09 pm Reply with quote

oops. I guess Raven must have renamed it. I never understood the naming convention anyway. I was just working off what was in the SVN and I never ran a full reload after Raven finalized it and put it in the new path. Caught again by what you "assume".

I guess maybe if we do a RN2.20.01 someday we can fix it but otherwise people will have to look for rn_core.sql.
 
Raven
PostPosted: Wed Feb 13, 2008 12:00 am Reply with quote

Smack

fkelly wrote:
I guess maybe if we do a RN2.20.01 someday we can fix it but otherwise people will have to look for rn_core.sql.

You might have missed this in the Release article:
Raven wrote:
In order to meet the time line that has passed at least twice Smile, we have released this with the following caveat. The documentation is about 98.6725401% complete. The remaining 1.3274599% will be released in the next couple of weeks or sooner. There is nothing that has been withheld that should affect the installation process. The omissions are mostly due to changes in screen prints, images, etc. Nothing too meaty.

I am trusting that the maintainers of all documentation will bring the docs up to v2.20.00 release compliance Wink
 
eagleeye1000
Hangin' Around


Joined: Nov 04, 2007
Posts: 34

PostPosted: Mon Feb 18, 2008 6:18 pm Reply with quote

hi guys,

kind of a beginner in this all. We are running rn2.10.01 now and want to go to this latest version.

So pls check if I follow you all correct here:

I have to put the rndb_upgrade.php and the rndb_upgrade_nukesentinel.php from the ../html/installation/ of the package into my main root and then run both from my browser?

Then I am fully updated? And do I need to copy any files from the full install package to my site to overwrite old files, or is just running those files enough?

I came here as I noticed on my forum admin page an info that I can upgrade my phpbb to the latest conversion of bbtonuke. Is that also fixed in this version?

Tnx alot
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Mon Feb 18, 2008 7:36 pm Reply with quote

Yes you will need the full files. Those upgrade scripts are only designed to update your tables

BBToNuke 2.0.23 will be released with the next v2.20.1

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
fkelly
PostPosted: Mon Feb 18, 2008 7:37 pm Reply with quote

You need to distinguish between the database tables and the PHP program files (and associated files) that are in the downloaded package. The first thing you need to do is to copy the downloaded program files up to your server. (Actually, the first thing you need to do is make a backup of everything, programs and tables, in case anything goes wrong).

Once the programs are copied successfully to your server you should read thru the HowToInstall manual including especially the section on upgrading. The two scripts that you mentioned in your post will take care of the MYSQL table updates for you but you need to do your own due diligence by reading the "manual" completely.
 
eagleeye1000
PostPosted: Tue Feb 19, 2008 6:44 am Reply with quote

ok tnx guys, will give it a go.

I assume nothing will be changed to any current settings on admins on the site?
 
fkelly
PostPosted: Tue Feb 19, 2008 12:30 pm Reply with quote

correct eagleeye
 
Doulos
Life Cycles Becoming CPU Cycles


Joined: Jun 06, 2005
Posts: 623

PostPosted: Thu Feb 21, 2008 8:52 pm Reply with quote

After running rndb_upgrade.php that came with the RN2.20.00 package, these were the results:

Copied and pasted after running rndb_upgrade.php:
Quote:
This program updates your Ravennuke tables from version 2.02 to version 2.10 or from Ravennuke 2.10.00 to version 2.10.01. For the upgrade from 2.02 you will also need to run NukeSentinel upgrades and the HTML newsletter portion of the installSQL.php that comes with the RN2.10.01 distribution. For the upgrade from 2.10.00 you just need to run the separate NukeSentinel database upgrade. Support for this program is available thru the Forums at Ravenphpscripts.com.

You may wish to print the output from this program or capture it to a file to assist in diagnosing any problems that occur when you try to run the distribution.

Your RavenNuke configuration value was detected as rn2.10.01
(This is the value that is in the "Version_Num" field of your config table.)
This program will simply update your Version_Num field to rn2.10.01 and terminate.
You may want to independently validate that this has occurred
UPDATE nuke_config SET Version_Num='rn2.10.01' Succeeded.
From phpmyadmin nuke_config table:
Quote:
rn2.10.01
From the rndb_upgrade.php file itself:
Code:
[b]This program updates your Ravennuke tables from version 2.02 to version 2.10 or from Ravennuke 2.10.00 to version 2.10.01.  [/b]For the upgrade from 2.02 you will also need to run NukeSentinel upgrades and the HTML newsletter portion of the installSQL.php that comes with the RN2.10.01 distribution.  For the upgrade from 2.10.00 you just need to run the separate NukeSentinel database upgrade.  Support for this program is available thru the Forums at Ravenphpscripts.com.

Have my tables been updated, or not?
I am sure I am using the files from the RN2.20.00 archive
 
View user's profile Send private message
fkelly
PostPosted: Thu Feb 21, 2008 10:03 pm Reply with quote

Just to double check I just went and downloaded and extracted the 7z package Raven made available. You are using a 2.10.01 distribution. The 2.20 distribution doesn't have the messages you quoted, those are from 2.10.01. Unless there is something different in the rest of the packages (zip, tar, etc.) and I really really doubt that, you seem to have grabbed a 2.10.01 copy.

Or maybe you had the old rndb_upgrade.php in your INSTALLATION directory and didn't overwrite it with the new one. I don't know but that is definitely an old copy of the program you are running. Using the new one will upgrade your tables from 2.10.01 to 2.20.
 
Doulos
PostPosted: Fri Feb 22, 2008 1:16 pm Reply with quote

Re-dl'd it and worked perfect. Thanks
 
eagleeye1000
PostPosted: Sat Feb 23, 2008 7:16 am Reply with quote

having some serious problem guys. Have copied and overwritten all of the html folder content to my website overwriting the old files there.

Now want to run the update php files but every page I try to open I get a internal server error page Neutral

EDIT forget my blond moment Embarassed overwrote the config.php and htaccess file

anyway... running nukever.php telling me I run the latest version so tnx all Very Happy
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©