Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
catweazle
Regular
Regular


Joined: Oct 14, 2006
Posts: 60
Location: Norway

PostPosted: Sat Feb 16, 2008 8:52 am Reply with quote

Hi All!

I have this fresh install of RavenNuke(tm) 2.20.00 and everything is working like a charm except for the Advertising module. Data written to the "Add New Banner Client" form is not saved/written to the DB. I'm unable to add banners as well (but guess that's due to this first issue).

FYI:
Code:
$display_errors = true;
in root/config.php don't report any errors...

For the time being I'm using the Banners module from my old PHP-Nuke v7.6 + Patch3.2b to administer all banners, but would off love to have the Raven's Advertising module up and running...

Thanks alot in advanced for any input on this!

speedtype

_________________
Regards,
Catweazle. 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Sat Feb 16, 2008 10:37 am Reply with quote

Check your site log, too. It sounds like there might be an issue with how the database was created.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Sat Feb 16, 2008 11:16 am Reply with quote

Read up on the new dblog too. All the settings are explained in rnconfig. If you turn it on you should see any SQL errors ... and display errors does nothing to show these.

There was a transition somewhere back from 2.00.xx to 2.10.xx where the banner clients table was renames. The old one was, if memory serves "bannerclients" and the new one is "banner_clients". The 2.20 code refers to "banner_clients" ... with the prefix of course pre-pended. If you truly did a fresh install this should not be an issue but try the dblog out and see. If you get an error shown in dblog and need help just post it here.
 
View user's profile Send private message Visit poster's website
catweazle
PostPosted: Sat Feb 16, 2008 2:21 pm Reply with quote

Well - guess it's no surprice that this issue was all my fault Embarassed

When I installed v2.20.00 I wanted my site to use my old theme, which gave a blank page due to the ads code in the theme. I deactivated the Advertising module, uploaded and activated my old Banners module instead. I replaced ofcource Raven's 5 banner tables in the db with the 2 old ones. This worked fine, but i was eager to try out the Advertisng module, so...

I removed the old Banners module, uploded and activated the Advertising module - and replaced those to old banner tables in the db with Raven's 5 new ones.

The dblog told me
Code:
February 16, 2008, 8:34 pm 1146 : Table 'xxxxx_xxxxx.nuke_bannerclient' doesn't exist

SQL was: select * from nuke_bannerclient

which reminded me that I forgot to delete the references to the old Banners module from the Admin part (in admin/case, links and modules) Embarassed

Working great now Exclamation
Thanks alot for your time and help,
Very Much Appreciated!! Thanks again!! Very Happy
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©