Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.5.x
Author Message
spike71
New Member
New Member


Joined: Dec 20, 2007
Posts: 6

PostPosted: Sat Dec 22, 2007 7:57 pm Reply with quote

Hello all,

After being hacked three times a friend told me about Nuke Sentinel. SO i downloaded the latest version and installed it. It installed just fine (i think) the issue here is that when i attempt to log in as and admin through the admin.php page a windows box opens and asks for a user name and password. I enter the user name and password, with not succes. After the thirds time it give me a page 401. The text of the box is:
"The server Only registered users can see links on this board! Get registered or login! at Restricted requires a username and password.

Warning: This server is requesting that your username and password be sent in an insecure manner (basic authentication without a secure connection).

I did some searching on your forums and found several posts refering to phpmyadmin and creating a new account. I created a new account in the AUTHORS table and it still will not let me in. I am quite confused and i must have missed a step in the instructions or something. Any help you guys can provide would be great thanks!!!

Mike
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Sun Dec 23, 2007 2:55 am Reply with quote

You just haven't set the Admin auth up correctly/completely. To get back to square one follow the instructions in this faq Only registered users can see links on this board! Get registered or login!

Then once you can get back into NukeSentinel(tm) admin, click the drop down box for Admin Auth in the Administrative Settings area. Then post back here and advise what your options are.
 
View user's profile Send private message
spike71
PostPosted: Sun Dec 23, 2007 3:19 am Reply with quote

Raven,

thanks for the reply! I followed the steps in FAQ 18. I went to the database and looked for the field HTTP Auth. This value was already set to zero (0). I tried to log in again with the account i created with the phpmyadmin in the author field with no luck..
 
Raven
PostPosted: Sun Dec 23, 2007 3:48 am Reply with quote

Edit your .htaccess file and comment out the following code.

# -----------------------------------------------------------------------------------------------------
# Leave this block commented out unless HTTPAuth is NOT available in your NukeSentinel(tm) Admin Panel.
# This code is mainly for use with CGI Authentication and most servers do not require it.
# -----------------------------------------------------------------------------------------------------
# <Files admin.php>
# <Limit GET POST PUT>
# require valid-user
# </Limit>
# AuthName "Restricted"
# AuthType Basic
# AuthUserFile /path/to/your/.staccess
# </Files>
# -----------------------------------------------------------------------------------------------------
# -----------------------------------------------------------------------------------------------------

Then once you can get back into NukeSentinel(tm) admin, click the drop down box for Admin Auth in the Administrative Settings area. Then post back here and advise what your options are.

I'm heading into bed but if you haven't figured this out by the time I next look at it I will get back to you if someone else hasn't.
 
spike71
PostPosted: Sun Dec 23, 2007 5:17 am Reply with quote

Okay editing the .htaccess file allowed me access back into the admin part of my site.
I clicked on the nuke sentinel icon in the admin area. I have two option the the pull down. I have: "OFF" and "Admin CGIAuth" i guess there is a bigger problem here right? should i not see somethng likt httpauth?

thanks for the help!

Mike
 
spike71
PostPosted: Sun Dec 23, 2007 5:33 am Reply with quote

okay i got it now. I recreated the HTACCESS file for the CGIAUTH. SO when i recopied the access file to the servber i was able to log in. Things are looking good, i am going to download the manual now and see how to configure the rest of the sentinel.. Isnt there a php-nuke block that shows the sentinel icon and blocked ip's? Thanks for the help Raven!!!!
 
Raven
PostPosted: Sun Dec 23, 2007 7:00 am Reply with quote

Glad you're working again Smile. If you ftp'd all the files according to the instructions you have the blocks and modules that you need. Just use the standard nuke ACP to activate the blocks that you want.

RavensScripts Only registered users can see links on this board! Get registered or login!
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.5.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©