Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
mkabwilliams
New Member
New Member


Joined: Apr 24, 2006
Posts: 1

PostPosted: Mon Apr 24, 2006 1:24 pm Reply with quote

I'm not sure where to post this but I just did a fresh install and i can log in with the regualr user account but not the Admin. Any suggestions?
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Mon Apr 24, 2006 2:46 pm Reply with quote

Empty the authors table, create a new God account through the admin page

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
steveintrouble
New Member
New Member


Joined: Jun 23, 2007
Posts: 2

PostPosted: Sat Jun 23, 2007 9:32 am Reply with quote

I have exactly the same problem.

I have also tried numerous times to drop the data in the nuke_users table and nuke_authors table.

I then followed this by again signing up for the admin account and for the question 'Do you want to create a normal user with the same data?' I selected the option 'YES'.

I am able to sign into the admin section of PHP-Nuke, but not the user account that should have been created.

I also tried by signing up for the admin account and for the question 'Do you want to create a normal user with the same data?' I selected the option 'NO'. I then tried to create the user account seperately, but this wouldnt work because I want to use 'Webmaster' as the user name and it doesnt let you do this.

I am no expert on MySQL, but after carefully comparing this fresh install with another, I do notice this....

In all my other installations, user ID 1 in the nuke_users table is for the Anonymous user account, so the one created when admin signs up during a fresh install is ID 2 in the nuke_users table.

However in this new install I am trying to complete, the account the system creates when admin signs up during a fresh install is ID 1 and there is apparently no Anonymous user account showing in the nuke_users table.

Anyone have any ideas please?
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9455
Location: Arizona

PostPosted: Tue Jun 26, 2007 5:49 am Reply with quote

steveintrouble, please make sure that you are using the lastest version of RavenNuke which is 2.10.01 and use the installer which comes with it. The setup.php script handles all of the user setup properly.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
steveintrouble
PostPosted: Tue Jun 26, 2007 8:34 am Reply with quote

Indeed Montego...THAT was the problem!

This naughty boy wasn't following the instructions properly and didn't use the Installer that comes with Ravens Nuke package.

Because I didnt use the Installer, the 'guest' ID was not being created before the admin one and so admin ID was being created as ID1.

All sorted out now!

Much appreciated Montego!

Cheers
 
montego
PostPosted: Wed Jun 27, 2007 6:59 am Reply with quote

RavensScripts
 
spike71
New Member
New Member


Joined: Dec 20, 2007
Posts: 6

PostPosted: Sat Dec 22, 2007 4:56 pm Reply with quote

how does one, empty the authors table?
 
View user's profile Send private message
spike71
PostPosted: Sat Dec 22, 2007 5:22 pm Reply with quote

Okay i used PHPmyadmin opened the Database, deleted the account in there. I think recreated the account. When i hit the admin link, to log into the admin part of my site, i get a windows login box that opens up and prompts me for a user name and password. I enter the credentials like i put into the database and it does not let me in. after 3 tries i get a 401 page. Help! Thanks Smile

Mike
 
montego
PostPosted: Sat Dec 22, 2007 7:47 pm Reply with quote

spike71, this is a NukeSentinel admin.php setup issue. You have to follow the instructions for NukeSentinel setup carefully. For now, re-upload the .htaccess file that came with the distro and start again with the Admin Auth settings. Wink Also, there are numerous threads here in the forums to help you out.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©