Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x
Author Message
rugbyleaguer
Hangin' Around


Joined: Dec 17, 2007
Posts: 29

PostPosted: Mon Dec 17, 2007 4:40 pm Reply with quote

I have this version installed with Bonusnuke, I want to upgrade could I just delete all the nsnst_*** out of my database and overwrite all the html files and do it as a fresh install or does anyone know of any patches available??? Or are they all none existant now???
 
View user's profile Send private message
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Mon Dec 17, 2007 8:44 pm Reply with quote

I know nothing about Bonusnuke. I would recommend getting the most recent upgrade from Nukescript.net from and copy the files over and run the upgrade script (after you have backed things up of course). Ravennuke comes patched. I can't say for Bonusnuke. There is a readme file with the NukeSentinel distribution that addresses core file edits but your mileage will vary depending on what's in your core.

In any case there should be no need to delete (or drop) all the nsnst_* out of your database and you'll lose any blocked IP's if you do. The upgrade script upgrades the tables as needed.
 
View user's profile Send private message Visit poster's website
rugbyleaguer
PostPosted: Tue Dec 18, 2007 3:01 am Reply with quote

Trouble is I tried the upgrade but when you run it, it start asking if you want to upgrade the table from 2.5.** onwards not 2.4, so I can't use it can I??
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Tue Dec 18, 2007 6:10 am Reply with quote

rugbyleaguer, yes, I would recommend dropping those tables and doing the fresh installation. It doesn't take much time to re-do the set up if you have done it before, unless you have added many Harvestors or String blockers.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
fkelly
PostPosted: Tue Dec 18, 2007 8:03 am Reply with quote

M. you got here first! But yeah, rubyleaguer, what Montego says goes. You would have the option to go back thru the 2.4.x releases one by one and upgrade till you got to 2.5 and then do the rest from there, but the most expeditious and reliable way is to do what Montego recommends. Sorry I didn't catch the 2.4.x thing yesterday. And keep in mind that if the so-called "Bonusnuke" core is different you may have core file edits to do (very carefully).
 
slackervaara
Worker
Worker


Joined: Aug 26, 2007
Posts: 236

PostPosted: Tue Dec 18, 2007 11:24 am Reply with quote

I wonder, if he have used the correct Sentinel files for his upgrade. To me it seems that he used the Sentinel Upgrade package, but should not he use the full version, as he starts from 2.4 and not from 2.5?
 
View user's profile Send private message
montego
PostPosted: Tue Dec 18, 2007 7:14 pm Reply with quote

Yes, he could (would have to run 15 separate updates), but I find it useful on major release changes to just "clean house" and start over with a nice fresh install.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©