Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
whitebox
Regular
Regular


Joined: Nov 22, 2004
Posts: 52

PostPosted: Tue Apr 25, 2006 9:28 am Reply with quote

ok i went and created two test groups using NSN just to make sure that blocks working fine and everything works ok, then i went to my Forum ACP and checked the forum groups and both groups that i create thru NSN are there so so far everything is working fine.
then i wanted to add something to Moderators groups that is default group in forum (Group Admin -->Management, selected group moderators and clicked on look up group) and this is what i got
Quote:
Could not obtain user info for moderator list

DEBUG MODE

SELECT user_id, username FROM nuke_users WHERE user_id = 5

Line : 119
File : admin_groups.php


now why would this be looking for user_id 5 when i have only 3 users, two test user and one that i created while making admin acc.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Tue Apr 25, 2006 6:27 pm Reply with quote

I ve got the same error message. General error on line 119.
Code:


Could not obtain user info for moderator list

DEBUG MODE

SELECT user_id, username FROM nuke_users WHERE user_id = 5

Line : 119
File : admin_groups.php



I only clicked in groups administration "Look up Group".
If you use the admin_groups.php from version 2.0.19 it works but its not the general solution because both files are different.


Last edited by Susann on Tue Apr 25, 2006 7:26 pm; edited 1 time in total 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Tue Apr 25, 2006 7:15 pm Reply with quote

Yep, I can duplicate this.. seems to be something with the Moderators group


Taking a look at it, it looks like NSN Groups (at least in RavenNuke) assumes there's a user id 5, it assigns it to be the group moderator for Moderators

In the bbgroups table, find the Moderators row and change the group_moderator number to your user id (probably two)

There are other references in the NSN Groups tables, but I don't know it well enough to say what effect they would have

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Susann
PostPosted: Tue Apr 25, 2006 7:41 pm Reply with quote

Thanks Evaders I changed that and the error message is gone.
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Tue Apr 25, 2006 7:52 pm Reply with quote

Can someone please enter this into Mantis? Thanks.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
whitebox
PostPosted: Wed Apr 26, 2006 7:12 am Reply with quote

yep that fixed the problem Smile
thanks evaders99
 
Susann
PostPosted: Thu May 04, 2006 2:09 pm Reply with quote

In the group administration I got this general error:
Error Nr. 1

Quote:


Could not obtain user info for moderator list

DEBUG MODE

SELECT user_id, username FROM nuke_users WHERE user_id = 0

Line : 119
File : admin_groups.php


but after I clicked again this was solved for this group (moderators):The group was successfully updated. But if I click on one of the other groups and look up I get this error again. Strange because I created a new test group and did´t get this error.

Error Nr. 2
I was logged in as user and got errors for the most of the groups I have created if I click on the Group Membership Details :

Quote:


Error getting user list for group

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY u.username' at line 7

SELECT u.username, u.user_id, u.user_viewemail, u.user_posts, u.user_regdate, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_msnm, ug.user_pending FROM nuke_users u, nuke_bbuser_group ug WHERE ug.group_id = '4' AND u.user_id = ug.user_id AND ug.user_pending = '0' AND ug.user_id <> ORDER BY u.username

Line : 797
File : groupcp.php


Anyone else got the same errors ?
 
evaders99
PostPosted: Sat May 06, 2006 4:14 pm Reply with quote

Weird I can't seem to duplicate it. May need to load a clean RavenNuke db again to test
Post the data in your bbgroups table, there must be something referencing user_id = 0 (which there shouldn't be)

The second error usually means your missing entries for your users in bbgroups, which can be fixed with the fix group script
 
Susann
PostPosted: Sun May 07, 2006 8:24 am Reply with quote

Another error message:
Code:



Could not obtain moderator status

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND aa.group_id = ug.group_id AND aa.auth_mod = 1

SELECT ug.user_id, COUNT(auth_mod) AS is_auth_mod FROM nuke_bbauth_access aa, nuke_bbuser_group ug WHERE ug.user_id IN () AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_id

Line : 530
File : admin_ug_auth.php




Yes, it's sort of weird. There are different errors and duplicate entrys with a username e.g. in the Group Information.
I don t believe that s easy to reproduce.
I have one group with this entries in the table:group_id 5, group_type 2,group_name standard,group_describtion all, group_moderator 0,group_single_user 0 I changed the group_moderator to 2 in that table and that solved this error.
Afterthat I changed the group moderator again in the phpBB forums administration and choosed "Delete the old group moderator?" and changed there the name of the group moderator. That worked.

However don t know why its possible to have duplicate entrys for a username in a group. But step by step I fix my errors for all groups with group_moderator 0 and when I create new groups I couldn ´t find new error messages.
 
dave_
New Member
New Member


Joined: Jun 10, 2006
Posts: 1

PostPosted: Tue Jun 13, 2006 6:53 am Reply with quote

Susann wrote:



Yes, it's sort of weird. There are different errors and duplicate entrys with a username e.g. in the Group Information.
I don t believe that s easy to reproduce.
I have one group with this entries in the table:group_id 5, group_type 2,group_name standard,group_describtion all, group_moderator 0,group_single_user 0 I changed the group_moderator to 2 in that table and that solved this error.Afterthat I changed the group moderator again in the phpBB forums administration and choosed "Delete the old group moderator?" and changed there the name of the group moderator. That worked.

However don t know why its possible to have duplicate entrys for a username in a group. But step by step I fix my errors for all groups with group_moderator 0 and when I create new groups I couldn ´t find new error messages.



Thx for that 1........almost getting nuts over the error.....10 POINT'S out of 10... Wink
 
View user's profile Send private message
Susann
PostPosted: Tue Jun 13, 2006 7:07 am Reply with quote

Glad that you also solved your groups problem. Smile
 
kevinkap
Involved
Involved


Joined: Apr 22, 2006
Posts: 356

PostPosted: Sat Oct 27, 2007 3:26 pm Reply with quote

I am having the same issue. I have checked the group table, it has group_moderator as 2 like it should.

I am able to make myself, ie: my regular user, moderator of various forums, but I am not able to make other people moderators. When I select a user, and change their "user lever" from user to administrator, I do not get the error, but it does not make that person a moderator. However, just trying to change their user level from an administrator to a user gives me the same "could not obtain moderator status" error. This is rn2.10.01.

_________________
Kevin Kappes 
View user's profile Send private message
kevinkap
PostPosted: Sun Nov 04, 2007 12:34 pm Reply with quote

bump.
 
evaders99
PostPosted: Sun Nov 04, 2007 7:08 pm Reply with quote

Get the fix group script and run it
 
mrs_fuzz
New Member
New Member


Joined: May 14, 2007
Posts: 5

PostPosted: Mon Nov 05, 2007 12:39 pm Reply with quote

Is this error along the same lines as the error posted above? I cannot access my forums but can access my admin panel....it comes and goes but right now I can't access my forums at all....only Private Messages.

How do I fix it? Blonde Moment


Could not query forum moderator information

DEBUG MODE

SQL Error : 1030 Got error 12 from storage engine

SELECT aa.forum_id, u.user_id, u.username FROM nuke_bbauth_access aa, nuke_bbuser_group ug, nuke_bbgroups g, nuke_users u WHERE aa.auth_mod = 1 AND g.group_single_user = '1' AND ug.group_id = aa.group_id AND g.group_id = aa.group_id AND u.user_id = ug.user_id GROUP BY u.user_id, u.username, aa.forum_id ORDER BY aa.forum_id, u.user_id

Line : 238
File : index.php
 
View user's profile Send private message
kevinkap
PostPosted: Mon Nov 05, 2007 4:17 pm Reply with quote

Ok, I got the script from here:
Only registered users can see links on this board! Get registered or login!

If this is what you were referring to . I uploaded it and tried to run it, but keep getting the "can't access file directly" error.
 
kevinkap
PostPosted: Mon Nov 05, 2007 4:31 pm Reply with quote

ok, got it finally. Thanks!
 
express
Client


Joined: Jan 03, 2007
Posts: 94

PostPosted: Wed Nov 28, 2007 8:40 pm Reply with quote

I have the same exact problem as mentioned by everyone above. How did you get it to work kevinkap?
 
View user's profile Send private message
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©