Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's
Author Message
Doulos
Life Cycles Becoming CPU Cycles


Joined: Jun 06, 2005
Posts: 623

PostPosted: Sat Jun 09, 2007 6:16 pm Reply with quote

I have activated the advertising module, set banners to on in admin/preferences - but when I add a client it adds 2 copies of ever client. Then when I try to add a banner, making sure I click the activate button, no active banners show for that client (and no banners show on webpage, obviously). I have tried it on my production site which is an upgrade from 2.02.02 and also on my test site which is a virgin install of 2.10. Same result on both. Any idea's?
 
View user's profile Send private message
ParodyUK
New Member
New Member


Joined: Jun 09, 2007
Posts: 5

PostPosted: Sat Jun 09, 2007 6:22 pm Reply with quote

your theme may not suppor them, you will need to find the banner code and add it in manually.
 
View user's profile Send private message
Doulos
PostPosted: Sat Jun 09, 2007 9:47 pm Reply with quote

using fisubice RN2.10 standard issue
 
ParodyUK
PostPosted: Sun Jun 10, 2007 12:04 pm Reply with quote

have you activated the banner itself?
 
Doulos
PostPosted: Sun Jun 10, 2007 3:00 pm Reply with quote

Ezekiel wrote:
I have activated the advertising module, set banners to on in admin/preferences - but when I add a client it adds 2 copies of ever client. Then when I try to add a banner, making sure I click the activate button, no active banners show for that client (and no banners show on webpage, obviously). I have tried it on my production site which is an upgrade from 2.02.02 and also on my test site which is a virgin install of 2.10. Same result on both. Any idea's?

If there are any other steps to getting banners to work, I don't know them.

I am adding clients with the Advertising module button then trying to add banners with the Banners admin button. The client does show up in the banners admin panel but does not get added either as active or inactive when I submit it.

What am I doing wrong?
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Mon Jun 11, 2007 6:51 am Reply with quote

Ezekiel, just added a new client on both a virgin install of 2.10.01 and my site which has gone through many upgrades from 7.5 to 7.6 to RN 2.02.00 on up. I am not getting a duplicate client when I add a new client.

Without being able to replicate this, I am at a loss as to what is happening. What version of PHP and mySQL are you seeing the issue on?

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Doulos
PostPosted: Mon Jun 11, 2007 2:31 pm Reply with quote

PHP 4.4.6
MySQL 4.1.22-standard
Apache 1.3.37 (Unix)
i686
Linux

No errors are being reported (when error reporting turned on) and even with the duplicate client deleted, no data is being passed to the db.

I tried re-uploading the advertising module again - no change. I checked in preferences and banners are set to "yes" and in the db and banners =1.

Anyone know of any center blocks that will change the content every few seconds, like the banners do? I have a block that will post my banners, but will only change the content when the page is refreshed. I also have one that will scroll through them, and one that uses javascript to hightlight the one you wish to click on, but these take up too much room on the page and would only show on my homepage. I really would like to get these banners working.
 
Doulos
PostPosted: Mon Jun 11, 2007 3:52 pm Reply with quote

OK, I got banners working. It seems I had a "Banners" admin module that was interferring with the "Advertising" module. I am experiencing a couple of issues...

1. The banner is showing up full size even when I put in the size I would like it to show up as. Do I need to resize all my banners to fit correctly in the 468x60 range?

2. I want the banners to display in the header like they do here, next to the logo. I saw a few posts concerning this and I will look at them when I get a chance.

Thanks for you time.

E.
 
Doulos
PostPosted: Mon Jun 11, 2007 5:09 pm Reply with quote

Adding $showbanners = ads(0); to the fisubice theme.php file worked to get the banner to show up inside the header, but now it is showing up at the top of the page AND in the header.

What do I do? I only want the banner to show inside the header, not at the top of the page.

Also, is there some code I need to add to get it to cycle through the banners every few seconds?
 
montego
PostPosted: Tue Jun 12, 2007 6:28 am Reply with quote

Quote:

What do I do? I only want the banner to show inside the header, not at the top of the page.


You have to create two separate banner positions in your banners admin. Then, you would use ads(0) for one and ads(1) for the other and when you set up new banners, you select which position you want it to display in.

Quote:

Also, is there some code I need to add to get it to cycle through the banners every few seconds?


The current banners module is only set up to randomize at refresh time. It would take a lot of code changes to try and cycle through automatically without a page refresh. However, are you really wanting just a few to "cycle through"? I.e., are you really using the banners for something other than real advertising? If so, you could, theoretically, combine a set of same sized banners into an animated GIF and then use that GIF for your one banner.
 
Doulos
PostPosted: Tue Jun 12, 2007 11:34 am Reply with quote

montego wrote:
I.e., are you really using the banners for something other than real advertising? If so, you could, theoretically, combine a set of same sized banners into an animated GIF and then use that GIF for your one banner.


Actually, these will be actual sponsers who will each want want there own add showing all the time. Getting them to cycle through was a compromise to save on space. I might have to use the scrolling ad block to make them happy.

I have thought of that for my own ads, but didn't consider it here. I don't know much about animated gif's. I assume only one link can be associated with the whole gif, correct? That won't work, but thanks for the suggestion.
 
montego
PostPosted: Tue Jun 12, 2007 6:06 pm Reply with quote

Ezekiel, yeah, you are right, given this use model, my suggestions will not work. Unfortunately, what you have in mind will require some thought and coding. Two approaches come to mind (as a jumping off point for your research):

1. Using AJAX to asynchronously go out and get another banner every NN seconds and replace it on your page (probably the most sophisticated approach).

2. Use an IFRAME which uses Javascript to re-submit a request to a PHP script which gets the next banner and displays it (much, much easier, but I don't like iframes).

You are right in that your only other approach might be the scrolling block.

Good luck!
 
Doulos
PostPosted: Tue Jun 12, 2007 6:34 pm Reply with quote

Thanks, Montego.
 
Doulos
PostPosted: Tue Jun 19, 2007 4:14 am Reply with quote

I was able to modify all my themes to show the banners inside the header, however, I decided to use ajax instead. Ajax works perfectly and the banners change randomly, at a predetermined rate, instead of whenever the page refreshes.

Thanks for all your help.
 
montego
PostPosted: Tue Jun 19, 2007 7:48 am Reply with quote

Hey, that is excellent news! Great job on incorporating AJAX. Not many of done that, however, it is the up-and-coming thing even though the technologies have been around since the late 90's.
 
Doulos
PostPosted: Tue Jun 19, 2007 10:12 am Reply with quote

I can't take the credit. I included a php file to post the banners at the top of the theme and a friend of mine MUCH more familiar with PHP added the AJAX to it. I looked at AJAX myself but I don't read chicken-scratch.
 
Doulos
PostPosted: Tue Jun 19, 2007 10:50 am Reply with quote

I just discovered a problem with the script. With a few themes, the Forums, Members List, and Private Messages modules it includes the space above the theme but never does display the banners. The script works perfect in all other modules. And a couple themes the banners don't show up on any page (though the space is included above the theme). All the themes included with RN2.10 word flawlessly with this script.
 
montego
PostPosted: Tue Jun 19, 2007 9:24 pm Reply with quote

Are there any javascript errors being thrown by the browser?
 
Doulos
PostPosted: Wed Jun 20, 2007 12:27 am Reply with quote

None that I know of. Would error reporting need to be on to see those?

The only two themes that are doing this are really the same theme only with different color schemes.
 
montego
PostPosted: Wed Jun 20, 2007 6:43 am Reply with quote

That is a browser thing. Each one reports in different ways. Maybe there is still a conflict in javascript that might be overwriting some variables.

The three modules that you mention all come from the phpBB code and I believe it also can use theme-specific code, so you'll have to dig into the theme files to find out what is causing the conflict.
 
Doulos
PostPosted: Wed Jun 20, 2007 12:46 pm Reply with quote

Ok, thanks.
 
Doulos
PostPosted: Sun Sep 09, 2007 10:50 pm Reply with quote

We are starting to get more advertisers who want specific placements for their adds. Several want his inside the header next to our logo. For some reason I cannot get this add to show up unless I disable the ajax banners which show at the top above the actual webpage. I get the ajax banners working by adding this to the theme.php
Code:
include ("ajaxbanner.php");
if I comment this out the ajax banners disappear and the banners inside the header show up again.

Any ideas? Using RN2.10.01, fisubice theme.

Center-up banner right below the header shows fine with ajax banner running.
 
spasticdonkey
RavenNuke(tm) Development Team


Joined: Dec 02, 2006
Posts: 1692
Location: Texas, USA

PostPosted: Wed Nov 07, 2007 4:19 am Reply with quote

Ok, this isnt exactly a banner problem, but, if you want to display two banners on the same page how do you make it display 2 different banners and not the same ad 2x?

My apologies, I know I saw it discussed here before somewhere, but after much searching I couldnt find it Sad
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©