Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
Nash
Regular
Regular


Joined: Jan 10, 2006
Posts: 93

PostPosted: Wed Mar 01, 2006 1:50 pm Reply with quote

Hey guys - I did search through the forums for Coppermine info, but couldn't find the answer to this.

After upgrading from chatserves' 7.1 to Raven's 7.6, my coppermine photo gallery module isn't working. To be specific, when I click on the link to go there, NOTHING appears on the page. We're talking 0. Nothing in the source but a few line breaks. Maybe it has to do with a googletap issue, but it worked fine before.

My modules.php file is getting accessed ... if I put an echo statement in there right below the isset($name) line, it will echo out the correct name.

Anyone have ideas?
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Wed Mar 01, 2006 3:58 pm Reply with quote

It might have to do with security, since RavenNuke has the latest patch, but your Coppermine probably hasn't been modified to work with that. Check the very first part of the Coppermine index.php to see how it checks for authorized access. If it thinks access is unauthorized and simply dies, you'll get a blank page as you described. If that's the case, you just need to modify the index to properly detect authorized access under the patch.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Wed Mar 01, 2006 5:43 pm Reply with quote

Check the Patched readme for changes you may need to your addons.
Enable error reporting and check your error logs

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Nash
PostPosted: Thu Mar 02, 2006 11:45 pm Reply with quote

Will check that out. - kguske - doesn't seem to be anything strange about the very first part of coppermine index.php. I'll post it later.
 
benson
Worker
Worker


Joined: May 15, 2004
Posts: 119
Location: Germany

PostPosted: Fri Mar 03, 2006 12:27 am Reply with quote

Hello,
I have version v1.3.1c running and there was no problem to upgrade to raven's package. Maybe you are on an older version of coppermin. The v1.3.1c is the last I know that supports phpNuke.

_________________
Best regards, Norbert

Only registered users can see links on this board! Get registered or login! & Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
technocrat
Life Cycles Becoming CPU Cycles


Joined: Jul 07, 2005
Posts: 511

PostPosted: Fri Mar 03, 2006 12:35 pm Reply with quote

I am going to say this again, using the current coppermine modules is a very BAD idea. All the CPG < 1.4.x have some bad security holes that are very easy to exploit. One script kiddie forum has a whole tutorial on how to quickly expoit 1.3.x

All the nuke patches and sentinel will NOT protect you from the CPG hacks!

So I would suggest you either find another module or use CPG as a stand alone product.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! / Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message
Nash
PostPosted: Fri Mar 03, 2006 4:33 pm Reply with quote

Thanks techno - what do you guys suggest as an alternative to CPG. As long is it has similar features I'm up for it. I went with coppermine because at the time it was the only Nuke gallery that really worked.
 
Nash
PostPosted: Fri Mar 31, 2006 2:16 pm Reply with quote

Updates:

So, my coppermine gallery Only registered users can see links on this board! Get registered or login! displays this when you go to it:



Any ideas? Someone else on here had that sequence of characters displayed when he upgraded as well, but with other errors.

Evaders - how do I enable error reporting?

Thanks.
 
benson
PostPosted: Fri Mar 31, 2006 2:31 pm Reply with quote

Hi,
right, I do see exactly what you told me Smile
Why is your coppermine modul named coppermins12 ? Is that, maybe the reason why some configuration does not work ?

Sorry, I don't know what that might be, I switched to gallery (see technocrat's comment) and now I am happy with it. (Except the boring UTF-8 problem for german language)
 
Nash
PostPosted: Fri Mar 31, 2006 2:33 pm Reply with quote

hey I found the reason it was displaying those weird characters. Apparently those were in the php file before the <?php for whatever reason...


Last edited by Nash on Fri Mar 31, 2006 2:36 pm; edited 1 time in total 
Nash
PostPosted: Fri Mar 31, 2006 2:35 pm Reply with quote

still checking
 
benson
PostPosted: Fri Mar 31, 2006 2:40 pm Reply with quote

Test - module name:

Smile Smile Smile Smile
 
Nash
PostPosted: Fri Mar 31, 2006 2:41 pm Reply with quote

haha yep in the process. Trying to find where the "echos" stop working. Thanks for looking!
 
Nash
PostPosted: Fri Mar 31, 2006 2:55 pm Reply with quote

So, I found that this line is what's stopping things:

"require("modules/" . $name . "/include/load.inc");"

So, I went to check if that file exists, and for some reason it exists in my folder as load.inc.php

There was never an error before, so I'm wondering wtf happened to either rename my file coincident with the upgrade to my Nuke or to change my code. Ideas?
 
Nash
PostPosted: Fri Mar 31, 2006 3:21 pm Reply with quote

I changed the line in the code to include load.inc.php now instead of just load.inc.

Now it seems the problem leads to a file include/oldnuke.php, which looks like this:

Code:
<?php 

// Coppermine Photo Gallery 1.2.0 phpnuke RC3                               //
/**
 * oldnuke.php                                                           *
 *
 * is a class simulator to use phpNuke 6.5+ modules in phpNuke 5.5 - 6.0 *
 * Be aware that not every new module will work because they want access *
 * to the BB tables or similar.                                          *
 *
 * -----------------------------------------------------------------------*
 *
 * Copyright (C) 2003   DJ Maze, Only registered users can see links on this board! Get registered or login!                        *
 * This file is created for the Coppermine Photo Gallery phpNuke version *
 *                   http://coppermine.sourceforge.net                      *
 *
 * This file may be freely distributed and altered for free use under    *
 * the GNU General Public License as published by the Free Software      *
 * Foundation; either version 2 of the License, or at your option) any   *
 * later version.                                                        *
 * You may not sell or ask user information like email or address before *
 * they can download this file.                                          *
 * This file, a modification or part may not be included in a commercial *
 * product, unless this full comment is included in the product license. *
 */

/**
 * // use this part in the $db needed files, below 'require_once("mainfile.php");'
 * if ($Version_Num[0] < 6 || $Version_Num == "6.0")
 * require_once("modules/".$name."/include/oldnuke.php");
 */
$field_user_id = "uid";
$field_user_name = "uname";
$field_user_pass = "pass";
$field_user_email = "email";

//define('BEGIN_TRANSACTION', 1);
define('END_TRANSACTION', 2);

class sql_db {
    var $dbi;
    var $query_result;
    var $row = array();
    // Constructor
    function sql_db($dbindex)
    {
        $this->dbi = $dbindex;
    }

    function sql_query($query = "", $transaction = false)
    {
        // If the module uses $db-> properly you can uncomment these
        // $query = preg_replace('/user_id/', 'uid', $query);
        // $query = preg_replace('/username/', 'uname', $query);
        // $query = preg_replace('/user_email/', 'email', $query);
        // $query = preg_replace('/user_password/', 'pass', $query);
        // $query = preg_replace('/user_website/', 'url', $query);
        // $query = preg_replace('/user_interests/', 'user_intrest', $query);
        // Remove any pre-existing queries
        unset($this->query_result);
        if ($query != "") {
            $this->query_result = sql_query($query, $this->dbi);
        }
        if ($this->query_result) {
            unset($this->row[$this->query_result]);
            return $this->query_result;
        } else {
            return ($transaction == END_TRANSACTION) ? true : false;
        }
    }

    function sql_fetchrow($query_id = 0)
    {
        if (!$query_id) {
            $query_id = $this->query_result;
        }
        if ($query_id) {
            $this->row[$query_id] = @mysql_fetch_array($query_id);
            return $this->row[$query_id];
//            $this->row[$query_id] = sql_fetch_row($query_id, 0);
//            return $this->row[$query_id];
        } else {
            return false;
        }
    }
}

$db = new sql_db($dbi);
?>


It looks to me like this code should only get executed for versions <=6.0.

The code that leads to that is here:
Code:
if ($Version_Num[0] < 6 || $Version_Num == "6.0")


$Version_Num is 7.6, but $Version_Num[0] is nonexistant.

This leads me to believe the code was faulty and should be more like

if (!($Version_Num[0] > 6 || $Version_Num > 6.0))

I'm not too familiar with this code, so any help would be appreciated.

Is $Version_Num[0] the syntax for Postnuke or something? Not sure.

If I make those code changes I get part of my gallery back up but it doesn't fully run.
 
Nash
PostPosted: Fri Mar 31, 2006 4:29 pm Reply with quote

I think I will just convert to the Coppermine 1.3.x version on my other site. I bet it is less buggy than the version I'm using.
 
Nash
PostPosted: Wed Apr 05, 2006 8:11 am Reply with quote

Hey - figured out some stuff.

As planned, I upgraded the code to a newer version of the coppermine Nuke port I had sitting on my computer - the old 1.2 code was just plain buggy.

This didn't immediately fix it. Then there was an issue with the table it was looking up to get the files directory. The newer version of coppermine uses [prefix]_[cpg_prefix]_cpg_installs as the table to look up the directories of your coppermine installations. The old version was using just [cpg_prefix]_cpg_installs.

I fixed that in my database (to avoid modifying source code) after some debugging and it's all good again. However, I think Coppermine still has some issues as described on Waraxe, and I'm trying to find a migrate script for coppermine -> gallery, since that seems to be more secure.
 
codsniper
Regular
Regular


Joined: Feb 19, 2007
Posts: 61
Location: Almost at the north-pole

PostPosted: Thu Sep 20, 2007 8:47 am Reply with quote

I get these signs at the top of my site after install: 
And I have searched arounf but cant find a solution, any tips?
 
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Sep 21, 2007 5:41 am Reply with quote

That is a character set and file encoding issue. For example, I had done this to myself once with my Dynamic Titles script. I had accidentally saved it in UTF-8 with BOM information and my site is ISO-8859-1.

So, looks like some file was not saved properly. Maybe you modify a config file somewhere and your editor didn't save it in the right encoding.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©