Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes
Author Message
boxingscene
New Member
New Member


Joined: Nov 17, 2003
Posts: 20

PostPosted: Tue May 11, 2004 2:04 pm Reply with quote

I am trying to figure out a problem that I keep having with my site. I posted the below problem a few hours ago on NukeCops but noone seems to know how to fix. I assume that it may be a cookie issue but who knows. It cant be Internet Explorer because your site and NC work fine logging in both ways.

"I started on 6.7, I'm on 7.3 now, I have yet to find a fix for the login problem.

If a user logs into my site under Only registered users can see links on this board! Get registered or login! everything is fine and dandy. If they login from mysite.com (without the "www" in front of the url), they are NOT logged in and sometimes have problems trying to login, BUT if they switch to Only registered users can see links on this board! Get registered or login! everything is fine and dandy again (this alos works in reverse as well, if they sign in under mysite.com, they have problems when coming onto Only registered users can see links on this board! Get registered or login! The solution always ends up with the user having to delete their cookie files and logging in fresh under Only registered users can see links on this board! Get registered or login!"

Please help if possible, very annoying and ive seen several people with the same problem.
 
View user's profile Send private message
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Tue May 11, 2004 2:12 pm Reply with quote

What have you for your nuke url config under setting?
Also what is your cookie domain in the PHPbb config (This is the likely culpurt)?
 
View user's profile Send private message
boxingscene
PostPosted: Tue May 11, 2004 8:15 pm Reply with quote

Only registered users can see links on this board! Get registered or login! is the site url under web site config

the forums cookie domain name is Only registered users can see links on this board! Get registered or login!

forums cookie file name is .boxingscene.com
 
sixonetonoffun
PostPosted: Tue May 11, 2004 8:39 pm Reply with quote

Ok I haven't seen this exact problem (I don't get out much)

Anyway this seems strange and I'd be quick to throw out the usual must be there browser settings but...

Have you tried leaving the forum domain blank? It will use the default one that is configured in your webserver then and with some luck resolve the issue.

The cookie domain I mean not the name. Otherwise it should have the Only registered users can see links on this board! Get registered or login! in front of it.
 
boxingscene
PostPosted: Tue May 11, 2004 9:11 pm Reply with quote

the one thing I forgot to mention is this also happens when I login only through Only registered users can see links on this board! Get registered or login! when i go back to my site without the "www" I am not logged in, with the "www" I am logged into admin.

erased cookie name and nothing
 
sixonetonoffun
PostPosted: Wed May 12, 2004 5:26 am Reply with quote

I'm fresh out of ideas on this one. How or why is this even an issue? Browsers don't switch on their own unless there are some hard coded links on the site.
 
peace
Worker
Worker


Joined: Mar 11, 2004
Posts: 209

PostPosted: Wed May 12, 2004 10:00 am Reply with quote

i discover that Only registered users can see links on this board! Get registered or login! are difference 2 months ago ( my first days at nuke ) i did chanced all my links to Only registered users can see links on this board! Get registered or login! Sad i didnt ask or tell it to anyone coz i thought i sure did something wrong and messed it as always Embarassed
 
View user's profile Send private message
sixonetonoffun
PostPosted: Wed May 12, 2004 1:15 pm Reply with quote

That makes more sense now. I couldn't see why this would be an issue otherwise.
 
boxingscene
PostPosted: Wed May 12, 2004 1:30 pm Reply with quote

peace wrote:
i discover that Only registered users can see links on this board! Get registered or login! are difference 2 months ago ( my first days at nuke ) i did chanced all my links to Only registered users can see links on this board! Get registered or login! Sad i didnt ask or tell it to anyone coz i thought i sure did something wrong and messed it as always Embarassed


what do you mean as far as changing your links? When someone logs on to my site without the "www", all the "nuke" links dont have the "www", almost like an auto reaction from the php script as my main menu is self done by me and that never changes.
 
sixonetonoffun
PostPosted: Wed May 12, 2004 2:30 pm Reply with quote

I think what he means is that there must be some coded links that aren't relative to the webroot. Once your to the site if you came via www it should stay www until you visit just mydomein.com either intentionally or by a hard coded link that is like Only registered users can see links on this board! Get registered or login! instead of Only registered users can see links on this board! Get registered or login!

If your really having an issue with this I'd contact your host because something is unique or odd about your system. Otherwise you could put something in your htaccess that redirects all requests to www which should eliminate the issue although its a mystery to me why this should be needed at all.

You didn't put something in the cookie path changing the default cookie path or something?

Did this happen before adding those nasty fastclick ads? I could see those cookies creating an issue with some browser configurations too.
 
peace
PostPosted: Thu May 13, 2004 12:10 am Reply with quote

i cannot remember well what happened but i tho it effected somethings about register things .i didnt chance anything with my cookie/ htaccess coz i dont know any idea how to Embarassed
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Fri May 14, 2004 11:23 pm Reply with quote

Have you tried changing your Nuke url to Only registered users can see links on this board! Get registered or login! and the forum domain name to mysite.com? You will probably need to delete all cookies and flush the cache.


Last edited by Raven on Sat May 15, 2004 11:14 am; edited 1 time in total 
View user's profile Send private message
newbie
Regular
Regular


Joined: May 03, 2004
Posts: 62
Location: USA

PostPosted: Sat May 15, 2004 8:26 am Reply with quote

boxingscene wrote:
the one thing I forgot to mention is this also happens when I login only through Only registered users can see links on this board! Get registered or login! when i go back to my site without the "www" I am not logged in, with the "www" I am logged into admin.

erased cookie name and nothing


I'm not sure if I can be of any help here, but I can tell you about a similar situation I was having ... only a bit weirder Wink

If people clicked on a link (in an email notification) to one of the forum posts it would ... they'd end up on my Nuke site ... but it looked as if the style sheet was missing or something. It was my Nuke site, alright ... but just really weird looking. Somehow we found out that it was adding an extra / in the url. I ended up having to add a redirect to just redirect to the correct url.

AND ... when people would click on the url to my blog ... they'd end up on my nuke site! The funny looking version!

I can't tell you how it was fixed ... other than I had a whole lot of RSS and XML feeds running from different areas of my site, as well as some feedserver apps. I deleted all of the unnecessary scripts and now everything functions perfectly.
 
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©