Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's Collapsing Forums Block
Author Message
Stang5_0
Hangin' Around


Joined: Oct 17, 2002
Posts: 49
Location: Phoenix, AZ

PostPosted: Thu Feb 02, 2006 3:53 pm Reply with quote

Excellent work thus far Raven, very excited to convert over to this once all is well. Thank You!

I was curious about something though. I read in the other posts how to get this block to play well with the shoutbox and that now works. But for some reason, I am not able to see my Top Posters?

The site is question at the moment is Only registered users can see links on this board! Get registered or login!

Anyone have ideas or is there a post addressing this?

Thanks everyone. Cool
 
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger ICQ Number
Taz
Worker
Worker


Joined: Dec 22, 2005
Posts: 158

PostPosted: Thu Feb 02, 2006 4:05 pm Reply with quote

Now that I read this over your not talking about Shout box top posters. Smile

I don't think top posters is a block in the base distribution. I'll check mine and see.

I don't see anything in mine like the block I see on your main site called Top Posters, maybe it's an add on.

Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
Stang5_0
PostPosted: Thu Feb 02, 2006 5:14 pm Reply with quote

Correct, that is the site which will come down.
The site with Raven's block is here Only registered users can see links on this board! Get registered or login!

The "newsite" is important to add Wink

But thank you for checking.......
 
Taz
PostPosted: Thu Feb 02, 2006 8:37 pm Reply with quote

Stang5_0 wrote:
Correct, that is the site which will come down.
The site with Raven's block is here Only registered users can see links on this board! Get registered or login!


lol Believe it or not, I got that Wink, I took it off to see your old site so I could see what block you were talking about. And from what I see, it is not a block that is in the base Raven distribution. But the site GODS will correct me if I'm wrong! Smile

later
Chris
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Fri Feb 03, 2006 2:09 am Reply with quote

Have you set these?

$showTopPosters = 2; // 0=None, 1=Username - no avatar, 2=Username and avatar
$showTopPostersRanks = 3; // 0=None, 1=Admin only, 2=Moderator only, 3=Admin and Moderator, 4=All
$showTopPostersNum = 5; // Total number of top posters to show
$showTopPostersPerRow = 5; // Number to show per line


If you have, then have you checked your error_log to see if any errors are appearing? What version of nuke are you using?
 
View user's profile Send private message
spacy
Hangin' Around


Joined: Oct 25, 2005
Posts: 46
Location: Hamburg/Germany

PostPosted: Fri Feb 03, 2006 7:54 am Reply with quote

I have absolutely the same problem with this block. I did the settings like you showed, Raven, and the errorlog shows no error.

Therefor i try something else but it doesnt work exactly like it should be. I changed the block that way:
Only registered users can see links on this board! Get registered or login!


I deleted the Top-Posters and replaced it with an scrolling-part.
But my problems with the code are:

1. You can see the User Anonymous
2. At the moment there are 5 person to be shown in this scrolling-part. They are all shown at once, not one after another.
You can see it here Only registered users can see links on this board! Get registered or login!

I hope you understand what i mean and excuse my bad english.

Can someone tell me what i made wrong?

Thanks, spacy
 
View user's profile Send private message
Stang5_0
PostPosted: Fri Feb 03, 2006 9:20 am Reply with quote

Hi Raven, thanks for the reply. Here is the code yu are referring to:

Code:
$hideLinksFromGuests         = TRUE;

$hideTheseForums           = '-1';  // use a comma delimited list of forum id's to hide like '1,5,8'
$tickerWidth               = '100%';
$tickerBGColor             = "$bgcolor2";
$tickDelay                 = 4000; // in miliseconds
$hideViewReadOnly          = TRUE;
$lastNewTopics             = 25; // Number of topics to show when list is expanded
$countTopics               = 0;
$showClosedNum               = 1; // Number of messages that are visible when collapsed - NOT IMPLEMENTED YET
$showJumpBoxes               = TRUE; // Display or don't display the 2 Jump Boxes
$showTopPosters            = 2;  // 0=None, 1=Username - no avatar,  2=Username and avatar
$showTopPostersRanks       = 3;  // 0=None, 1=Admin only, 2=Moderator only, 3=Admin and Moderator, 4=All
$showTopPostersNum         = 5;  // Total number of top posters to show
$showTopPostersPerRow      = 5;  // Number to show per line
$showTickerMessage         = FALSE; // show/hide the top ticker message
$skipTopPostersUserNames   = ""; // use a comma separated list with each name in single quotes, like 'user1','user2'.
$backendForumsXML          = 'backendforums.php';  //Filename of the xml script.  Assumed in root directory.


I am using your latest distro as well. Not sure if this has to do with it being in a subdirectory (newsite) or not, but my intentions are to move it up into root once I get everything working correctly, which hopefully will be today.

When I expand the block, things are there I'm just not getting the posters like how they appear on your site.

Did you need more info?
 
Raven
PostPosted: Fri Feb 03, 2006 9:48 am Reply with quote

I have never seen this not work. It's a simple routine. What version of nuke are you using? Have you altered the nuke_users table in any way?
 
spacy
PostPosted: Fri Feb 03, 2006 10:44 am Reply with quote

mine is RN76 2.02
 
Raven
PostPosted: Fri Feb 03, 2006 10:55 am Reply with quote

spacy wrote:
mine is RN76 2.02

I will test this right away and see if it works for me.
 
Stang5_0
PostPosted: Fri Feb 03, 2006 12:03 pm Reply with quote

Mine is RN76 2.02 as well raven.
 
Raven
PostPosted: Fri Feb 03, 2006 2:01 pm Reply with quote

k - I'll test this later today and report back.
 
Stang5_0
PostPosted: Fri Feb 03, 2006 2:49 pm Reply with quote

Thanks Raven.....
And I double checked, the user table has not been modified in any way.
 
spacy
PostPosted: Fri Feb 03, 2006 8:33 pm Reply with quote

so, Ive installed RN76 with the collapsing-Block at my second and third webspace and everywhere it doesnt work corretly but nothing shows up in the error logs.
But something else is strange. When I activate the block my webspace is loading and loading and so on but that seems to be a specific problem in Firefox. Look at Only registered users can see links on this board! Get registered or login! or Only registered users can see links on this board! Get registered or login! .Watch the pages in Firefox and with IE...
 
Stang5_0
PostPosted: Sat Feb 04, 2006 12:08 am Reply with quote

Ah same issue. Now I don't feel so bad.
Still don't quite get what the trouble might be.

I have tried turning off various blocks but no luck.
 
Raven
PostPosted: Sat Feb 04, 2006 12:36 am Reply with quote

I installed it and it worked right out of the box.
Have you tried turning $display_errors=true; in config.php?
Are you sure you ftp'd all the folders and files?
 
spacy
PostPosted: Sat Feb 04, 2006 2:39 am Reply with quote

Raven, to both questions yes. Ive uploaded it several times but always the same problem...
 
Raven
PostPosted: Sat Feb 04, 2006 2:47 am Reply with quote

Well, as I said, I just installed v2.02.00 and the block worked right out of the box. Have you installed other blocks other than what came with the distro? If so, disable all of them and see if that works. Then enable them 1 by 1 to see where the conflict may be.
 
spacy
PostPosted: Sat Feb 04, 2006 2:58 am Reply with quote

Both of us have done that but without any success...
 
Stang5_0
PostPosted: Sat Feb 04, 2006 9:45 am Reply with quote

I turned on errrors Raven and got this:

Parse error: parse error in /home/httpd/vhosts/stangsgarage.com/httpdocs/newsite/includes/javascript.php on line 53

While waiting for an response, I'll shut off blocks as you suggest and see what happens...

Thanks by the way for your time for sure.....
 
Stang5_0
PostPosted: Sat Feb 04, 2006 10:29 am Reply with quote

Ok, got rid of that error. It would seem I missed a couple of line in the javascript.txt when adding it. I added them and the error went away. Shut down the other blocks again but no luck in displaying top posters. I shall keep working away at this though.
 
Stang5_0
PostPosted: Sat Feb 04, 2006 10:51 am Reply with quote

Still no luck. I have reloaded all files, turned off all other blocks that have to do with java and still not able to see the top posters...
 
Raven
PostPosted: Sat Feb 04, 2006 1:07 pm Reply with quote

Stang5_0,

PM me your
site url, and set me up an admin id/pass
ftp url, id/pass

I'll take a look when I get a chance.
 
spacy
PostPosted: Sun Feb 05, 2006 10:33 am Reply with quote

So, ive just done a complete new RN76 2.02 installation and there is absolutely the same problem. The site is already completely loaded but as far as i use the collapsing blocks the loading does not end within 2 minutes. This "neverending" loading can only be seen with Firefox. I do not understand why. As long as there is no forums already configured everything is ok but with an forum it begins with the problem. What is wrong? I do not have any idea...
 
Raven
PostPosted: Sun Feb 05, 2006 10:52 am Reply with quote

spacy,

I'll make you the same offer as Stang5_0 although he has yet to take me up on the offer Confused

PM me your
site url, and set me up an admin id/pass
ftp url, id/pass

I'll take a look when I get a chance.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's Collapsing Forums Block

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©