Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
jdimaging
Hangin' Around


Joined: Oct 25, 2003
Posts: 27

PostPosted: Wed Jan 18, 2006 1:50 pm Reply with quote

I uploaded my files and when I try the install I get:

config.php file found!
Successfully connected to localhost as user rt76 and assigned password!
Database rt76 found!

Then when I make the next selection I get:

ERROR! The exact error message that your MySQL server reported is You have an error in your SQL syntax near '; ' at line 1.

I an running php database MySQL 3.23.58
HTTP Server: Apache/1.3.27 (Unix) mod_python/2.7.8 Python/2.2.2 mod_webapp/1.2.0-dev mod_perl/1.28 mod_throttle/3.1.2 PHP/4.3.10 FrontPage/5.0.2.2510 mod_ssl/2.8.14 OpenSSL/0.9.7d.

I really would appreciate some help. I posted somewhere else but think I must have got the wrong place.

Thanks for your help.

Darlene Janssen
 
View user's profile Send private message Send e-mail
jaded
Theme Guru


Joined: Nov 01, 2003
Posts: 1006

PostPosted: Wed Jan 18, 2006 4:50 pm Reply with quote

Only registered users can see links on this board! Get registered or login!


This will help. Your host is using an ancient mysql. I wish you the best of luck! Razz

_________________
Themes BB Skins Only registered users can see links on this board! Get registered or login!
Graphic Tees Only registered users can see links on this board! Get registered or login!
Paranormal Tees Only registered users can see links on this board! Get registered or login!
Ghost Stories & More Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
jdimaging
PostPosted: Fri Jan 20, 2006 1:27 pm Reply with quote

Any ideas anyone or am I totally out of luck. Even ideas on a better more secure version as I had 2000 members and lost it all so a little hesitant to start again incase this happens again.

Darlene
 
Dawg
RavenNuke(tm) Development Team


Joined: Nov 07, 2003
Posts: 910

PostPosted: Fri Jan 20, 2006 2:49 pm Reply with quote

The best idea I have for you is to switch to Raven for hosting.

A better more secure version? This is the best out there IMHO!

Dawg
 
View user's profile Send private message
chelshale
New Member
New Member


Joined: Sep 15, 2002
Posts: 3

PostPosted: Thu Feb 02, 2006 3:01 pm Reply with quote

Can I do a quick bump on this problem, I have the same error

ERROR! The exact error message that your MySQL server reported is You have an error in your SQL syntax near '; ' at line 1.

Jaded your link to Only registered users can see links on this board! Get registered or login! can't be found.

Can any one help, please Crying or Very sad
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Fri Feb 03, 2006 2:18 am Reply with quote

That link works perfectly well and has the answer to the issue.
 
View user's profile Send private message
chelshale
PostPosted: Fri Feb 03, 2006 8:11 am Reply with quote

Your no doubt right,

but can you give me the address for the correction because this is the error I get.

graphic at Only registered users can see links on this board! Get registered or login!

This is what shows on my screen after clicking the link

Thanks
 
Raven
PostPosted: Fri Feb 03, 2006 9:50 am Reply with quote

That is the address Confused Try this one Only registered users can see links on this board! Get registered or login!
 
chelshale
PostPosted: Fri Feb 03, 2006 3:43 pm Reply with quote

Sorry Raven but I get the same error with the new address.

I've tried internet explorer instead of firefox, turning my antivirus program off, another computer, corrected my email address and even re-activated my account, all to no avail.

Could I have made a wrong selection in my profile? I can't find anything that I can see.

I've even tried uploading the tables through phpmyadmin (2.6, I think) directly but I get errors.

Should I perhaps try an earlier version and then try to upgrade?

After being hacked so many times in the past I'm keen to get as much protection for our site as possible.
 
Raven
PostPosted: Sat Feb 04, 2006 2:51 am Reply with quote

Try accessing the link from a proxy, like Only registered users can see links on this board! Get registered or login!
 
Duke
Regular
Regular


Joined: Jan 09, 2006
Posts: 56
Location: Under your bed

PostPosted: Sat Feb 04, 2006 5:44 am Reply with quote

That doesn't help because once you login your bumped back to the proxify website.
 
View user's profile Send private message Send e-mail Visit poster's website
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Sat Feb 04, 2006 5:55 am Reply with quote

I think that thread got moved to 'moved posts'.
 
View user's profile Send private message Send e-mail
Duke
PostPosted: Sat Feb 04, 2006 6:11 am Reply with quote

I guess that explains why I can't find it Confused
 
Guardian2003
PostPosted: Sat Feb 04, 2006 6:48 am Reply with quote

I think the problem was due to an ancient version of Mysql.
Try Ravens fix
Quote:
You can always use a text editor and do a search and replace on -- to ## . Note that there MUST be a space after the -- and ##.
 
Duke
PostPosted: Sat Feb 04, 2006 6:56 am Reply with quote

do you mean just replace the -- with ## on the mysql version # or everywhere in the rn76_core_pl31 file?
 
Guardian2003
PostPosted: Sat Feb 04, 2006 7:27 am Reply with quote

Everywhere on the file.
From what I understand, these characters are suppose to signify that the line is a comment and should be ignored by mysql but some earlier versions of mysql try to execute it instead of ignoring it.
 
sting
Involved
Involved


Joined: Sep 23, 2003
Posts: 456
Location: Somewhere out there...

PostPosted: Sat Feb 04, 2006 7:27 am Reply with quote

Whichever method you use - the version of MySql you are running needs to interpret the comment indicator as a # instead of a -


-sting

actually, in your case it would be

#sting
 
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
Raven
PostPosted: Sat Feb 04, 2006 12:40 pm Reply with quote

Bang Head - Duh - I missed that one (moved posts) - Thanks guys. Maybe we can split the moved post and put the good stuff back? I'll take care of that Smile
 
Raven
PostPosted: Sat Feb 04, 2006 1:23 pm Reply with quote

Okay, I have split the moved post and you should be able to access it now at Only registered users can see links on this board! Get registered or login!

Sorry about all the confusion!
 
Duke
PostPosted: Sun Feb 05, 2006 7:33 am Reply with quote

This is painful, my God, oh how I miss the Power Tools Confused

I actually took the time to edit the rn76-core-pl31 and changed all -- to ## and now I get an error message that says:

ERROR! The exact error message that your MySQL server reported is Query was empty.

I've been at this for a number of hours now off and on so I apologize if this is a stupid question but any idea what may be wrong?

BTW, I also updated the above file with my exact server info. taken from another db as follows:

Code:


## phpMyAdmin SQL Dump
## version 2.6.0-pl3
## http://www.phpmyadmin.net
##
## Host: localhost
## Generation Time: Dec 16, 2005 at 10:49 PM
## Server version: 3.23.58
## PHP Version: 4.3.10
##
## Database: `mysitename_com_-_testing`


Any ideas?

Thanks for your help!
 
Guardian2003
PostPosted: Sun Feb 05, 2006 8:27 am Reply with quote

Wait one, I'll post a link to a revised file.
 
Guardian2003
PostPosted: Sun Feb 05, 2006 8:40 am Reply with quote

Try this one. Only registered users can see links on this board! Get registered or login!
 
Duke
PostPosted: Sun Feb 05, 2006 9:03 am Reply with quote

Thanks a lot, unfortunately the file is not found:

The requested URL /rn76-core-pl31.zip was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.34 Server at Only registered users can see links on this board! Get registered or login! Port 80
 
Guardian2003
PostPosted: Sun Feb 05, 2006 9:34 am Reply with quote

Oops, Imust get more coffeee.
Try Only registered users can see links on this board! Get registered or login!
 
Duke
PostPosted: Sun Feb 05, 2006 12:30 pm Reply with quote

Cannot be found Confused
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©