Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> phpnuke 7.8
Author Message
Gabe
Regular
Regular



Joined: Oct 30, 2005
Posts: 62

PostPosted: Sun Oct 30, 2005 6:09 pm Reply with quote

Hey everyone, Iam getting this problem again. Before when I had phpnuke 7.7 I had the same sort of problem, so I upgraded to nuke 7.8 and the problem was pritty much gone, now Iam still on nuke 7.8 BUT with the "nukefix" 3.1 and Iam also running sentinel 2.4.2, everything was working fine untill i installed nukefix 3.1 or sentinel, iam not sure wich caused the problem, but heres a screenshot of what Iam talking about
-http://img453.imageshack.us/img453/1870/problem13fm.jpg

next problem is this
-http://img458.imageshack.us/img458/9639/problem25sj.jpg

notice how some of the button where I pointed out are missing, and almost none of those buttons work ether
 
View user's profile Send private message
kguske
Site Admin



Joined: Jun 04, 2004
Posts: 6404

PostPosted: Sun Oct 30, 2005 6:40 pm Reply with quote

It looks like TinyMCE is trying to override the textareas in the forums, where BBcode is used instead of HTML. I doubt it's a NukeSentinel issue - it sounds more like it might a patched issue. Chatserv might be able to shed some light on this as he is both the author of the patched series and a BBTONUKE guru... 64bit might also be able to give some ideas on this as he has worked extensively with both 7.8, the forums and TinyMCE.

In the mean time, I'd suggest reviewing the changes and installation instructions on the patched version. You simply need to turn off TinyMCE for the forums.

_________________
I google, therefore I exist...
nukeSEO - nukeFEED - nukePIE - nukeSPAM - nukeWYSIWYG
 
View user's profile Send private message
Gabe







PostPosted: Sun Oct 30, 2005 7:26 pm Reply with quote

I backed my site up to where it was just nuke 7.8 with nukefix 3.1, everything seems fine now, maybe I screwed the sentinel install, no matter what Iam going to have to reinstall sentinel now, also whats the tiny-mce thing? would that have fixed my problem in the first place

Iam just gonna have to see if the problem comes back when I install sentinel again
 
kguske







PostPosted: Sun Oct 30, 2005 7:32 pm Reply with quote

TinyMCE is the WYSIWYG editor that was added in 7.7. It what causes the extra buttons , some of which are missing, to be displayed in your forums. I don't see how NukeSentinel could cause this problem to happen, but I haven't played with 7.8 either...
 
Gabe







PostPosted: Sun Oct 30, 2005 7:35 pm Reply with quote

it doesent make sence why those extra buttons would come up after installing sentinel in nuke 7.8, that seems really weird, lol

Iam supose to edit all those files in "edit for core files" folder right, I did them all

includes
modules
admin.txt
header.txt
mainfile7.8.txt
 
kguske







PostPosted: Sun Oct 30, 2005 7:50 pm Reply with quote

Like I said, I don't see how adding NukeSentinel would cause TinyMCE to suddenly start working in the forums. Let me see what I can find... Where did you download 7.8+patched 3.1?

Hey, I'm in south Florida, too. Luckily, I got power and DSL on Wednesday....
 
Gabe







PostPosted: Sun Oct 30, 2005 8:10 pm Reply with quote

well thanks for doing some digging on my ip, I got my power on friday, we went right though the hurricane eye here, i have a movie on my site of wilma that I took, www.alloutcomputers.net/downloads/wilma.wmv

anyway back on topic, I downloaded nuke from [ Only registered users can see links on this board! Get registered or login! ] and nukefix 3.1 from [ Only registered users can see links on this board! Get registered or login! ]
 
kguske







PostPosted: Sun Oct 30, 2005 8:24 pm Reply with quote

Actually, I registered for your site and saw the posts re: Wilma...

Let me duplicate what you've done - that will help me understand more (hopefully).
 
Gabe







PostPosted: Sun Oct 30, 2005 8:44 pm Reply with quote

you dont have to do what I've done, thats kinda alot of work, Iam working on installing sentinel right now, then if I have the weird tags thing again, we can turn off that wgysgy whatever thing, lol
 
kguske







PostPosted: Sun Oct 30, 2005 8:53 pm Reply with quote

Sorry - I meant that I will download the same scripts you did so I can see what's going on with TinyMCE.
 
Gabe







PostPosted: Sun Oct 30, 2005 8:57 pm Reply with quote

you can do it if you want
 
kguske







PostPosted: Sun Oct 30, 2005 9:34 pm Reply with quote

As I suspected, the code that determines whether or not to load the TinyMCE editor is in the includes/javascript.php file. It checks to see that you are not using the Private Messages or Forums modules before loading the TinyMCE code.

Can you email this file (includes/javascript.php) AFTER your Sentinel changes to me at kguske at bellsouth dot net (replacing appropriate words with appropriate symbols to get the real email address)?
 
Gabe







PostPosted: Sun Oct 30, 2005 9:45 pm Reply with quote

well i havent started to edit the files to finish the sentinel install yet, I will probally do that tomorrow since its getting late, do you want the javascript file before i edit it or after i edit it
 
kguske







PostPosted: Sun Oct 30, 2005 9:51 pm Reply with quote

After. No rush.
 
Gabe







PostPosted: Mon Oct 31, 2005 11:25 am Reply with quote

still havent started to edit the files yet, my site seems to be going up and down, waiting to here from my host, I dont think it has to do with the half done install of sentinel though
 
kguske







PostPosted: Mon Oct 31, 2005 3:55 pm Reply with quote

Sounds good. Let me know when you a ready...
 
Gabe







PostPosted: Mon Oct 31, 2005 5:28 pm Reply with quote

yea, there was a ddos attack on the server my site was hosted on, I can still get into the ftp so I'll go ahead and edit the file

anyway, I have a problem, when editing the mainfile7.8.txt. theres a small bug

Code:
#-----[ FIND ]------------------------------------------

#
if (defined('FORUM_ADMIN')) {
   @require_once("../../../config.php");
   @require_once("../../../db/db.php");
   @require_once("../../../includes/sql_layer.php");
   if (file_exists("../../../includes/custom_files/custom_mainfile.php")) { @include_once("../../../includes/custom_files/custom_mainfile.php"); }
   @require_once("../../../includes/ipban.php");
   if (defined('NUKE_HEADER') && file_exists("../../../includes/custom_files/custom_head.php")) { @include_once("../../../includes/custom_files/custom_head.php"); }
   if (defined('NUKE_HEADER') && file_exists("../../../includes/custom_files/custom_header.php")) { @include_once("../../../includes/custom_files/custom_header.php"); }
} elseif (defined('INSIDE_MOD')) {
   @require_once("../../config.php");
   @require_once("../../db/db.php");
   @require_once("../../includes/sql_layer.php");
   if (file_exists("../../includes/custom_files/custom_mainfile.php")) { @include_once("../../includes/custom_files/custom_mainfile.php"); }
   @require_once("../../includes/ipban.php");
   if (defined('NUKE_HEADER') && file_exists("../../includes/custom_files/custom_head.php")) { @include_once("../../includes/custom_files/custom_head.php"); }
   if (defined('NUKE_HEADER') && file_exists("../../includes/custom_files/custom_header.php")) { @include_once("../../includes/custom_files/custom_header.php"); }
} else {
   @require_once("config.php");
   @require_once("db/db.php");
   @require_once("includes/sql_layer.php");
   if (file_exists("includes/custom_files/custom_mainfile.php")) { @include_once("includes/custom_files/custom_mainfile.php"); }
   @require_once("includes/ipban.php");
   if (defined('NUKE_HEADER') && file_exists("includes/custom_files/custom_head.php")) { @include_once("includes/custom_files/custom_head.php"); }
   if (defined('NUKE_HEADER') && file_exists("includes/custom_files/custom_header.php")) { @include_once("includes/custom_files/custom_header.php"); }
}

Code:
#-----[ CHANGE TO ]------------------------------------------

#
if (defined('FORUM_ADMIN')) {
   @require_once("../../../config.php");
   @require_once("../../../db/db.php");
   @require_once("../../../includes/sql_layer.php");
   if (file_exists("../../../includes/custom_files/custom_mainfile.php")) { @include_once("../../../includes/custom_files/custom_mainfile.php"); }
   //@require_once("../../../includes/ipban.php");
   @include_once("../../../includes/nukesentinel.php");
   if (defined('NUKE_HEADER') && file_exists("../../../includes/custom_files/custom_head.php")) { @include_once("../../../includes/custom_files/custom_head.php"); }
   if (defined('NUKE_HEADER') && file_exists("../../../includes/custom_files/custom_header.php")) { @include_once("../../../includes/custom_files/custom_header.php"); }
} elseif (defined('INSIDE_MOD')) {
   @require_once("../../config.php");
   @require_once("../../db/db.php");
   @require_once("../../includes/sql_layer.php");
   if (file_exists("../../includes/custom_files/custom_mainfile.php")) { @include_once("../../includes/custom_files/custom_mainfile.php"); }
   //@require_once("../../includes/ipban.php");
   @include_once("../../includes/nukesentinel.php");
   if (defined('NUKE_HEADER') && file_exists("../../includes/custom_files/custom_head.php")) { @include_once("../../includes/custom_files/custom_head.php"); }
   if (defined('NUKE_HEADER') && file_exists("../../includes/custom_files/custom_header.php")) { @include_once("../../includes/custom_files/custom_header.php"); }
} else {
   @require_once("config.php");
   @require_once("db/db.php");
   @require_once("includes/sql_layer.php");
   if (file_exists("includes/custom_files/custom_mainfile.php")) { @include_once("includes/custom_files/custom_mainfile.php"); }
   //@require_once("includes/ipban.php");
   @include_once("includes/nukesentinel.php");
   if (defined('NUKE_HEADER') && file_exists("includes/custom_files/custom_head.php")) { @include_once("includes/custom_files/custom_head.php"); }
   if (defined('NUKE_HEADER') && file_exists("includes/custom_files/custom_header.php")) { @include_once("includes/custom_files/custom_header.php"); }
}

I dont have what it says to find, this is what I have

great the ftp is now down, so I cant show you waht I have, what I have is kinda like what is above but theres alot of spaces, I read on other forums and people have the same problem, can you help me[/code]
 
Gabe







PostPosted: Mon Oct 31, 2005 7:04 pm Reply with quote

i just managed to fix the weard tags and everything, I edited the javascript file wrong
 
kguske







PostPosted: Mon Oct 31, 2005 11:39 pm Reply with quote

Glad you found the javascript.php file issue. The one you sent looked fine. I just tested your site and TinyMCE is no longer appearing in the forums.

Regarding the mainfile changes, this post might help.
 
Gabe







PostPosted: Tue Nov 01, 2005 6:19 pm Reply with quote

the account page on my site isent working, everyone just gets a totally blank white page, people cant register, nor login, can you help, Iam not sure when I got this problem, i just emailed you my index.php file from /modules/Your_Account
 
kguske







PostPosted: Tue Nov 01, 2005 6:53 pm Reply with quote

If you access the page directly (http://alloutcomputers.net/modules/Your_Account/index.php) you'll see the problem - it's a parsing error on line 784, which is:
Code:
in function login($username, $user_password, $redirect, $mode, $f, $t, $random_num, $gfx_check) {

and should be
Code:
function login($username, $user_password, $redirect, $mode, $f, $t, $random_num, $gfx_check) {

Not sure where the "in" came from, but removing it should fix this problem.
 
Gabe







PostPosted: Tue Nov 01, 2005 7:08 pm Reply with quote

that dident fix it Crying or Very sad
 
kguske







PostPosted: Tue Nov 01, 2005 7:15 pm Reply with quote

Still showing the same error. Actually, upon closer review, you should remove the whole line 784.
 
Gabe







PostPosted: Tue Nov 01, 2005 7:24 pm Reply with quote

still dident fix, sorry to bug you
 
kguske







PostPosted: Tue Nov 01, 2005 7:33 pm Reply with quote

Did you try to load the page directly (http://alloutcomputers.net/modules/Your_Account/index.php)? It now shows a parsing error on line 899.

Delete this line:
Code:
in function userinfo($username, $bypass=0, $hid=0, $url=0) {

around line 882 in the file you previously sent, but it could now be 899...
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> phpnuke 7.8

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©