Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ Bug Reports
Author Message
evaria
New Member
New Member


Joined: Mar 07, 2005
Posts: 10

PostPosted: Mon Mar 07, 2005 7:46 pm Reply with quote

Hi all,
Seems I have a problem. I upgraded sentinel today from 2.1.3 to 2.2.0 and since the upgrade htaccess on my site isn't working at all. I went so far as to completely remove sentinel and reinstall it 5 times. After 5 hours of dealing with all this im about fedup and ready to dump my site and go with HTML.

As it stands my site is running 7.5.0.2.9 which I downloaded from either nukescripts.net or nukecode.com can't remember. All the latest NSN modules including downloads, center blocks, supporters and news. I ran the site with 2.1.3 for about 2 hours with all the new stuff and everything was fine and dandy as soon as I upgraded to 2.2.0 no htaccess and Ideas about what could be wrong would be greatly appreciated.

Thanks in advance
 
View user's profile Send private message
evaria
PostPosted: Mon Mar 07, 2005 7:51 pm Reply with quote

I should add that I didn't change anything in the htaccess file or change the file itself and as I said it worked fine before the upgrades
 
CurtisH
Life Cycles Becoming CPU Cycles


Joined: Mar 15, 2004
Posts: 638
Location: West Branch, MI

PostPosted: Mon Mar 07, 2005 8:11 pm Reply with quote

I had to revert back to 2.1.3 myself... 2.2.0 was giving me quite a bit of trouble. I will have to wait for replies in my help request. I couldn't get it block IP's other than via htaccess (manually or automatically) even after removing all components and reinstalling 7 times. It just would add the IP's to the database. Plus there was the Forum admin issue that I like to have never gotten resolved. I imagine I did something wrong somewhere but cannot figure out what for the life of me. *LOL*

_________________
Those who dream by day are cognizant of many things which escape those who dream only by night. ~Poe 
View user's profile Send private message Visit poster's website Yahoo Messenger
grantb
Regular
Regular


Joined: Feb 16, 2005
Posts: 67
Location: Canada

PostPosted: Tue Mar 08, 2005 2:50 am Reply with quote

I have found the HTTP Auth not working at all as well..after upgrade from 2.1.3 to 2.2.0 shows all passwords set and path is ok...i hope there is an fix for this? by the way.. php-nuke7.4(2.9) bbtonuke2.13
 
View user's profile Send private message
DaveTomneyUK
Hangin' Around


Joined: Sep 27, 2003
Posts: 49

PostPosted: Tue Mar 08, 2005 5:29 am Reply with quote

I maybe wrong but does it not say that Sentinel 2.2.0 is only for PHP-Nuke 7.1 and 7.6 running the ChatServ patch 2.9? As I run PHP-Nuke 7.6 with Patch 2.9 and it works fine.

_________________
Image
Only registered users can see links on this board! Get registered or login! - Only registered users can see links on this board! Get registered or login! - Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message
evaria
PostPosted: Tue Mar 08, 2005 7:13 am Reply with quote

Quote:
I maybe wrong but does it not say that Sentinel 2.2.0 is only for PHP-Nuke 7.1 and 7.6 running the ChatServ patch 2.9? As I run PHP-Nuke 7.6 with Patch 2.9 and it works fine.


Glad it works for ya... BUT it's meant for 7.x 2.9
 
evaria
PostPosted: Tue Mar 08, 2005 10:32 am Reply with quote

I thought if I posted my htaccess files contents it might help. So here they are:
Code:
<Files 403.shtml>

order allow,deny
allow from all
</Files>

deny from 200.176.3.142
deny from 200.177.162.127
deny from 200.101.197.249
deny from 195.239.237.98
deny from 213.30.159.52
deny from 201.4.40.49
deny from 69.56.181.122
deny from 66.82.9.83
deny from 200.100.41.79
deny from 201.7.49.147
deny from 200.180.18.123
deny from 69.93.7.146
deny from 213.186.42.47
deny from 200.226.137.9
deny from 209.202.218.12
deny from 200.227.112.169
deny from 81.208.22.98
deny from 201.3.47.185
deny from 200.160.2.15
deny from 201.9.9.140
deny from 24.56.17.114
deny from 68.51.252.87
deny from 195.43.41.107


Yes there is a blank line at the end of it.
Someone please help a girl out Smile
 
DaveTomneyUK
PostPosted: Tue Mar 08, 2005 11:36 am Reply with quote

I know an easy way to test if your htaccess file works try put this in your file

Code:


deny from all


In your root folder and when you goto your site is should say forbidden to everyone. Then you will know your htaccess file works.
 
evaria
PostPosted: Tue Mar 08, 2005 12:00 pm Reply with quote

It worked before the NukeSentinel Upgrade. Since the upgrade it doesn't and it has not changed so I think it would be safe to assume the htaccess file itself does work. FYI I removed 2.2.0 and replaced it with 2.1.3 and the htaccess started working... I put back 2.2.0 and it stopped. Same File 2 different versions. Works fine with one doesn't work with the other.
 
grantb
PostPosted: Wed Mar 09, 2005 1:26 pm Reply with quote

Well I guess it's time to look for an alternative solution. I think I will try Admin Secure. I don't know what else to do. Thanks anyways...
 
CurtisH
PostPosted: Wed Mar 09, 2005 2:24 pm Reply with quote

evaria wrote:
It worked before the NukeSentinel Upgrade. Since the upgrade it doesn't and it has not changed so I think it would be safe to assume the htaccess file itself does work. FYI I removed 2.2.0 and replaced it with 2.1.3 and the htaccess started working... I put back 2.2.0 and it stopped. Same File 2 different versions. Works fine with one doesn't work with the other.


Same issue here. Had to switch back to 2.1.3 as well as HTTPAuth stopped working with 2.2.0, meaning that I no longer got the pop up request for username and pass.
 
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Fri Mar 11, 2005 5:56 am Reply with quote

question is ,does everybody has this problem or just some of us...
im just waiting with the upgrade...
 
View user's profile Send private message
evaria
PostPosted: Fri Mar 11, 2005 6:49 am Reply with quote

Anyone???? Have an answer to this I went back to 2.1.3 had nothing but problems with the site
 
CurtisH
PostPosted: Fri Mar 11, 2005 8:41 am Reply with quote

Look at this thread, it might help you
Only registered users can see links on this board! Get registered or login!
 
evaria
PostPosted: Sun Mar 13, 2005 9:38 am Reply with quote

Thanks but during the time I was waiting for someone to help me. My site was hacked and totally whiped out. A WEEK IS A BIT LONG TO BE WAITING FOR SOMETHING AS IMPORTANT AS THIS. So I am going back to good ole HTML. The whole experience I had with PHP Nuke was nightmarish to say the least. Patch this, upgrade that it made the entire experience of owning a site kinda tedious. I patched my site to 2.9 and viola found the forums didn't work Crying or Very sad Fixed that problem then found other things didn't work. Im not saying PHP Nuke isn't a good thing. But in my mind it isn't a primetime player yet. Too many bugs and too easy even with sentinel to exploit. PLAIN OLD HTML HERE I COME!!!!!
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Sun Mar 13, 2005 3:02 pm Reply with quote

Not sure how you calculate that you were waiting a week. You were being helped as you posted your issues. There are thousands of people using Nuke and NukeSentinel w/o any problems so it does make it a tedious process to resolve when a particular site is having problems. I would try to determine how the hack occurred befor throwing the baby out with the bath water and assuming one thing or another.
 
View user's profile Send private message
CurtisH
PostPosted: Sun Mar 13, 2005 3:22 pm Reply with quote

evaria wrote:
Thanks but during the time I was waiting for someone to help me. My site was hacked and totally whiped out. A WEEK IS A BIT LONG TO BE WAITING FOR SOMETHING AS IMPORTANT AS THIS. So I am going back to good ole HTML. The whole experience I had with PHP Nuke was nightmarish to say the least. Patch this, upgrade that it made the entire experience of owning a site kinda tedious. I patched my site to 2.9 and viola found the forums didn't work Crying or Very sad Fixed that problem then found other things didn't work. Im not saying PHP Nuke isn't a good thing. But in my mind it isn't a primetime player yet. Too many bugs and too easy even with sentinel to exploit. PLAIN OLD HTML HERE I COME!!!!!




Did you buy your Nuke from someone here? If so then maybe that attitude is ok, but if not...well no one here owes you anything. I can understand your frustration, but please do not take it out on us. We all help when we can. Sometimes (many actually) our personal lives take so much of our time we are unable to reply in as quick of a manner as we would like.

Now in regards to your hacked site. Do you make daily backups of your database and your root directory like the rest of us? That is a key responsibility of any webmaster. Restoring a back up would have fixed your hacked site immediately.

As for whether or not Nuke is ready for prime time...well that is indeed a matter of opinion. Many have no problems at all providing they perform the normal duties of a conscientious webmaster (i.e. backups before upgrading or patching). I have also seen many that DO have problems which usually are the outcome of either making a mistake or NOT managing backups.

I am sorry that Nuke isn't your cup of tea. It definitely is not for everyone. Personally I enjoy working with it and helping others where and when I can. I don't always have the answers though and troubleshooting across the net via a message board can sometimes be tricky. Can I get an amen? *LOL*

No flame intended. I just too frequently see posts that appear to be "biting" when in all honesty it is unjust.

Hope I didn't offend anyone. Smile
 
labadore
New Member
New Member


Joined: Mar 28, 2005
Posts: 9
Location: Los Angeles

PostPosted: Mon Mar 28, 2005 2:24 am Reply with quote

I just upgraded sentinel from 2.1 to 2.2 and upgraded chatserv 2.8 to 2.9....Im running 7.6 platinum and now all of a sudden I cannot add blocks....I'm so screwed because I had everything working prior to this move...I had a bad feeling about updating the two at the same time and now I dont know which one is causing my problem since Im not very knowledgable with php. Does anyone know why I cannot add blocks? Any help is greatly appreciated!!!! I searched the web and found posts reffering to the nuke_blocks table having extra fields but my fields seem normal. I did look in the blocks.php and noticed a variable was missing that was in the table, think it was groups. Couldnt find anything about this though so I dont know if its a bug...Ive searched the web all day saturday to fix it and now its sunday night and since I cant find the answer....i said what the hell and decided to finally post =)


also does sentinel effect (add fields) to any tables that came with 7.6 platinum or does it just add its own tables to the db?

And if this bug is off the wall without an easy fix, is there anyway to back out of chatserv 2.9 and sentinel 2.2 without hours and hours of work and wiping out the database?

Please Help

Its probably something stupid I did that you guys will recognize.

THANK YOU IN ADVANCE!!!
 
View user's profile Send private message
hitwalker
PostPosted: Mon Mar 28, 2005 4:52 am Reply with quote

well im not sure but it could be caused by your blocks file in admin/modules/blocks.php
so try using your old blocks.php
 
Raven
PostPosted: Mon Mar 28, 2005 9:37 am Reply with quote

NukeSentinel does NOT add any fields to any existing nuke tables. To verify if NukeSentinel is a part of the cause, simply edit the NukeSentinel code that you added to your mainfile.php.
 
labadore
PostPosted: Mon Mar 28, 2005 10:27 am Reply with quote

Raven I did what you said and removed that chunk of code added to mainfile.php and I still cannot add blocks. I guess it's not sentinel, it must of been my chatserv 2.9 upgrade. hitwalker on saturday I tried all day removing the new blocks.php from 2.9 and replacing with the old one from 2.8 but still could not add blocks. I just realized, when I converted from nuke 7.5 to 7.6 platinum, I had not tried to add any new blocks until after I made the chatserv 2.9 switch..These are the fields I have in the nuke_blocks table....

bid
bkey
title
content
url
bposition
weight
active
refresh
time
blanguage
blockfile
view
groups
expire
action
subscription
display
-----------------------------
these are the parameters I have in the blocks.php BlocksAdd function....

function BlocksAdd($title, $content, $url, $bposition, $active, $refresh, $headline, $blanguage, $blockfile, $view, $expire, $action, $subscription) {


seems like groups is missing....Im not sure and Im probably on a wild goose chase but....if someone can please help me figure out why I cannot add blocks it would be much appreciated.....thank you soooo much!!!!!!
 
Raven
PostPosted: Mon Mar 28, 2005 10:32 am Reply with quote

Have you reviewed your server error log to see if any messages are being written to the log?
 
labadore
PostPosted: Mon Mar 28, 2005 11:01 am Reply with quote

can you please tell me where to find that, I certainly will check...


is that built into phpnuke or do I have to goto my hosting provider for that?
 
Raven
PostPosted: Mon Mar 28, 2005 11:26 am Reply with quote

Normally you have access to your server access and error logs via your control panel, like cPanel, Plesk, etc.
 
labadore
PostPosted: Mon Mar 28, 2005 11:45 am Reply with quote

my host, webhost4life, said this...


customer will not have direct access to the server error log,

can you tell us if there is anything else we can help you with, thanks!
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ Bug Reports

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©