Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Cache Lite Admin Module
Author Message
Nomad
Client


Joined: Jan 21, 2006
Posts: 87
Location: Arizona

PostPosted: Wed Jun 14, 2006 12:00 am Reply with quote

Just installed cache light and the admin module. Worked exceptionally well. I experienced the following errors.

  1. The first time I installed the cache on some blocks, I experienced an error, forgot the exact syntax but it basically said that the cache file didnt exist. I refreshed the page a few times and I started up (i got the refresh icon and properties icon).
  2. I couldnt not establish the cache on the following blocks, period: RN Forums Collapsing Block, Fourms Survey block and The Sommaire Menu Block. I get an error like this
    Code:
    
    
    Fatal error: Call to undefined function: sommaire_is_user() in /home/nomad76/public_html/blocks/block-Sommaire.php on line 60

  3. All the modules worked fine except when I tried to access a module that uses a seperate database (other than the nuke database). Specifically, my gallery2 module became inaccessable, with the following error.
    Code:
    Query failed for block-ChatView.php. MySQL said: Table 'xxx_xxxx_gal2.nuke_rpscachelite' doesn't exist
    This error will propigate down to each block as I disable its predicessor. I assumed that the cause was the different database. I havnt figured out how to fix this yet. The encryptions makes it difficult to troubleshoot. I just copied the 'nuke_rpscachelite' table into my other databases. Now its oK

  4. The mod cut my site load time by about 6 seconds


Great job! More instruction would have been nice. It left a lot to assumption, but I figured it out. The grey area I had was in setting the block cache time. I had to assume that if you left the input field blank, it will use the default value. Usually when a value is default, it either isnt asked of you or is already filled in.
For the purpose of troubleshooting, a master on/off switch would be nice.

I know this is a lot, but you asked for feed back Dance-Stick

_________________
Nomad!~! 
View user's profile Send private message Visit poster's website AIM Address
natbur
New Member
New Member


Joined: May 21, 2007
Posts: 2

PostPosted: Mon May 21, 2007 11:13 am Reply with quote

The admin.php is hardcoded in the script, this completely disables the script for those of us who renamed our admin files. any call to the admin file should use the global $admin_file variable.
 
View user's profile Send private message
gregexp
The Mouse Is Extension Of Arm


Joined: Feb 21, 2006
Posts: 1497
Location: In front of a screen....HELP! lol

PostPosted: Tue May 22, 2007 7:41 am Reply with quote

What is this post in relationship to?

It just appears to be out of nowhere and posted in a weird place, thanks.

_________________
For those who stand shall NEVER fall and those who fall shall RISE once more!! 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9453
Location: Arizona

PostPosted: Wed May 23, 2007 5:51 am Reply with quote

gregexp, this is in relationship to the cache lite module and a thread where feedback is being requested by Raven, so, this is in the right place. However, I'll be honest, I have no heard Raven talk about Cache Lite in a very, very, very long time.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
natbur
PostPosted: Fri May 25, 2007 9:29 pm Reply with quote

Yeah, it would appear that I revived the thread from beyond the grave. I ended up just installing cache lite manually, works well that way.
 
sexycoder
Spammer and overall low life


Joined: Feb 02, 2009
Posts: 82

PostPosted: Fri Jun 19, 2009 5:51 am Reply with quote

Where can I download it? I would like to try it to see how it goes. I guess nuke evo already implemented.
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sat Jun 20, 2009 8:56 pm Reply with quote

Only registered users can see links on this board! Get registered or login!

I haven't looked at this in a long while but I still use it on my sites.
 
View user's profile Send private message
sexycoder
PostPosted: Sun Jun 21, 2009 4:22 am Reply with quote

I am really interesting on this addon Raven. Can u please take care of this important file for a future use. Thanks for that link. I will test it in order to see the results.

One question:

I noticed this addon is protected with IONCUBE. Why do you protect such an addon?

I am affraid to install it because I really dont like IONCUBE. This is not your case I suppose but what about if a hacker hide codes which calls others in order to steal password or redirect spam. I dont understand why it is so protected. . Can u imagen if They start protecting linux operating system. Nobody could ever modify or improve it. That is why Windows OS has so many problems. Now since Windows 7 u can download it for free people are allow it to make it more beautiful and i think Windows 7 will rock. I tested with just 512Mb and it is working much better than windows vista.

Can u imagen if FB (who never give the right support as you are doing here) protected phpnuke with IONCUBE, phpnuke could desapear since nobody could ever modify it or improve it. Sometimes I think you are the owner of phpnuke because of the amazing support u are giving to the community here. I appriciate it so much.

Can u imagen if you can not take care of this file anymore? It is happening and we will depend on you all the time since nobody is improving it because of the protection. Just my opinion.
 
sexycoder
PostPosted: Sun Jun 21, 2009 5:48 am Reply with quote

Shocked These are the first errors I get after clicking on Cache Lite Admin Menu. This is what I mean. How can I fix this if init.php is protected by ioncube. I hate IONCUBE.

Refering to this post
Only registered users can see links on this board! Get registered or login!

I dont have those files from the link u show me here. I know something is missing but where are these files? I dont have them. Shocked

Code:
Warning: require_once(includes/Cache_Lite/Lite.php) [function.require-once]: failed to open stream: No such file or directory in home/admin/modules/rpscachelite/init.php on line 15


Fatal error: require_once() [function.require]: Failed opening required 'includes/Cache_Lite/Lite.php' (include_path='.:/php5/lib/php/')



Can u please zip those fies from include/ Cache_Lite folder and send it to ?
 
Raven
PostPosted: Sun Jun 21, 2009 9:50 am Reply with quote

IonCube is pretty much a/the standard as it is used in major applications all over the world. It protects Intellectual Property. Zend has an encoder as well as SourceGuardian, NuSphere, and several other companies. This application is not GPL and is available for purchase. Obviously you would not want to trust any application, whether encoded or not, from an untrusted source. Comparing this to Operating Systems is comparing apples and oranges. I do not intend for people to modify and/or improve it Smile. If there are needed/wanted changes then just submit them and I will look into it.

RTM As to files you are missing, please refer to the README and see this statement:
[USAGE]
This assumes that the Cache_Lite package is installed in the "includes" folder of phpNuke


You have to d/l the Cache_Lite package from Only registered users can see links on this board! Get registered or login! and install it according to the instructions. All other files are included in my package. That way you always have the latest and greatest from the author of the Cache_Lite package.
 
Raven
PostPosted: Sun Jun 21, 2009 10:04 am Reply with quote

I just looked at the latest release of Cache_Lite and it may not be compatible with my admin wrapper. I will look into this when I have time.
 
sexycoder
PostPosted: Sun Jun 21, 2009 1:20 pm Reply with quote

What version u choose to make it comatible. Where can I get that version. I hope you make it compatible. Thanks for explanation and reply. Do u have the old package that was compatible with your addon? I cant find those files. Shocked
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Cache Lite Admin Module

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©