Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
NoDialtone
New Member
New Member


Joined: Aug 21, 2004
Posts: 2

PostPosted: Sat Aug 21, 2004 5:17 pm Reply with quote

I installed sentinel and followed all instructions (in the manual, and in the forums, and the faq at the end of the manual.) When I include the line
Code:
include("includes/sentinel.php");

i get a blank page. However when i dont include that line, my site works but sentinel doesnt. I double checked to make sure that i didnt make any typos in any of the file edits.

Here's what i'm using:
Chatserv's Phpnuke patched 7.1 v2.5
NukeSentinel 2.01

Its a fresh install with no users yet. Any help would be appreciated.

No Dialtone
 
View user's profile Send private message
NoDialtone
PostPosted: Sat Aug 21, 2004 5:26 pm Reply with quote

Ahh, fixed it. The problem was that the Force URL option doesnt work with URL forwarding services like no-ip.com. I disabled it and all works fine.
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sun Aug 22, 2004 9:50 pm Reply with quote

Thanks for the update. We will include this in the FAQ!
 
View user's profile Send private message
TheVillageIdiot
New Member
New Member


Joined: Sep 07, 2004
Posts: 13
Location: Bay Area of California

PostPosted: Tue Sep 07, 2004 6:53 pm Reply with quote

I'm having an identical problem on my own nuke site, but this Force URL thing seems to be off. I can't even get far enough so that I can get into the config. I've added you to my Y! list, Raven, so we can troubleshoot in real time, and once we find a solution I'll post it here...

Unless someone else happens to know a solution.

The problem in a nutshell: Include anything to the effect of sentinel.php in the mainfile.php, and everything that uses mainfile.php on my site returns a completely blank page. This is a brand new, fresh install of NSN Sentinel on a PHPNuke 7.3 website.

Currently, my website has the include script commented out so that my users can still visit the site. But I really would like to get Sentinel working to secure my page.
 
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
Raven
PostPosted: Tue Sep 07, 2004 7:53 pm Reply with quote

Are you using PHP5, perchance?
 
TheVillageIdiot
PostPosted: Tue Sep 07, 2004 8:10 pm Reply with quote

Currently running PHP version 4.3.8. The only unique thing I may have that others do not is output_buffering on in my php.ini, which is required for my forum arcade to work properly. I don't believe that would be what is causing it.

Why aren't you on Y! buddy? Smile
 
Raven
PostPosted: Tue Sep 07, 2004 8:27 pm Reply with quote

Busy with something else right now. This exact behavior occurs in PHP5 because MySQL is no longer compiled in and has to be set in the php.ini. I would turn display_errors to On and also check your error logs.
 
TheVillageIdiot
PostPosted: Tue Sep 07, 2004 9:42 pm Reply with quote

I have turned display_errors on and have checked my errors log, neither has outputted anything when I receive the blank page. Bang Head

Hm, I'm curious, but the original poster said he fixed it by disabling Force URL. That would be the variable contained within nsnns_config's table that defaults to 0 on install, right? Just want to make sure I am not overlooking his solution.
 
Tao_Man
Involved
Involved


Joined: Jul 15, 2004
Posts: 252
Location: OKC, OK

PostPosted: Tue Sep 07, 2004 10:05 pm Reply with quote

TheVillageIdiot wrote:


Hm, I'm curious, but the original poster said he fixed it by disabling Force URL. That would be the variable contained within nsnns_config's table that defaults to 0 on install, right? Just want to make sure I am not overlooking his solution.


That would be the one.

_________________
------------------------------------------
To strive, to seek, to find, but not to yield!
I don't know Kara-te but I do know cra-zy, and I WILL use it! 
View user's profile Send private message Visit poster's website
TheVillageIdiot
PostPosted: Tue Sep 07, 2004 10:14 pm Reply with quote

Then it appears not to be the solution because I can't even get to the point in config where I can change that to positive without editing my database directly... Bang Head

Any other ideas? Raven?
 
blith
Client


Joined: Jul 18, 2003
Posts: 977

PostPosted: Wed Sep 08, 2004 8:04 am Reply with quote

TheVillageIdiot wrote:
Then it appears not to be the solution because I can't even get to the point in config where I can change that to positive without editing my database directly... Bang Head

Any other ideas? Raven?

I am sorry to be OT but you took for your user name my rank... very interesting...
 
View user's profile Send private message Visit poster's website
Tao_Man
PostPosted: Wed Sep 08, 2004 8:23 am Reply with quote

Check for blank lines after the closing ?> tag in the sentinel.php files, also in mainfile.php.

I don't know but I had some strange problems caused by blank lines at the end of files.

Also check the language files for blank lines.
 
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Wed Sep 08, 2004 8:24 am Reply with quote

I have to ask which version of Nuke Sentinel you are using because in the current version
include("includes/sentinel.php");
was changed to
if ($forum_admin == 1) {
include("../../../includes/sentinel.php");
} elseif ($inside_mod == 1) {
include("../../includes/sentinel.php");
} else {
include("includes/sentinel.php");
}

Which fixed some issues with Forums and Modules.

_________________
[b][size=5]openSUSE 11.4-x86 | Linux 2.6.37.1-1.2desktop i686 | KDE: 4.6.41>=4.7 | XFCE 4.8 | AMD Athlon(tm) XP 3000+ | MSI K7N2 Delta-L | 3GB Black Diamond DDR
| GeForce 6200@433Mhz 512MB | Xorg 1.9.3 | NVIDIA 270.30[/size:2b8 
View user's profile Send private message
TheVillageIdiot
PostPosted: Wed Sep 08, 2004 2:40 pm Reply with quote

Tao, I've checked both mainfile.php and sentinel.php for blank lines several times, and it did not work this time either. Sad

The language files should be fine because phpnuke still functions perfectly when I do not add the includes to the mainfile.php. Unless I am not thinking of a new a language file that is called upon in sentinel.php.

six, I have Nuke Sentinel version 2.0.2. I've tried both methods of includes, both result in the same identical problem.
 
Raven
PostPosted: Wed Sep 08, 2004 3:14 pm Reply with quote

With the line commented out, are you able to access your Nuke Preferences panel and make changes?
 
TheVillageIdiot
PostPosted: Wed Sep 08, 2004 4:52 pm Reply with quote

Yes, but obviously the Nuke Sentinel part of the admin panel (that appears as _AB_NUKESENTINEL) isn't available without sentinel.php included... Everything else functions fine in the admin panel from what I can tell.
 
TheVillageIdiot
PostPosted: Wed Sep 08, 2004 4:57 pm Reply with quote

When trying to access "_AB_NUKESENTINEL" in the admin panel with the includes commented out, I get
Quote:
Fatal error: Call to undefined function: abget_configs() in /home/xioust2/public_html/dht/admin/modules/sentinel.php on line 29
 
Raven
PostPosted: Wed Sep 08, 2004 5:58 pm Reply with quote

I said the Nuke Preferences panel, not the Sentinel Admin panel.
 
sixonetonoffun
PostPosted: Wed Sep 08, 2004 6:48 pm Reply with quote

Most often I've seen this sort of thing happen is when the Original sec codes in phpnuke are commented out instead of removed or left alone. Comments are closed in the middle of some of default phpnuke sec filters which creates a parse error. But you say you say no erros are showing in the error log so I'm running out of ideas here. Maybe if we're lucky Raven will have some.
 
TheVillageIdiot
PostPosted: Wed Sep 08, 2004 9:13 pm Reply with quote

Sorry, I wasn't specific... Raven, I meant that I could get into the preferences, but not into the Sentinel Admin panel.

So yes, I can get into the Nuke Preferences panel.
 
TheVillageIdiot
PostPosted: Wed Sep 08, 2004 9:14 pm Reply with quote

Original sec codes!? You mean the security code when you login or register? I have that disabled completely on my forums... Along with e-mail verification. I didn't think that would cause it. Is that what you meant, six?
 
Raven
PostPosted: Wed Sep 08, 2004 9:16 pm Reply with quote

But can you make changes and save them? Sorry but debugging is a process of elimination. Also, are you sure when you ran the NukeSentinel install program (nsnst.php) that there weren't any errors? This is acting like a database connection issue, sortof. You might try deinstalling and reinstalling the database tables.
 
TheVillageIdiot
PostPosted: Wed Sep 08, 2004 9:29 pm Reply with quote

The database is most definately working, and it all installed fine. The tables are named dhtnuke_whatever because my $prefix is dhtnuke, and I proofread through all sentinel's files to make sure the nuke_ prefix wasn't required. I'll check that I can change the preferences right now.

Oh, and don't say sorry, I'm thankful for any help you can give me at all Smile
 
TheVillageIdiot
PostPosted: Wed Sep 08, 2004 9:32 pm Reply with quote

Yes, I can change settings in my preferences in the nuke admin panel. Bang Head
 
sixonetonoffun
PostPosted: Wed Sep 08, 2004 9:50 pm Reply with quote

Sorry for jumping in and out here. I meant the security filters at the beginning of mainfile.php Uniontap and $_GET/$_POST filters. Sometimes people choose to comment those out thinking they don't need them anymore (which really if the proper Nuke Sentinel filters are enabled they don't) but what happens is that this throws a parse error because single comment chars exist inside the filters and that would definetly show in the error logs if not on the pages. So with that I'll jump back out of the topic unless I come up with something better to contribute.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©