Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> PHPBB
Author Message
tora
New Member
New Member


Joined: Jul 05, 2010
Posts: 1
Location: Amsterdam

PostPosted: Mon Jul 05, 2010 6:39 am Reply with quote

Hi,

First I want to say "thank you" for this fantastic free cms! I am playing now with on a test box and I am impressed.

Reason for my post: I just looked at the forum admin interface and there it said phpbb 2.0.23 and that my installation was up2date.

I thought that phpbb 2.x had a load of security issues or did you do some coding magic to remove those issues? wuvUbaby

Just thinking about script kiddies, hence the question.
 
View user's profile Send private message
spasticdonkey
RavenNuke(tm) Development Team


Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Mon Jul 05, 2010 7:11 am Reply with quote

phpbb 2.0.23 is the latest in the phpbb2 series, which is no longer being developed, but still being used by many sites... including some of my own, no worries Wink
 
View user's profile Send private message Visit poster's website
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Mon Jul 05, 2010 9:11 am Reply with quote

The RN Team kept up on all the patches, as well as added a few fixes of their own. :-;

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Palbin
Site Admin


Joined: Mar 30, 2006
Posts: 2583
Location: Pittsburgh, Pennsylvania

PostPosted: Mon Jul 05, 2010 11:03 am Reply with quote

We are working on a move to PHPBB3, but it will not integrate into the site as seamlessly as phpBB2 did. The reason is so that it is easy to upgrade when phpBB comes out with updates and so mods will not need rewritten.

_________________
"Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." — Brian W. Kernighan. 
View user's profile Send private message
thumpn8974
Worker
Worker


Joined: Feb 09, 2011
Posts: 188
Location: US

PostPosted: Wed Sep 14, 2011 1:06 pm Reply with quote

I am running Ravenuke 2.40.01 on my server, and I too have phpbb 2.0.23 as my forum version. Is there updates out there, and if so, where are they, and what do I need to do to install them or update them?
I was looking on this website Only registered users can see links on this board! Get registered or login! (I hope I am allowed to post it) and he said he is working on phbb3 integrated module. So, should I just wait till he completes that? Or has someone already done it?

Here is the
 
View user's profile Send private message Visit poster's website Yahoo Messenger
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Wed Sep 14, 2011 2:23 pm Reply with quote

@ thumpn8974 - if you are using RN 2.40.01 then it includes the last version of phpBB 2.x series that was released, plus further fixes and compliance stuff as already mentioned in a previous post in this thread by Montego

Regarding phpBB 3.x Palbins post was made on July 5th, the news article you linked to is dated July 29th. Even if RN uses phpBB 3.x as a module at some point in the future, I personally doubt it will ever be completely 'integrated' into RN. It isn't a question of not being able to do it (from a technical standpoint), it is simply because a bridge (as against full integration) is much easier from a maintenance perspective.
With phpBB 2.x pretty much every add-on released for phpBB 2.x had to be specifically ported (modified) to work with RN. That causes maintenance headaches when upgrading RN and also when patches etc were released for phpBB 2.x

I cannot speak for the RN Team or anyone else but that's one merry-go-round I would prefer not to get back on. I want to spend time using my site, not having maintenance headaches.
 
View user's profile Send private message Send e-mail
thumpn8974
PostPosted: Wed Sep 14, 2011 6:25 pm Reply with quote

I understand, and thank you for your insight. So, should I use the bridge that they have for phpbb to nuke? If I do use the bridge, what is added or changed? If that isn't a big answer?
 
Guardian2003
PostPosted: Wed Sep 14, 2011 10:45 pm Reply with quote

Which of the two options you use is really down to personal preference. I have no need for multiple different Forum add-ons so I'm quite happy to use what currently ships with RN and wait for whatever the RN Team decide to use.
If I just had to have phpBB 3.x I would use a bridge or install phpBB 3.x as a seperate piece of software or wait a few weeks to see what bobby (from the news article link you posted) comes up with.
 
thumpn8974
PostPosted: Thu Sep 15, 2011 4:49 am Reply with quote

Is there a new version of RN coming out soon?
 
nuken
RavenNuke(tm) Development Team


Joined: Mar 11, 2007
Posts: 2024
Location: North Carolina

PostPosted: Thu Sep 15, 2011 4:55 am Reply with quote

Just to let you know, we are working on a bridge module for phpBB3. It will not be a full integration. It will share the RN users and theme to an extent. This is not going to be a full integration due to the reasons mentioned above about the headache involved with updating and modifying. Once RavenNuke 2.50 is released, work will continue on the phpBB3 bridge for RN.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Thu Sep 15, 2011 9:37 am Reply with quote

Quote:
Is there a new version of RN coming out soon?


The RN team is working on the release right now. Issues are being closed down and final testing will take place soon. Can't put a date on it because all the bugs are out when they are out.
 
View user's profile Send private message Visit poster's website
thumpn8974
PostPosted: Thu Sep 15, 2011 9:30 pm Reply with quote

Thanks for the information, I am looking forward to it.
 
duck
Involved
Involved


Joined: Jul 03, 2006
Posts: 273

PostPosted: Thu Sep 15, 2011 10:25 pm Reply with quote

Joe Moth: oooh shiny new phpbb number 3 buzzzzzz ZZZZZAPPP! d*** bug zappers!
Fred Moth: oooh loook is that a shiny 4 I see in the distance bzzzzz ZZZZAPPP! Oh Sh@#$
 
View user's profile Send private message
mike63740
Worker
Worker


Joined: Jun 21, 2010
Posts: 101

PostPosted: Thu Nov 02, 2017 4:05 am Reply with quote

I am currently working with a new installation of RavenNuke 2.51 in XAMPP. So far I have restored settings, folders and files from an older installation of RavenNuke 2.51.

My phpBB Reads:

Version Information

Your installation does not seem to be up to date. Updates are available for your version of phpBB, please visit Only registered users can see links on this board! Get registered or login! to obtain the latest version of BBToNuke (the ported version of phpBB files for phpNuke).
The latest available version is phpBB 7.2.0. You are running phpBB 2.0.23.

When I click the link http://www.nukeresources.com to update phpBB 2.0.23, I get a web page in a foreign language.

Where should I go from here?
 
View user's profile Send private message
neralex
The Mouse Is Extension Of Arm


Joined: Aug 22, 2007
Posts: 1328
Location: Germany

PostPosted: Thu Nov 02, 2017 5:55 am Reply with quote

The used phpBB-version in RN is a highly modified/patched bridge between the CMS and the forums-software. Its working well and its secured as possible.

If you would update the integrated version, then you would brick the whole functionality of this bridge and you would open many closed security holes. As Guardian mentioned, the effort is not comparable to patch a newer version to the current level of the integrated version.

In short: leave as it is - it's fine.
 
View user's profile Send private message
Guardian2003
PostPosted: Thu Nov 02, 2017 7:24 am Reply with quote

phpBB no longer support version 2.x so we are stuck with the phpBB ported version, which is at 2.0.23
The Nuke Resources website looks like it has changed ownership so you can safely ignore those version messages.
The ported (modified phpBB form) used in RavenNuke (tm) 2.5x is as safe and stable as we can make it and should work for a long time to come if there are no significant changes to the PHP programming language it uses.
 
mike63740
PostPosted: Fri Nov 03, 2017 2:15 am Reply with quote

This I like:

Guardian2003 wrote:
I have no need for multiple different Forum add-ons so I'm quite happy to use what currently ships with RN and wait for whatever the RN Team decide to use.


I hoped this was the case with phpBB 2.0.23:

neralex wrote:
The used phpBB-version in RN is a highly modified/patched bridge between the CMS and the forums-software. Its working well and its secured as possible.

In short: leave as it is - it's fine.


Valuable and comforting information:

Guardian2003 wrote:
The Nuke Resources website looks like it has changed ownership so you can safely ignore those version messages.
The ported (modified phpBB form) used in RavenNuke (tm) 2.5x is as safe and stable as we can make it and should work for a long time to come if there are no significant changes to the PHP programming language it uses.


Thank you all. Confused
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> PHPBB

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©