Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
BobMarion
Former Admin in Good Standing


Joined: Oct 30, 2002
Posts: 1037
Location: RedNeck Land (known as Kentucky)

PostPosted: Fri Jul 02, 2004 10:06 pm Reply with quote

YW

_________________
Bob Marion
Codito Ergo Sum
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
chatserv
Member Emeritus


Joined: May 02, 2003
Posts: 1389
Location: Puerto Rico

PostPosted: Fri Jul 02, 2004 10:46 pm Reply with quote

I see nothing in the module's code that would make it fail so my first guess would be variables might be clashing, i'll check in the am, kinda late right now.
 
View user's profile Send private message Visit poster's website
Justin_Sane
New Member
New Member


Joined: Jul 02, 2004
Posts: 4
Location: Lost Vegas

PostPosted: Fri Jul 02, 2004 10:47 pm Reply with quote

ChatServe 'n Bob: The Hot_or_Not_v2.0 is an old version of the ported module from trash for php nuke 5.5. The newer version for php nuke > than 6.0 and up is Hot_or_Not_Chicagobase.com_Ver_1 which I can get to ya folks if ya like. It's not all that much different but there are some minor changes...

I know 'cause I been screwin with this finicky hot or not ported mod for hours on end.. Used to work - first had a 'getimagesize' problem that turned out to be a problem withi it working with deny order allow in .htaccess. Although that was just before I installed sentinel after getting hacked. At least I've found this post telling me it is just as I thought - something to do with cookies or refresh from the sentinel program..

I mean I love sentinel, and would hate to have to go back to changing the name of admin.php! Interesting thing is that hot or not doesn't 'tabulate' the correct number of pages now either aside from not changing'em (knowing how many photos are in each category). Also noticed some 'page changing' problems here as well - or at least getting to this second page. Sentinel works like a charm warding off the scumbags on the net! Laughing But for me, hot or not, like Curtis, is very popular... So it is imperative I get it working....

Also like Curtis, my php abilities are rather limited Shocked So any help from you folks with this hot or not page change problem when used with sentinel would be greatly appreciated...

Let me know if ya need that latest and last version of hot or nor for 6.0 and up and I'll send you the zip copy. The chicago.com site is now offline.

Prior Butt kissing Wink
 
View user's profile Send private message Send e-mail
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Fri Jul 02, 2004 11:43 pm Reply with quote

Please send me a copy also at raven (at) ravenphpscripts (dot) com

Thanks!
 
View user's profile Send private message
CurtisH
Life Cycles Becoming CPU Cycles


Joined: Mar 15, 2004
Posts: 638
Location: West Branch, MI

PostPosted: Sat Jul 03, 2004 12:35 pm Reply with quote

I am glad I am not the only one who has needed help with this particular module. *LOL*

_________________
Those who dream by day are cognizant of many things which escape those who dream only by night. ~Poe 
View user's profile Send private message Visit poster's website Yahoo Messenger
Justin_Sane
PostPosted: Sat Jul 03, 2004 1:01 pm Reply with quote

Hot_or_Not_Chicagobase.com_Ver_1.zip forwarded to both raven 'n Curtis...
 
Raven
PostPosted: Sat Jul 03, 2004 1:02 pm Reply with quote

Got it. Will take a look later as everyone else will too Laughing - Thanks
 
blacksnday
Hangin' Around


Joined: Jul 06, 2004
Posts: 43

PostPosted: Tue Jul 06, 2004 8:44 pm Reply with quote

Hello everyone Smile

I would also like to add another Mod to the list that Sentinel doesnt like.

I use the Streaming mod from uzerlik.

You can find the download on my server by going here
Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login!

I had to comment out a certain section of Sent, cause with the 2.0 Version of the streaming mod, Sent was blocking.
Most likey based on the URL string that it uses.
I would like to be able to un-comment out Sent so that the mod can work without comprising Sent.

Now the second download link I gave, is the updated version of the streaming mod, which now wont work at all, and I sense that Sent it the reason it wont.
First, it having error's saying 'header already sent....' which i know isnt sent, but it wont show any catorgories and videos that are already added via the Admin menu.

If you had the time, would you be able to try to help me fix these problems?
If you need to know what I commented out of sent to get the 2.0 version of Streaming to work, then let me know and I will email it to you(as i dont want it listed publicly for site security concerns)

Thanks a ton to you both Smile
 
View user's profile Send private message
Raven
PostPosted: Tue Jul 06, 2004 8:48 pm Reply with quote

Quote:
First, it having error's saying 'header already sent....' which i know isnt sent, but it wont show any catorgories and videos that are already added via the Admin menu.
See if this fixes that issue Only registered users can see links on this board! Get registered or login!
 
blacksnday
PostPosted: Tue Jul 06, 2004 8:53 pm Reply with quote

I dont have access to php.ini

and had already tried the .htaccess fix as i read that somewhere else, which it hasnt worked, and just applied the mainfile.php fix and it didnt work either
 
Raven
PostPosted: Tue Jul 06, 2004 9:01 pm Reply with quote

Not trying to be argumentative, but the .htaccess fix has to work if done correctly (no offense) unless your host doesn't allow you to use .htaccess.
Code:
PHP_FLAG output_buffering On

save it as .htaccess and upload to the same place mainfile.php is located.
If your hosts is blocking .htaccess, then I would seriously look for another host if you can't persuade him otherwise. Also, if you are not using Apache then the .htaccess will not work as it is Apache specific.
 
blacksnday
PostPosted: Tue Jul 06, 2004 9:02 pm Reply with quote

the new version requires the 'method post' to add new catorgories to the mod.

Would Sent be blocking that?
 
Raven
PostPosted: Tue Jul 06, 2004 9:05 pm Reply with quote

No. We are not, at present, blocking any methods, but we wouldn't block post methods in any event.
 
blacksnday
PostPosted: Tue Jul 06, 2004 9:21 pm Reply with quote

I am on Apache, and already use .htaccess files on main root and other directories that are for paid members only and such.
I did add the fix to the existing .htaccess file on my nuke root folder and it still shows the error of the header

and yes nuke is installed from the root
 
Raven
PostPosted: Tue Jul 06, 2004 9:23 pm Reply with quote

With the fix applied in .htaccess, can you run phpinfo() and report back what the LOCAL setting is for output buffering?
 
blacksnday
PostPosted: Tue Jul 06, 2004 9:50 pm Reply with quote

the local setting is

output_buffering 1
 
blacksnday
PostPosted: Tue Jul 06, 2004 9:55 pm Reply with quote

with this new version of this streaming mod, i get that header error.

I have never recieved the header error with any other mod on site


maybe it's something in the mods code?
 
blacksnday
PostPosted: Tue Jul 06, 2004 10:06 pm Reply with quote

Would Sentinel Stop the following code?
Code:


$line_end_symbol = Chr(13) . Chr(10); //for memo fields
global $REQUEST_METHOD;
global $HTTP_POST_VARS;
global $HTTP_GET_VARS;
global $argsstring;



wierd, the mod itself wont add the files and catorgories, but the block does show them.....i think something in sent is stopping the mod, because for version 2.0 sent was stopping anyone from being able to view any video, and i edited sent to stop it from blocking......

but now the new version of streaming, will still play the videos, but wont update in the mod.
 
Raven
PostPosted: Wed Jul 07, 2004 4:25 am Reply with quote

This is just a side comment, but by setting those arrays to global you are being set up for hacker heaven. That is very poorly written and with all the exploits that are out there, I would encourage you to contact the author and suggest that he rewrite that.
 
blacksnday
PostPosted: Wed Jul 07, 2004 3:06 pm Reply with quote

Ok, I had just installed this streaming mod on another site I run that does not Use Sentinel.....and it works perfectly.

That tells me the reason why it wont work on my main site is because
Sentinel is causing it not to.

Like i had said above, Sentinel DID stop people from being able to view any video and i had to comment out 1 line in Sentinel to allow this mod to work.

And now with this new version of the streaming mod, Senitinel prevents the mod from being able to show what catogories and videos are there.

This is a HUGE blow to me, because the streaming mod is heavily used on my site, and i really really really do not want to get rid of sentinel Only for the use of one Mod, but thIs mod is a money maker for me.

Can someone please please please take a look at this mod's code with the link I had given above in an earlier post(the 3.0 version) and help me correct this so that Sentinel will allow this mod to work correctly.

The Blocks for this mod, which show the files, DOES work and the mod itself works. Sentinel is just blocking this from being able to show what files and catogories are available.
 
Raven
PostPosted: Wed Jul 07, 2004 3:12 pm Reply with quote

Have you gotten rid of the 'headers' issue? If not, then that one is probably still at the root of the problem.
 
blacksnday
PostPosted: Wed Jul 07, 2004 3:15 pm Reply with quote

the header is not the problem, as that also shows on my other site that does not use sentinel, but the mod still works fine there


I KNOW it is sentinel causing the Mod from not showing the mod's main page, as i said before with the earlier version of this streaming mod sent blocked anyone from being able to view any video, and i had corrected the problem.

Only reason i come here, is because i cannot pinpoint where in Sentinel and the Mod files, is causing this error now. and i am asking for someone to take a look at the Streaming Mod code so they can find it and advise me how to fix IF it can be fixed
 
Raven
PostPosted: Wed Jul 07, 2004 4:09 pm Reply with quote

Please understand, that we understand, it is an INTERACTION between the two modules. There is no defensiveness here. But, consider that neither are necessarily to blame as they both work independent of each other. No one is placing blame nor avoiding the issues. We have to ask questions to know what we are working with. Sentinel revealed that Your_Account/index.php had errors that no one knew were there. There could very well be the same issues here. The fact that you have a module that misbehaves when Sentinel is active is the symptom, not the cause. I and hundreds of others have Sentinel running w/o even a hint of a glitch. Without even looking at the code I pointed out the carelessness of the GLOBALS code which definitely leads me to suspect that there are some poor coding practices in your mods. Be that as it may, we will look at that code just as soon as we can.
 
blacksnday
PostPosted: Wed Jul 07, 2004 4:12 pm Reply with quote

thank you
 
blacksnday
PostPosted: Wed Jul 07, 2004 4:20 pm Reply with quote

I do understand what you mean.......

however the only reason I am certain it is Sentinel is because it did stop the older version of the mod from allowing anyone to view any video, and it would loop them back to the index page, just as the prob with Your Acount and stuff.

After I found what Sentinel was blocking, I edited sentinel (unfortunatly), and the streaming mod once again worked and users could access the videos streams
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©