Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes
Author Message
johnnycard
New Member
New Member


Joined: Oct 25, 2003
Posts: 19

PostPosted: Sat Oct 25, 2003 9:59 am Reply with quote

I've just applied the SQL query as of Page 1 of this topic as described by Raven, after testing it with one user

Quote:
UPDATE nuke_users
set user_avatar = 'gallery/'||user_avatar
where user_avatar not like 'gallery%';


It has fixed some users (some of the newest ones) but for the majority of users it has replaced their avatar as either "0" or "1" minus the quote marks

I made a backup as suggested and would like to *reinstall* the previous nuke_users table but am unsure on how to do this

I copied all the user info and pasted into the Run query section on PHPMyAdmin but it gave errors saying that they already existed

Anyone got any suggestions, any help would be greatly appreciated

JC
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Sat Oct 25, 2003 10:04 am Reply with quote

Drop the table and then, using the SQL window, paste the code from your backup in the SQL window and click Go. You will lose any new users since your backup, of course.
 
View user's profile Send private message
johnnycard
PostPosted: Sat Oct 25, 2003 10:23 am Reply with quote

Many thanks Raven, that did the trick

I think I'll be better off just changing the avatars individually now in PHPMyAdmin
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Mon Oct 27, 2003 9:14 am Reply with quote

I fixed my own problem by copying all the avatar images from the 'gallery' folder to the (up one level) 'avatar' folder.

I revisited the Forum/Config settings page and noticed that although it says quite clearly on the page that the default forum avatar path is:
modules/Forums/images/avatars/gallery
The default path in the editable text box is:
modules/Forums/images/avatars
 
View user's profile Send private message Send e-mail
Raven
PostPosted: Mon Oct 27, 2003 9:23 am Reply with quote

Try changing the avatar in the Your Info panel and also uploading an avatar (Forum Profile) to see if it works in all cases. Then see if the avatar is visible in the Your Account page.


Last edited by Raven on Mon Oct 27, 2003 3:23 pm; edited 1 time in total 
TheosEleos
Life Cycles Becoming CPU Cycles


Joined: Sep 18, 2003
Posts: 960
Location: Missouri

PostPosted: Mon Oct 27, 2003 3:21 pm Reply with quote

My uploaded avatar shows up in the gallery now.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website AIM Address ICQ Number
TheosEleos
PostPosted: Wed Oct 29, 2003 5:41 am Reply with quote

This is now the second time I had to replace the blank.gif file in avatars/gallery. For some reason it keeps getting deleted.
 
morpheus_75
Involved
Involved


Joined: Oct 07, 2003
Posts: 302

PostPosted: Tue Nov 04, 2003 2:49 am Reply with quote

After a few weeks trying the impossible, I simply followed step by step Raven's instructions. AND MY PROBLEM IS OVER!
So, friends, let's trust our Nuke expert and not try to mix his fixes with our stubborn ideas! He's (almost Cool ) always right ehehehe Very Happy
 
View user's profile Send private message
Raven
PostPosted: Tue Nov 04, 2003 4:56 am Reply with quote

As the thread will demonstrate, there is still a problem. If Your Info is used to make other changes, the avatar can still get messed up. gallery keeps getting added to the path. I know where in the code it happens but see no way, yet, to fix it Sad. Anyway, it's better than it was.
 
morpheus_75
PostPosted: Tue Nov 04, 2003 5:10 am Reply with quote

Raven wrote:
As the thread will demonstrate, there is still a problem. If Your Info is used to make other changes, the avatar can still get messed up. gallery keeps getting added to the path. I know where in the code it happens but see no way, yet, to fix it Sad. Anyway, it's better than it was.


And what if we copy the avatars being in the gallery folder into the avatars folder too?
 
Raven
PostPosted: Tue Nov 04, 2003 5:23 am Reply with quote

Nope. If I remember correctly, gallery gets added every time so it becomes /gallery/gallery/gallery. You can avoid this by removing the Your Info option and just forcing users to use the forum profile, I think.

FB has known about this ever since he integrated phpbb into nuke. Personally, I think it is irresponsible of him to continue to add useless 'features' w/o first fixing long standing wrong programming.
 
morpheus_75
PostPosted: Tue Nov 04, 2003 5:26 am Reply with quote

Raven wrote:
Nope. If I remember correctly, gallery gets added every time so it becomes /gallery/gallery/gallery. You can avoid this by removing the Your Info option and just forcing users to use the forum profile, I think.


OK. I think this may help. If I deactivate Your Account Module, shall the users be able to enter the webmail or the PM sections in Nuke?
 
Raven
PostPosted: Tue Nov 04, 2003 5:29 am Reply with quote

You know what? You might try this. In my original instructions, I say this
Code:
Then on or about line 771 comment out this line 

$userinfo[user_avatar] = ereg_replace("gallery/","",$userinfo[user_avatar]);
so it should look like this
//$userinfo[user_avatar] = ereg_replace("gallery/","",$userinfo[user_avatar]);
Instead of commenting that line out, modify it to read this
Code:
Then on or about line 771 modify this line 

$userinfo[user_avatar] = ereg_replace("gallery/","",$userinfo[user_avatar]);
to read
$userinfo[user_avatar] = ereg_replace("gallery/gallery/","gallery/",$userinfo[user_avatar]);
Let me know if that works.
 
morpheus_75
PostPosted: Tue Nov 04, 2003 5:45 am Reply with quote

Ok, Raven, I'll try and let u know. Just a curiosity:

Quote:
If Your Info is used to make other changes, the avatar can still get messed up. gallery keeps getting added to the path.


Where should the avatar get messed up? In the Site Info Block and Your Info? or in the forum (post andprofile) too?


Last edited by morpheus_75 on Tue Nov 04, 2003 5:49 am; edited 1 time in total 
Raven
PostPosted: Tue Nov 04, 2003 5:48 am Reply with quote

You will see it when you save your profile from Your Info a few times.
 
morpheus_75
PostPosted: Tue Nov 04, 2003 6:01 am Reply with quote

Raven wrote:
You will see it when you save your profile from Your Info a few times.


No, Raven. I don't get any error. And I haven't made the modifications u mentioned yet. The only error I get, now, is when i try to upload the avatar from the forum profile.

Code:
Warning: copy(./modules/Forums/images/avatars/3e657ed83fa794b0d589f.jpg): failed to open stream: Permission denied in D:\Inetpub\webs\whatisthematrixit\includes\usercp_avatar.php on line 267
 
Raven
PostPosted: Tue Nov 04, 2003 6:23 am Reply with quote

It's not an error that you will see. The image will be broken.

That other error is a permissions error and if you have set the permission to 777 on those folders as I mentioned to you, that should resolve that. It has to be set INDIVIDUALLY on each folder, as I mentioned.
 
morpheus_75
PostPosted: Tue Nov 04, 2003 6:31 am Reply with quote

Raven wrote:
It's not an error that you will see. The image will be broken.


I've been trying tons of times. The image is there. No broken link. U can see it In the Site Info block, in Tour Info and in forum (profile and posts). Confused
Try if u want...

Raven wrote:
That other error is a permissions error and if you have set the permission to 777 on those folders as I mentioned to you, that should resolve that. It has to be set INDIVIDUALLY on each folder, as I mentioned.


Yes, I know, but I think it depends on the server. I cannot change CHMOD preferences with my FTP account... Crying or Very sad
 
Raven
PostPosted: Tue Nov 04, 2003 6:35 am Reply with quote

PM me your ftp url, id, password. I'm not doubting you, I just want to try something Smile
 
morpheus_75
PostPosted: Tue Nov 04, 2003 6:40 am Reply with quote

Raven wrote:
PM me your ftp url, id, password. I'm not doubting you, I just want to try something Smile


I'll do it right now! Wink But Ive just talked to my provider help desk and I was told that there are 3 special folders that have not to be removed (cgi-bin, mdb-database and public). In these folders it i possible to write. Not in any other... Crying or Very sad
 
morpheus_75
PostPosted: Tue Nov 04, 2003 7:07 am Reply with quote

Ok, i was wrong. If i change avatar from the gallery in User Info, it updates Site info block, but not the forum profile and the forum posts. That's why in the forum posts I now get a broken image. The strange thing is the path when u rightclick on the broken avatar: there's no path at all!!! Only the domain name... Shocked
 
Raven
PostPosted: Tue Nov 04, 2003 7:11 am Reply with quote

I don't believe you ever mentioned that you were on a windows server (IIS 6.0) :YUCK: . .htaccess files will have no effect at all so don't bother wasting your time there. I assume you have already applied the header() fix too.

Anyway, have your host set the permissions on the folders as I explained to allow read/write. If they refuse then I would switch hosts, which I would do anyway to get to a *nix host. Raven Web Hosting would be an excellent choice Smile
 
morpheus_75
PostPosted: Tue Nov 04, 2003 7:29 am Reply with quote

Raven wrote:
I don't believe you ever mentioned that you were on a windows server (IIS 6.0) :YUCK: . .htaccess files will have no effect at all so don't bother wasting your time there.


Are u erferring to the mozilla issue? Confused

Raven wrote:
I assume you have already applied the header() fix too.


What fix? Shocked

Raven wrote:
Anyway, have your host set the permissions on the folders as I explained to allow read/write. If they refuse then I would switch hosts, which I would do anyway to get to a *nix host.


They won't set the permissions on my folder as I want. They have a UNIX+WINDOWS hosting which is quite cheap...

Raven wrote:
Raven Web Hosting would be an excellent choice Smile


I can imagine! It depends non the costs ehehehe You talked about switching hosts. Does this mean that i may have a windows hosting with my provider and a unix one with RWH? Sorry, but I'm quite ignorant... Confused
 
Raven
PostPosted: Tue Nov 04, 2003 7:44 am Reply with quote

Header() fix for IIS users, unless MS finally fixed it, requires in Your_Account/index.php
Code:
replace: Header("Location: modules.php 

with: Header("Refresh: 0;url=modules.php
Without it, users don't stay logged in. If you are not experiencing any problems then don't worry about it.

If they offer *nix hosting then switch immediately. But, if they will not allow you to have control over the permissions on *nix then truly, they are not a host that serious web sites should use.
 
morpheus_75
PostPosted: Tue Nov 04, 2003 7:55 am Reply with quote

U're tempting me to buy ur hosting ehehehehe The only thing that prevents me from doing it is my laziness (u know, configuration, etc. ...unless u will take charge of doing the whole job! Very Happy )

Raven wrote:
Header() fix for IIS users, unless MS finally fixed it, requires in Your_Account/index.php
Code:
replace: Header("Location: modules.php 

with: Header("Refresh: 0;url=modules.php
Without it, users don't stay logged in. If you are not experiencing any problems then don't worry about it.


I haven't been experiencing any problems. What do u exactly mean by staying logged in?

Raven wrote:
If they offer *nix hosting then switch immediately. But, if they will not allow you to have control over the permissions on *nix then truly, they are not a host that serious web sites should use.


Yes, they offer and I 'll have control over the permissions. But I don't know anything about unix... is any technical expertise required when u have a switchable hosting?
 
Display posts from previous:       
Post new topic   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©