Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.5.x
Author Message
aimhighgranny
New Member
New Member


Joined: Oct 05, 2007
Posts: 3

PostPosted: Sat Jan 05, 2008 4:07 pm Reply with quote

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
 
View user's profile Send private message
aimhighgranny
PostPosted: Sat Jan 05, 2008 4:49 pm Reply with quote

I did get it working.. i recopied files back over. and the the page would never load. I ended up using the nsnst.php to upgrade tables from 07-08 and that fixed it.. thanks for your time
 
utalice
New Member
New Member


Joined: Jan 07, 2008
Posts: 11

PostPosted: Tue Jan 15, 2008 4:09 pm Reply with quote

aimhighgranny wrote:
I did get it working.. i recopied files back over. and the the page would never load. I ended up using the nsnst.php to upgrade tables from 07-08 and that fixed it.. thanks for your time


Now wait a minute...I'm a noob here, so I don't have a clue how you fixed this by "recopied files back over" or "using the nsnst.php to upgrade..." Embarassed

I noticed that her line 22 was the same as my line 17 in the socket_test.php. So, it's the same error.

I also have GoDaddy and am experiencing the same problem.

How exactly is this fixed?

I think if there's a detailed explanation here, it would save a lot of time and headaches on answering the noob GoDaddy victims' posts. Wink

thanks!
A|ice
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Tue Jan 15, 2008 5:22 pm Reply with quote

I gave a detailed explanation earlier in my post dated Sun Dec 09, 2007 5:44 pm. What else do you need?
 
View user's profile Send private message
utalice
PostPosted: Tue Jan 15, 2008 7:02 pm Reply with quote

Raven wrote:
I gave a detailed explanation earlier in my post dated Sun Dec 09, 2007 5:44 pm. What else do you need?


Thanks Raven...I have a few questions, I hope it's not too much, but I want to make sure I understand. That way, I may be able to figure out things on my own and not bug folks here on the forum. Confused

First, I don't understand what you meant in that post by "commented out all the logic". I do understand what "commenting out" IS...I don't know exactly what part of nukesentinel.php you commented out though. Is it the part you posted? I only know what I've learned about php in the past two weeks...and that's not a lot. I've edited scripts before, but I used the " ; " to comment out lines. Here, in php, it seems to be this, " / ". Does " /***" and " ***/ " mean that everything in between the two is commented out?

If I do have that correct, when commenting out those lines, how does that effect NukeSentinel?

Referring to aimhighgranny, she said she recopied files back over. What files? Does it mean she recopied over certain files on her server somehow? Or did she copy files from one server to a new server? What does she mean when she refers to "07-08" is this a version of something or 2007-2008? Is this what I need to do, or is this anything I should even be worrying about?

I couldn't find an nsnst.php file anywhere on my server, after Googling it, I believe it's what you configure NukeSentinel with. So is she using that to upgrade the tables that are part of NukeSentinel because when she "recopied files" it screwed something up?

Should I just be doing what you said in the previous post when you said "commented out the logic"?

I always hated my time in noobsville, lol...sorry this is so long...but I need to understand it.

Thanks again,
A|ice
 
Raven
PostPosted: Tue Jan 15, 2008 8:06 pm Reply with quote

Alice,

See if this post helps. If not, just let us know Smile
Only registered users can see links on this board! Get registered or login!
 
utalice
PostPosted: Tue Jan 15, 2008 10:47 pm Reply with quote

Raven wrote:
Alice,

See if this post helps. If not, just let us know Smile
Only registered users can see links on this board! Get registered or login!


Hmm, well...my nukesentinel.php didn't have that " $socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP); " section in it.

I just downloaded the Ravenscript from the Home page a day or so ago, maybe it has a more recent version?

But, I did delete the section you mentioned a few posts up in this thread and now I can see my NukeSentinel when I click on the icon in the Administration panel. Very Happy

But.

I had read on the homepage that this version of Ravenscript had "...all of the latest patches installed as well as the latest NukeSentinel(tm) release (2.5.10 as of this writing) and more".
But, when I opened it in my Admin panel, it says it's version 2.5.08 of NukeSentinel.
Soooo...

Now...for the doomed upgrade...lol, wish me luck.

THANKS!
A|ice
 
Raven
PostPosted: Tue Jan 15, 2008 10:54 pm Reply with quote

You need to upgrade NukeSentinel(tm) to v2.5.15. The RavenNuke(tm) v2.10.01 has NukeSentinel(tm) v2.5.08 in it. We don't update the releases for you - sorry Smile


Last edited by Raven on Wed Jan 16, 2008 12:30 am; edited 1 time in total 
utalice
PostPosted: Tue Jan 15, 2008 11:29 pm Reply with quote

Boy, this is really confusing ! lolol
Let me see if I'm getting this right...
RavenNuke (sorry for the previous mis-wording of that) has NS v.2.5.10 in it, but when I run it...it's only v.2.5.08, so then I have to upgrade it to v2.5.15? Argh, boy do I have some more reading to do...lolol.

What about security patches? I had just picked up somewhere (I think while reading about how to upgrade the NS to v.2.5.15) that it won't update unless I have the most recent security patches. Are these the patches that are advertised (as being the latest patches) when I downloaded the latest RavenNuke or do I need to look for those at NukeFixes?

BTW, thanks for letting me in on a better way to run PhPNuke...I surely wish I would have hit your site before throwing $12 down the toilet at someone else's site to get PhPNuke 8.1. I was ready to shoot myself trying to figure that thing out. Anyone looking for this...I'll be sending your way.

And another thing...my site ran really slow before. I can see a considerable change with RavenNuke. Yippeeeee!
 
Raven
PostPosted: Wed Jan 16, 2008 12:48 am Reply with quote

That was a typo on my part - I have corrected it.

When RavenNuke(tm) v2.10.01 was released it had the latest version of NukeSentinel(tm) at that time which was v2.5.08. After we release RavenNuke(tm) it is up to the individual webmasters to keep the scripts updated until we release another version. The only exception we make to that is if its a major security issue.

So, now you have NukeSentinel(tm) v2.5.08 installed. Now you need to grab a copy of NukeSentinel v2.5.15 UPGRADE, not FULL. Then, load the the following folders/files to your site overlaying all.

public_html/nsnst.php
public_html/nsnst_installer
public_html/includes/nukesentinel.php
public_html/admin/modules/nukesentinel.php
public_html/admin/modules/nukesentinel/
public_html/blocks/block-Sentinel.php
public_html/blocks/block-Sentinel_center.php
public_html/blocks/block-Sentinel_Scrolling.php
public_html/blocks/block-Sentinel_side.php
public_html/modules/NukeSentinel/

Then, log in as a god admin and execute the nsnst.php script. You now have to execute the following scripts, in order.
08->09
09->10
10->11
11->12
12->13
13->14
14->15

Assuming you have made all of the core edits correctly, you should either see the admin control panel or not. If you are not seeing it then comment out the block of code in admin/modules/modules/nukesentinel.php as instructed in the earlier post.


Last edited by Raven on Thu Jan 17, 2008 8:13 am; edited 1 time in total 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Thu Jan 17, 2008 8:06 am Reply with quote

To your other question, you do not need any of the security patches because they are already integrated into RavenNuke.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
utalice
PostPosted: Thu Jan 17, 2008 10:14 pm Reply with quote

That's great, it all turned out very well.
I could have swore I posted another message stating that it all went well but I wanted to know if I had to do anything else that it had stated in the "readme" file, such as editing cores and something to do with the country flags.
I can't remember now but lemme try to see if I can get all this figure out then most likely, I'll be back...lol.
Thanks again everyone for the help.

A|ice
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.5.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©