Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke
Author Message
ga-nightcrawler
New Member
New Member


Joined: Jul 05, 2006
Posts: 23

PostPosted: Wed Jul 12, 2006 4:29 pm Reply with quote

Ok i want to know which php-nuke version im running on my site if any because i contacted my site provider and they told me i have the php current version 4.4.2 and thats the current version so no need to upgrade. So i want to know if im running php-nuke or not and where i could know which version. Please!!!
 
View user's profile Send private message
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Wed Jul 12, 2006 5:37 pm Reply with quote

Check the table nuke_config also in in the statistics module is the nuke version available. Check also the mainfile.php for the patch version.
 
View user's profile Send private message
ga-nightcrawler
PostPosted: Wed Jul 12, 2006 9:26 pm Reply with quote

ok ty very much..my nuke version is 7.0 now where i have to navigate to see if its patched and if not where do i find the patch for 7.0
 
ga-nightcrawler
PostPosted: Wed Jul 12, 2006 10:11 pm Reply with quote

ok i think i found the patched 7.0, its the 3.1 patch for nuke 7.0-7.1?......in the description say i need to upload the patched 7.2-7.3 files and then upload the 7.0 patched......its that ok?... i dont want to mess up everything with my site.......please help...im noob at this but i want to learn Smile
 
Susann
PostPosted: Thu Jul 13, 2006 12:52 am Reply with quote

Maybe your site is already patched with the 3.1 patch. There is a information about the patch version from Chatserv at the top of the mainfile.php normally. If you overwrite your files with the patched files you can merge your own files with the newest otherwise you loose possible your own changes n the files. You can also think about upgrade to a higher nuke version e.g. 7.6 or e Raven Nuke because there is a newer patch 3.2B available and RavenNuke is the better Nuke.
Important is also that you use the new NukeSentinel version and that the forums version is up-to-date. Confused
 
ga-nightcrawler
PostPosted: Thu Jul 13, 2006 2:36 pm Reply with quote

ok i've checked the mainfile.php and there is no information about any patch version from chatserv. If i want to upgrade from 7.0 to Raven Nuke,

1) did i will lose all my "site" and will need to start all over again or i just need to upgrade from 7.0 to raven nuke(what version) without losing all my "site" making a back up?

2)Where i will do this backup?. in Cpanel(where my provider is the only one who can install) or phpmyadmin(backing up the databases, exporting and importing steps?) or how i do it

3) It's Raven Nuke free or i need to buy it and where i can find if its free?

4)how do i make this upgrade?, I need to contact my host provider to do it or i can do it myself from 7.0 to raven nuke upgrade?

5) how much long is this process?

6) Can you help me on step by step on how to do the upgrade?

7) where i can check if my forums is up-to-date(which version) and if not how i do it? and after doing the update of forum, I will lose all the data there?

I would appreciate if you can help me on this and once i pass my critical economical situation to a better one i will donate for sure Smile
 
Susann
PostPosted: Thu Jul 13, 2006 4:14 pm Reply with quote

You need to upgrade to Nuke 7.6 and from this version number it´s easier to switch to RavenNuke. The best way to do this is described by many members in the RavenNuke Support forum. I´m not really good in explaining in detail the steps so its better you use the search function for this.

RavenNuke is free. You ´ll find more information and what´s all preinstalled in this wonderfull package here:
Only registered users can see links on this board! Get registered or login!
and there is also some information on the main page.

Backups can be done with phpMyAdmin. Don´t know why you need to contact your host provider because you can normally do it alone.
The forums version you will find in the database table.

The current phpBB version is 2.0.21.
 
ga-nightcrawler
PostPosted: Thu Jul 13, 2006 10:59 pm Reply with quote

ok i've downloaded phpnuke patched 7.6 full pack 3.0 patches for free from nukeresources.com, its that the correct file?.....and ravennuke 7.6.....now when i checked the nuke 7.6 i see in the upgrade folder the upgrade scripts but there is none of them about 7.0-7.6, only 7.0-7.1, 7.1-7.2, 7.2-7.3.......7.5-7.6 now how i can upgrade from 7.0 to 7.6 if there is no upgrade script that point it.......do i need to run every upgrade until 7.6?......please help
 
gregexp
The Mouse Is Extension Of Arm


Joined: Feb 21, 2006
Posts: 1497
Location: In front of a screen....HELP! lol

PostPosted: Fri Jul 14, 2006 4:51 am Reply with quote

Yes upgrade each script at a time and you will be fine.

_________________
For those who stand shall NEVER fall and those who fall shall RISE once more!! 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
ga-nightcrawler
PostPosted: Fri Jul 14, 2006 5:43 am Reply with quote

ok ty very much...now a couple of questions, after the upgrade is completed

1) i wont lose anything on my site?

2) it will remain the same as now?

3)while upgrading, my site wont be accesible?

4) i will need to modify any of my tables or anything running on my actual 7.0 so i dont lose them?

5) The up-to-date version of forums is included on the file and will be updated too?


Please help me as im a noob that want to learn on how to do it without any problems losing my actual data so i dont need to start all over again in my site

after setting up everything without problem i will ask again on how to upgrade to ravennuke 7.6 Razz
 
ga-nightcrawler
PostPosted: Fri Jul 14, 2006 1:51 pm Reply with quote

help, sussan, darklord, raven.....anyone with the knowledge Mr. Green
 
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Fri Jul 14, 2006 3:53 pm Reply with quote

1) If you upgrade correctly, you won't lose your date, if that's what you mean. It's always a good idea to backup your data before making significant changes.

2) What do you mean by it will remain the same as now? Isn't the point of upgrading to change things?

3) If you already have NukeSentinel on your site, you can disable your site before upgrading. You can try to upgrade your current site and leave it active, but I wouldn't recommend that. It's probably better to copy, upgrade the copy and test before making the changes live.

4) You won't necessarily need to modify 7.0 tables so that you don't lose them. But you WILL need to modify 7.0 tables so they work with 7.6. Finding the upgrade scripts for Nuke and for phpBB is possible, though I doubt it will be easy.

5) See # 4.

The bottom line is: backup your data before doing anything.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
ga-nightcrawler
PostPosted: Fri Jul 14, 2006 5:51 pm Reply with quote

ok,
when i say if i wont lose anything on my site i want to say if i dont need to reinstall any modules or other stuff already in it

when i say if it will remain the same i want to say if it will look the same as now, home page, modules, etc..

now how do i modify 7.0 tables so they work with 7.6?

and what u mean by finding the upgrade scripts for nuke and for phpbb? because i think i have the 7.6 nuke patched and darklord said i need to upgrade version by version because there is no upgrade70-76.php in the upgrades folder, its that what u mean about the scripts? i need to find the upgrade70-76.php script?.....
 
Susann
PostPosted: Fri Jul 14, 2006 7:01 pm Reply with quote

Do you already know the FAQ ? There is something about "How to upgrade"
Only registered users can see links on this board! Get registered or login!

RTM What s going on with that upgrade script ?

Only registered users can see links on this board! Get registered or login!

You ll find the nuke versions 7.1 - 7.6 in every great database I believe. For example here are also some prepatched versions but the patch is 2.8 !:
Only registered users can see links on this board! Get registered or login!

I found the 7.6 version in Ravens download section. Smile

The current patch level from Chatserv is 3.2.b.

It´s possible that some of your modules doesn´t work proper with that newest patch. You can try this on your localhost its like Kguske said test it and backup !
But I can tell you there are many really bad things on the web going around and without upgrade, without nukesentinel and the newer forums version its possible that your site doesn´t exist very long.
 
ga-nightcrawler
PostPosted: Fri Jul 14, 2006 11:35 pm Reply with quote

ok,
is this the phpnuke 7.6 with patched 3.0?:
Only registered users can see links on this board! Get registered or login!

is this the ravennuke 7.6 full?:
Only registered users can see links on this board! Get registered or login!


Also i want to know if in the above files are included any forum version at all and will upgrade the current one on my site?

or where i can find the newest forum version or they are included with any of the above files?

and do i need to upgrade the forum as a single file, i mean, it wont upgrade when upgrading phpnuke version? or i need to upgrade the forums from my current version to the latest in a numerical order, i.e. from my current version to the next version, version from version until the latest one?

Please sorry and forgive me if im a pain in the a** but im a noob at this and want to do this my self but making sure i will do it the right way with the most minimum mistakes or no mistakes at all
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sat Jul 15, 2006 12:05 am Reply with quote

You'd want to go with Patched 3.2B probably. It is meant as an upgrade from 7.6 only... and it is not a full package of files.
However, RavenNuke is a better choice if you want to go for a complete full package. Patches + Sentinel and many other changes.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
ga-nightcrawler
PostPosted: Sat Jul 15, 2006 2:02 am Reply with quote

ok ty......i just want to know if the file's link i posted above are the Full package of phpnuke 7.6 with 3.0 patch applied, because thats what it say in the download section link, "PHP-nuke Patched 7.6 Full Pack" in nukesources.com

I just downloaded RavenNuke76 v2.02.02 FULL - A distro with all patches and NukeSentinel, from download section on this website because i think thats the Full ravennuke 7.6 i will need, to run raven-nuke on my site.

thats ok, but i need to upgrade from my current phpnuke 7.0 to phpnuke 7.6 before i upgrade to ravennuke 7.6, thats what i've been told, I only needs to know if the file's link refering to Php-nuke patched 7.6 Full pack, in whose description says: PHP-Nuke 7.6 with Nuke Patched 3.0 already applied, is the file i need to upgrade from my current 7.0 version to 7.6....after that i can search for the latest 3.2b patch, but i want to know if im ok with the file i link above in my post
 
evaders99
PostPosted: Sat Jul 15, 2006 2:05 am Reply with quote

Well that's what 7.6 says it is.

Actually, you don't even need that. You just need the upgrade scripts to 7.6
Smile
And then install RavenNuke (NSN Groups and Sentinel tables, not the core tables again)
 
ga-nightcrawler
PostPosted: Sat Jul 15, 2006 3:44 am Reply with quote

so you mean i dont need the php-nuke 7.6 files to overright my current ones, only the upgrade scripts in folder upgrades to upgrade from 7.0 to 7.6?

and how about the rn7.6?, nsn groups and sentinel tables only? what about the html files in both?

then why ppl say i need to overright current files with the ones in the folders of 7.6 by uploading them?

sorry but im illiterate in this sorta things Razz
 
ga-nightcrawler
PostPosted: Sat Jul 15, 2006 4:28 am Reply with quote

one more ?....if my current forum is 2.0.6 version in php-nuke 7.0 and i upgrade to php-nuke 7.6...what will happen to my current forum, i will lose all the sections i've made? or i need or can upgrade first phpbb to the latest on my actual php-nuke 7.0 and then perform the php-nuke 7.0-7.6 upgrade?....


EDIT: nvm i found a topic talking about this...i need to upgrade to phpbb 2.1.0 due to the fact that 7.6 comes with 2.1.0, but if i upgrade phpbb manually from 2.0.6 to 2.1.0 when i upgrade to nuke7.6 what will happen to phpbb 2.1.0 i upgraded manually if 7.6 comes with it?
 
evaders99
PostPosted: Sat Jul 15, 2006 12:58 pm Reply with quote

You don't need to run any phpBB upgrade scripts... they are included in the phpNuke upgrade scripts. Also, RavenNuke includes those upgrade scripts... so it really is all you need.
 
ga-nightcrawler
PostPosted: Sat Jul 15, 2006 11:04 pm Reply with quote

so you mean i dont need to upgrade from my current nuke7.0 to nuke 7.6 to be able to upgrade to raven nuke .....i can upgrade from my 7.0 directly to raven-nuke 7.6?
 
gregexp
PostPosted: Sat Jul 15, 2006 11:59 pm Reply with quote

What evaders is saying is that raven nuke has the update scripts within the package and you will need to run those incrimentally to update your site.

Although there is a readme in it that says not to use these files, not sure if raven put that readme or if it was pulled into the folder from an upgrade package already made.

So to the team, is it in there and able to be run or is there a problem with them?
 
ga-nightcrawler
PostPosted: Sun Jul 16, 2006 4:46 am Reply with quote

darklord wrote:
What evaders is saying is that raven nuke has the update scripts within the package and you will need to run those incrimentally to update your site.

Although there is a readme in it that says not to use these files, not sure if raven put that readme or if it was pulled into the folder from an upgrade package already made.

So to the team, is it in there and able to be run or is there a problem with them?


ok i think i got it....i dont need to upgrade from my phpnuke 7.0 to phpnuke 7.6, i can upgrade from my php-nuke 7.0 to rn7.6 directly...am i right?

one more ?.....my current tables on 7.0 will work OK on 7.6? or i need to modify something so they work on 7.6? and if i need to modify them, how and what i need to modify in them?
 
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Sun Jul 16, 2006 7:14 am Reply with quote

no...7.0 tables arent compatible with 7.6
just follow the instructions in the ravennuke readme files.
when doing the upgrade it also upgrades/alters your database tables.
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©