Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
gregexp
The Mouse Is Extension Of Arm


Joined: Feb 21, 2006
Posts: 1497
Location: In front of a screen....HELP! lol

PostPosted: Sat Jul 01, 2006 11:41 am Reply with quote

it wont work in ff for me now either and I have been trying to do this and it just wont work

_________________
For those who stand shall NEVER fall and those who fall shall RISE once more!!

Last edited by gregexp on Sat Jul 01, 2006 6:06 pm; edited 1 time in total 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
rawksie
New Member
New Member


Joined: Jun 29, 2006
Posts: 14
Location: Twitching at the bottom of a stress-pit. x.X

PostPosted: Sat Jul 01, 2006 11:54 am Reply with quote

darklord wrote:
...
In the style sheet(s), can we make an if statement like
if browser==IE{
scrollbar..blah
}
else{
nothing defining scrollbars
}
...

I will take a look at that, thanks so much. I'm lazy, but I am actually a webdesigner. Laughing

Currently however, one of my friends is on the verge of mental breakdown, which I'm trying to help with...
 
View user's profile Send private message
gregexp
PostPosted: Sat Jul 01, 2006 12:20 pm Reply with quote

Thats really not good but I still cant resolve this with the codes I have found.

I have done this in style.css and forums.css of my theme:

<--[if IE]>
code for scrollbars which is in body code
<[end if]-->

then I did this
<comment>
code for body without scrollbar
</comment>

it seems IE will recognize the if IE attribute but no other browser will so its like commenting the lines out for everyother browser type.

And vis-versa

the comment attribute is apparently not reognized by IE but recognized by all others so when it comments out the body code, your site gets messed up but putting it back in there under the comments tag sets your site right again.
This is still not working though, it does eliminate the errors in the javascript console of firefox but it still does not allow the javascript to work the way it should

I'm sorry, I will continue to work at this but now that I have eliminated this as being a problem, I've hit the end of what I think could be wrong and kguske, I installed that phpbb extension to verify that was it, it didnt work either just so you all know I have searched and worked on every angle I can think of. If any other ideas pop up, I'll be happy to try them and see how it works but now it isnt just you, its also me thats having this problem with firefox. Thus the reason I like firefox for its strict adherence to properly made pages, I dont like its lacking of javascript ability, I personally prefer to set IE up with security.

That is what I use for the most part IE.
 
jaded
Theme Guru


Joined: Nov 01, 2003
Posts: 1006

PostPosted: Sat Jul 01, 2006 5:28 pm Reply with quote

i suggest that rawski go and change the theme to fisubice on her site.

then close the browser totally and open it again.

Then try to post on your own forum with that theme pack.

Post back to us the results.

There is no point in altering a theme or css at all until we know if it is theme related

it could be the theme, odder things have happend.

This is the best way to deal with this right now.

_________________
Themes BB Skins Only registered users can see links on this board! Get registered or login!
Graphic Tees Only registered users can see links on this board! Get registered or login!
Paranormal Tees Only registered users can see links on this board! Get registered or login!
Ghost Stories & More Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
rawksie
PostPosted: Sun Jul 02, 2006 6:29 am Reply with quote

Tested it, it works in fisubice...

It's definitely the theme then.

I don't really give schmitt about coloured sidebars for IE users, so I'll try removing that.
 
jaded
PostPosted: Sun Jul 02, 2006 6:39 am Reply with quote

I do not think that will do it. You can try but I suspect you may have to either disect the theme altogether or do without it and choose another.
 
rawksie
PostPosted: Sun Jul 02, 2006 6:41 am Reply with quote

Well, I cut the scrollbar color code out, and you're entirely correct, Jaded. It did not work.

...I have to try and remember where in the mass of files the drop-in code was...

EDIT: Mokay.... The fisubice and the subblack drop in sections (file is in theme/forums/posting body pertinent part is bbfontstyle onwards.) are completely different.

I'm going to play around a little, try using fi's code for subblack, and so on...


Last edited by rawksie on Sun Jul 02, 2006 6:52 am; edited 1 time in total 
jaded
PostPosted: Sun Jul 02, 2006 6:51 am Reply with quote

I do not believe that will make any difference. I believe that it is something fundamental with the theme that doesnt agree with your system. If I were you, and wanted to save time this is what I would do

I would go into the theme folder of your theme you want.

I would then rename the forums folder in the theme folder to forums-old

Then I would go to my site and try to use the fourms. It will revert it back to the standard subSilver.

You may have trouble reading it due to color confilicts but you can still do a test.

Then I would try to post a test post with the b,i, color, etc tags. Similar to the one that I posted

If it works, then it is something in your forum pack. If it doesnt work, it is something in your theme iteself and the forum files may be fine.

I would take this approach or toss out the theme altoghter.

Please let us know how things go.
 
rawksie
PostPosted: Sun Jul 02, 2006 6:55 am Reply with quote

Smile I've determined it's definitely the theme, as the drop-in works for fisubice.
The scrollbar code didn't affect it, so I'm experimenting with the javascript in posting_body .. they are completely different for each theme, so I will be attempting renaming the old ones for subblack and using the ones from fisubice and seeing if that helps (or kills it!).

HURRAH! Very Happy
I don't see why you guys could get it to work and I couldn't, but then, I don't know javascript too well... It's probably a 'switch' that my FF don't like.
 
jaded
PostPosted: Sun Jul 02, 2006 7:19 am Reply with quote

well, you are going about it wrong in my opinion. You should do as I suggested in my last post. That will save you a great deal of time and aggrivation.

The reason that we dont have that problem is that it is your system. Something in your computer is incompatible. It is not solely a firefox issue as you get the same errors in IE or so you said.

I wish you luck.
 
gregexp
PostPosted: Sun Jul 02, 2006 11:25 am Reply with quote

rawskie, I worked at eliminating the scrollbars and other things on a theme as well, Jaded makes custom themes and is the theme guru on this site so I'd sudjest to follow her instructions to a T and she will lead you right where you need to be.

Jaded as it may not be an issue soley with firefox, I'm pretty sure mines setup and installed and now I'm getting the same error, back to the thinking kguske had, is there an addon perhaps we are missing that may be able to help?
 
rawksie
PostPosted: Sun Jul 02, 2006 2:46 pm Reply with quote

Did I not make it clear that it was not the sidebars, but the drop-in code itself, in posting_body.tpl, and that I'd fixed it...?

I realise Jaded is a theme guru, but I am a webdesigner anyhow, so apart from knowing the filesystem a little better, I really see no difference in our knowledge levels. However, I already tried that method before hand anyway, as I previously stated way before he/she suggested it. Have I been speaking french?

EDITED: d*** typos..
 
gregexp
PostPosted: Sun Jul 02, 2006 3:02 pm Reply with quote

ok glad to see you fixed this, also glad to see that your "knowledge" pointed you in the right direction in the first place, I asked because I miss read the previous post.

Glad we could point you in the right direction but the attitude should go!
 
rawksie
PostPosted: Sun Jul 02, 2006 3:05 pm Reply with quote

I'm sorry, it did sound rather snappy, didn't it?

People have been not-listening to me all day, and it's getting me a liiiiittle riled up. The worst was a client asking why some graphic wasn't displaying, and then after an hour's phone call, I found out it was because he'd mis-typed the url, which I asked him to check as soon as he called! /swt
 
gregexp
PostPosted: Sun Jul 02, 2006 4:28 pm Reply with quote

its alright, people have good and bad days, just glad you let us know that there was no offense intended and therefore none takin.
 
jaded
PostPosted: Sun Jul 02, 2006 5:25 pm Reply with quote

Rolling Eyes

Quote:
Posted: Sun Jul 02, 2006 4:46 pm

--------------------------------------------------------------------------------
Did I not make it clear that it was not the sidebars, but the drop-in code itself, in posting_body.tpl, and that I'd fixed it...?

I realise Jaded is a theme guru, but I am a webdesigner anyhow, so apart from knowing the filesystem a little better, I really see no difference in our knowledge levels. However, I already tried that method before hand anyway, as I previously stated way before he/she suggested it. Have I been speaking french?


I can do without sarcasm. Next time I will not offer up any help.


Quote:

Posted: Sun Jul 02, 2006 8:55 am

--------------------------------------------------------------------------------
I've determined it's definitely the theme, as the drop-in works for fisubice.
The scrollbar code didn't affect it, so I'm experimenting with the javascript in posting_body .. they are completely different for each theme, so I will be attempting renaming the old ones for subblack and using the ones from fisubice and seeing if that helps (or kills it!).

HURRAH!
I don't see why you guys could get it to work and I couldn't, but then, I don't know javascript too well... It's probably a 'switch' that my FF don't like.



this does not state that you fixed it except for the HURRAH. You stated that you were going to try something. Best of luck to you. I also never said that I knew more then you however, a web designer would have looked at replacing the file system early on. TATA
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Thu Jul 06, 2006 6:53 am Reply with quote

rawksie wrote:
But why only on my site and not on this one?
(I like to know the why of everything, sorry if it's slightly annoying..)

What could be the difference? o.o

EDIT: I see. That's a good idea, darkmatter. And I'm a she, not that it really matters. Embarassed


You keep referring to "this" site! If by that you mean Raven's, do not assume that he is running RavenNuke, because he is not! His site is a heavily modded 6.5 nuke! It suits his purpose and the needs of the community, so he has no reason to change.

As others have been saying, the issue is with your system. Since these bbcode functions are javascript based, it has to be the way your specific version of FF is handling these. You just never know with these browsers. Not ONE of them conforms 100% to W3C specs and so even 100% compliant JS code will behave differently. (I am not saying phpBB's code is 100% compliant as I have no idea whether their code is or not.)

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©