Xoops Horoscope Module *xoopsConfig[root_path]* File Inclusion

Posted on Wednesday, June 13, 2007 @ 19:43:35 PDT in Security
by Raven

SECUNIA ADVISORY ID: SA25651

VERIFY ADVISORY: http://secunia.com/advisories/25651/

CRITICAL: Highly critical

IMPACT: Exposure of system information, Exposure of sensitive information, System access

WHERE: >From remote

SOFTWARE: Horoscope 2.x (module for Xoops) - http://secunia.com/product/14526/

DESCRIPTION: BeyazKurt has discovered a vulnerability in the Horoscope module for Xoops, which can be exploited by malicious people to disclose sensitive information or to compromise a vulnerable system.

Input passed to the "xoopsConfig[root_path]" parameter in footer.php is not properly verified before being used to include files. This can be exploited to include arbitrary files from local or external resources. Successful exploitation requires that "register_globals" is enabled. The vulnerability is confirmed in version 2.00. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly verified.

PROVIDED AND/OR DISCOVERED BY: BeyazKurt

ORIGINAL ADVISORY: http://milw0rm.com/exploits/4064
 
 
click Related        click Share
 
News ©

Site Info v2.2.2

Last SeenLast Seen
Server TrafficServer Traffic
  • Total: 346,309,063
  • Today: 7,811
Server InfoServer Info
  • Jan 21, 2018
  • 04:16 am PST
 
 

Daily Inspiration