Ravens PHP Scripts

Google Chrome Multiple Vulnerabilities
Date: Friday, February 04, 2011 @ 18:20:58 PST
Topic: Security


SECUNIA ADVISORY ID: SA43193

VERIFY ADVISORY: Secunia.com: http://secunia.com/advisories/43193/

RELEASE DATE: 2011-02-04

CRITICALITY: Highly Critical

DESCRIPTION: Some weaknesses and vulnerabilities have been reported in Google Chrome, where some have an unknown impact and others can be exploited by malicious people to bypass certain security restrictions and potentially compromise a user's system




1) An error within the sandbox related to "stat()" can be exploited to leak certain information. Note: This only affects the Mac OS X version.
2) A use-after-free error exists within the image loading.
3) Some restrictions are not properly applied to cross-origin drag and drop operations.
4) An error exists related to "extensions with missing key", which can be exploited to cause a crash.
5) An error exists within the PDF event handler, which can be exploited to cause a crash.
6) An error exists within the merging of autofill profiles.
7) An error related to the Mac OS 10.5 SSL libraries can be exploited to cause a crash. Note: This only affects the Mac OS X version.
8) An error related to a bad volume setting can be exploited to cause a crash.
9) A race condition error exists within the audio handling.

SOLUTION: Fixed in version 9.0.597.84.

PROVIDED AND/OR DISCOVERED BY: The vendor credits:
1) Daniel Cheng
2, 5) Aki Helin, OUSPG
3) SkyLined of the Google Chrome Security Team and Michal Zalewski and David Bloom of the Google Security Team
4) Brian Kirchoff
6) Inferno, Google Chrome Security Team
7) Dan Morrison
8) Matthew Heidermann
9) various persons of the "Reddit!" community

ORIGINAL ADVISORY: http://googlechromereleases.blogspot.com/2011/02/stable-channel-update.html






This article comes from Ravens PHP Scripts
http://www.ravenphpscripts.com

The URL for this story is:
http://www.ravenphpscripts.com/modules.php?name=News&file=article&sid=3889