Ravens PHP Scripts

Nukedit *dbsite.mdb* Database Disclose Security Issue
Date: Wednesday, December 17, 2008 @ 15:17:36 CET
Topic: Security


SECUNIA ADVISORY ID: SA33165
VERIFY ADVISORY: http://secunia.com/advisories/33165/
CRITICAL: Moderately critical
IMPACT: Exposure of sensitive information
SOFTWARE: Nukedit 4.x - http://secunia.com/advisories/product/10231/

DESCRIPTION: Cyber.Zer0 has discovered a security issue in Nukedit, which can be exploited by malicious people to disclose sensitive information. This security issue is confirmed in version 4.9.8. Other versions may also be affected.



The security issue is caused due to the "dbsite.mdb" database being stored with insecure permissions inside the web root. This can be exploited to gain knowledge of sensitive information (e.g. user names and password hashes) by downloading the file.
SOLUTION: Move the database file out of the web root.
PROVIDED AND/OR DISCOVERED BY: Cyber.Zer0
ORIGINAL ADVISORY: http://milw0rm.com/exploits/7491






This article comes from Ravens PHP Scripts
http://www.ravenphpscripts.com

The URL for this story is:
http://www.ravenphpscripts.com/modules.php?name=News&file=article&sid=3511