Ravens PHP Scripts

Coppermine Photo Gallery Multiple Vulnerabilities
Date: Wednesday, January 30, 2008 @ 22:02:53 PST
Topic: Security


SECUNIA ADVISORY ID: SA28682

VERIFY ADVISORY: http://secunia.com/advisories/28682/

CRITICAL: Moderately critical

IMPACT: Cross Site Scripting, Manipulation of data, System access

SOFTWARE: Coppermine Photo Gallery 1.x - http://secunia.com/product/1427/

DESCRIPTION: Some vulnerabilities have been reported in Coppermine Photo Gallery, which can be exploited by malicious people to conduct cross-site scripting attacks and by malicious users to conduct SQL injection attacks or compromise a vulnerable system. Successful exploitation of the vulnerabilities requires valid user credentials.



1) Input passed to unspecified parameters in util.php and reviewcom.php is not properly sanitised before being used in SQL queries. This can be exploited to manipulate SQL queries by injecting arbitrary SQL commands.

2) Input passed to unspecified parameters in include/imageObjectIM.class.php is not properly sanitized before being used to execute commands. This can be exploited to execute arbitrary commands via shell escape characters contained within the affected parameters.

3) Input passed to the "h" and "t" parameters in docs/showdoc.php is not properly sanitized before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

SOLUTION: Update to version 1.4.15.

PROVIDED AND/OR DISCOVERED BY: The vendor credits Janek Vind.

ORIGINAL ADVISORY: http://coppermine-gallery.net/forum/index.php?topic=50103.0






This article comes from Ravens PHP Scripts
http://www.ravenphpscripts.com

The URL for this story is:
http://www.ravenphpscripts.com/modules.php?name=News&file=article&sid=3217