Ravens PHP Scripts

PHP-Nuke *lang* Local File Inclusion Vulnerability
Date: Monday, March 12, 2007 @ 13:42:47 PDT
Topic: Security


SECUNIA ADVISORY ID: SA24484

VERIFY ADVISORY: http://secunia.com/advisories/24484/

CRITICAL: Moderately critical

IMPACT: Exposure of system information, Exposure of sensitive information

WHERE: >From remote

SOFTWARE:
PHP-Nuke 7.x - http://secunia.com/product/2385/
PHP-Nuke 8.x - http://secunia.com/product/13524/

DESCRIPTION: Aleksandar has discovered a vulnerability in PHP-Nuke, which can be exploited by malicious people to disclose sensitive information.



Input passed in the "lang" cookie to index.php is not properly verified before being used to include files. This can be exploited to include arbitrary files from local resources. Successful exploitation requires that the system is running PHP 5 and that "magic_quotes_gpc" is disabled.

The vulnerability is confirmed in version 7.9 and reported in version 8.0. Other versions may also be affected.

SOLUTION:
Edit the source code to ensure that input is properly verified.
Set "magic_quotes_gpc" to On.
Use another product.

PROVIDED AND/OR DISCOVERED BY: Aleksandar a.k.a. sale83






This article comes from Ravens PHP Scripts
http://www.ravenphpscripts.com

The URL for this story is:
http://www.ravenphpscripts.com/modules.php?name=News&file=article&sid=2795