Ravens PHP Scripts

BBClone *BBC_LIB_PATH* File Inclusion Vulnerability
Date: Wednesday, January 24, 2007 @ 11:35:51 CET
Topic: Security


SECUNIA ADVISORY ID: SA23874

VERIFY ADVISORY: http://secunia.com/advisories/23874/

CRITICAL: Highly critical

IMPACT: Exposure of system information, Exposure of sensitive information, System access

SOFTWARE: BBClone 0.x - http://secunia.com/product/13310/

DESCRIPTION: A vulnerability has been discovered in BBClone, which can be exploited by malicious people to disclose sensitive information and potentially compromise vulnerable systems.


Input passed to the "BBC_LIB_PATH" parameter in lib/selectlang.php is not properly verified before being used to include files. This can be exploited to include arbitrary files from local resources and potentially also from external resources. Successful exploitation requires that "register_globals" is enabled and that "magic_quotes_gpc" is disabled. The vulnerability is confirmed in version 0.4.9. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly verified.

PROVIDED AND/OR DISCOVERED BY: Dr Max Virus

ORIGINAL ADVISORY: http://www.milw0rm.com/exploits/3183






This article comes from Ravens PHP Scripts
http://www.ravenphpscripts.com

The URL for this story is:
http://www.ravenphpscripts.com/modules.php?name=News&file=article&sid=2681